Le périphérique d'entrée audio (microphone) ne fonctionne pas

34

J'ai récemment mis à jour mon système d’ordinateur portable d’Ubuntu 12.04 à 14.04

Après la mise à jour du système d'exploitation, le périphérique de saisie de mon ordinateur portable, par exemple, le microphone ne fonctionne pas.

Auparavant, il travaillait avec Ubuntu 12.04.

Il n’ya pas non plus de pilote de périphérique d’entrée audio détecté

J'utilise Dell Vostro 1014.

après avoir exécuté la commande $ gstreamer-properties , la sortie est la suivante:

Je pense que mon microphone fonctionne mais n'est pas perçu par Ubuntu comme sur la capture d'écran ci-dessus.

Mais après avoir exécuté le contrôle du son par impulsions audio, il affiche la progression du son d’entrée, cela signifie que le périphérique d’entrée fonctionne mais n’est pas détecté. Même par enregistreur audio.

Après avoir exécuté alsamixer , la sortie est la suivante:

    
posée Anuj TBE 07.08.2014 - 19:08
la source

10 réponses

29

J'ai eu un problème similaire - aucun pilote de périphérique d'entrée audio n'a été détecté. J'ai utilisé pavucontrol, comme expliqué dans ici et cela a résolu le problème:

  • Installer pavucontrol: sudo apt-get install pavucontrol
  • Exécuter: sudo pavucontrol
  • Allez dans l'onglet "Périphériques d'entrée"
  • Cliquez sur l’icône de verrouillage pour déverrouiller les canaux
  • Sous "Port", sélectionnez le bon microphone (avant ou arrière)
réponse donnée Erel Segal-Halevi 21.12.2015 - 09:03
la source
7

essayez ceci dans le terminal pour aucun son:

sudo alsa force-reload

redémarrer le périphérique et vérifier si le son fonctionne correctement?

si ce n'est pas le cas:

sudo apt-get remove --purge alsa-base pulseaudio

sudo apt-get install alsa-base pulseaudio

Redémarrez le périphérique et vérifiez ..Cela devrait probablement faire le travail!

    
réponse donnée Tejas Ghalsasi 07.08.2014 - 19:37
la source
4

eu le même problème. Résolu comme ça:

  • Exécutez pavucontrol depuis la fenêtre du terminal.
  • Vérifiez le niveau du microphone et désactivez le commutateur dans l'onglet Périphériques d'entrée .
  • Onglet Ouvrir Enregistrement .
  • En parallèle, lancez la fonction d'enregistrement dans l'application souhaitée. Par exemple. Appuyez sur record dans Audacity ou lancez un appel test dans Skype.
  • Dans l'onglet Enregistrement de pavucontrol , une sélection de source est désormais disponible. Sélectionnez le bon. Travaillé pour moi.

Pour moi, il est (était) déroutant que le sélecteur de source ne soit pas toujours présent dans pavucontrol .

    
réponse donnée oscar1919 17.01.2017 - 20:13
la source
2

Ouvrez un terminal et lancez la commande alsamixer vous obtiendrez un écran comme celui-ci:

utilisez la flèche droite pour mettre en surbrillance le microphone avant

si le son est coupé comme indiqué ci-dessus, appuyez sur la touche "M" pour désactiver la sourdine.

utilisez ensuite la flèche vers le haut pour augmenter le gain (sensibilité) que votre résultat final doit ressembler à ceci. Appuyez sur la touche Esc pour quitter. Votre microphone devrait maintenant fonctionner comme annoncé.

    
réponse donnée Sergei 21.08.2014 - 16:37
la source
0

Ce qui suit pourrait fonctionner pour vous:

  1. Exécutez gksudo gedit /etc/modprobe.d/alsa-base.conf sur le terminal (si vous n'avez pas accès à une interface graphique dans le moment, utilisez sudo nano au lieu de gksudo gedit .
  2. Ajoutez options snd-hda-intel position_fix=1 ou position_fix=2 à la fin du fichier.
  3. Redémarrer

Les sources: lien et lien

    
réponse donnée Waldir Leoncio 05.04.2015 - 15:50
la source
0

J'ai eu le même problème. J'ai trouvé la solution après la mise à niveau vers 16.04, mais je pense que cela fonctionne aussi avec 14.04! Dans Skype, cliquez sur "Ouvrir PulseAudio Volume Control". À partir de là, passez à "Périphériques d'entrée" et modifiez le port. Par miracle, mon microphone a commencé à fonctionner après avoir changé mon port pour "Microphone (unplugged)". Bonne chance!

    
réponse donnée kodujuust 09.08.2016 - 22:53
la source
0
sudo nano /etc/modprobe.d/alsa-base.conf

ajoutez cette ligne:

options snd-hda-intel index=0 model=laptop-dmic
    
réponse donnée Haendler 19.06.2017 - 10:11
la source
0

Pour moi, tout semblait correct, le périphérique d’entrée était correctement sélectionné, mais je ne pouvais pas utiliser le micro interne ou externe. Je l'ai résolu en activant la webcam en utilisant les touches Fn . Apparemment, ils sont activés et désactivés par la même clé Fn .

    
réponse donnée Waqleh 04.07.2017 - 10:09
la source
0

Goto contrôle de volume PulseAudio - & gt; Configuration, choisissez "Duplex analogique stéréo" dans la section Profil.

Redémarrez votre machine.

* Essayé dans Ubuntu 16.04 LTS

    
réponse donnée N.Sinha 20.09.2017 - 07:29
la source
-1

J'ai eu un problème similaire le 14.04, la source d’entrée audio était vide dans les "Paramètres audio". J'ai fait ce qui suit: qu'est-ce que l'astuce a été d'installer 'Audacity', pour plus d'informations, consultez le lien

suivant
sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio
sudo apt-get install audacity
    
réponse donnée Swift Guy 27.01.2015 - 16:51
la source

Lire d'autres questions sur les étiquettes