Modifier l'éditeur de crontab par défaut

104

J'essaie de changer l'éditeur par défaut de nano à vim .

J'ai exécuté les commandes suivantes:

sudo update-alternatives --config editor

et

update-alternatives --config editor

Les deux sorties maintenant:

  Selection    Path                Priority   Status
------------------------------------------------------------
  0            /bin/nano            40        auto mode
  1            /bin/ed             -100       manual mode
  2            /bin/nano            40        manual mode
* 3            /usr/bin/vim.basic   30        manual mode
  4            /usr/bin/vim.tiny    10        manual mode

J'ai redémarré ma session ssh et redémarré sshd mais crontab -e s'ouvre toujours dans nano

Que dois-je faire d'autre?

    
posée austinbv 29.07.2011 - 20:15
la source

8 réponses

94

Essayez votre session ssh suivie de

export EDITOR=vim

ou éventuellement

export EDITOR=/usr/bin/vim.basic

Le format de réglage de la variable EDITOR dépend du shell que vous utilisez.

Dans Ubuntu, vous pouvez définir la variable d’environnement EDITOR lors de la connexion en ajoutant ce qui précède à ~/.profile

Votre session SSH lira un fichier similaire (s’il existe) sur l’hôte distant appelé ~/.ssh/environment . Cela doit être spécifiquement défini par la configuration du démon ssh. Voir man sshd_config et recherchez PermitUserEnvironment pour plus de détails.

    
réponse donnée fossfreedom 29.07.2011 - 20:29
la source
162

Il suffit de lancer select-editor , cela vous permettra de choisir l’éditeur de votre choix.

    
réponse donnée Mostafa Shahverdy 06.03.2013 - 15:19
la source
21

Ma préférence personnelle ...

cd /bin
mv nano nano_must_die
ln -s /usr/bin/vim nano
    
réponse donnée Dave 08.01.2014 - 00:39
la source
12

De "man crontab":

   The -e option is used to edit the  current  crontab  using  the  editor
   specified  by  the  VISUAL  or EDITOR environment variables.  After you
   exit from the editor, the modified crontab will be installed  automati‐
   cally.  If  neither  of  the environment variables is defined, then the
   default editor /usr/bin/editor is used.

Vous avez peut-être la variable d'enivronment EDITOR définie sur nano?

    
réponse donnée aureianimus 29.07.2011 - 20:28
la source
9

Sur mon ordinateur Ubuntu 12.04, crontab utilise le fichier ~/.selected_editor , qui contient le chemin de l'éditeur sélectionné. Modifiez-le:

nano ~/.selected_editor

Je l'ai édité directement ou utilisé select-editor , qui est un script pour faire la même chose. Modifiez la ligne suivante:

SELECTED_EDITOR="/usr/bin/vim.basic" 

Les gens d’IHMO ne devraient rien changer dans / etc ou / bin pour ce faire. C'est une chose au niveau de l'utilisateur, pas une tâche à l'échelle du système.

    
réponse donnée NormanD 05.01.2016 - 03:37
la source
6

Si vous voulez seulement choisir l'éditeur temporairement, vous pouvez faire ce qui suit

EDITOR=nano crontab -e

Ceci définit la variable d'environnement EDITOR pour la commande

    
réponse donnée Luke Madhanga 08.02.2017 - 12:07
la source
2

J'avais des difficultés avec select-editor et update-alternatives , ma solution était simplement de modifier le lien:

  1. sudo rm /etc/alternatives/editor
  2. sudo ln -s /usr/bin/vim /etc/alternatives/editor

editor ouvre maintenant Vim

    
réponse donnée Dennis Bellinger 16.05.2014 - 17:31
la source
1

J'ai eu le même problème - crontab -e repose sur select-editor, visudo s'appuie sur la configuration de "alternatives"

Ma solution:

exécutez les deux commandes en tant que root

# update-alternatives --install /usr/bin/editor editor /usr/bin/sensible-editor 50

# select-editor 

Select an editor.  To change later, run 'select-editor'.
  1. /bin/nano        <---- easiest
  2. /usr/bin/sensible-editor
  3. /usr/bin/vim.basic
  4. /usr/bin/vim.tiny

Choose 1-4 [1]: 3
    
réponse donnée julian 12.07.2017 - 16:43
la source

Lire d'autres questions sur les étiquettes