Clock affiche l'heure incorrecte après le passage d'Ubuntu à Windows 10 [dupliquer]

53

J'ai double-amorcé Windows 10 et Ubuntu 16.04 en mode UEFI (démarrage sécurisé). Mon temps dans le BIOS est correct.

Lorsque je démarre dans Ubuntu et que je démarre Windows 10, l’heure est incorrecte. Je dois le corriger manuellement ou par Internet sous Windows 10, et lorsque je redémarre sous Windows 10, cela ne pose aucun problème. L'horloge indiquera l'heure correcte. Et puis, lorsque je redémarre sous Linux, l’horloge est correcte, mais le retour à Windows 10 fait de nouveau l’horloge.

    
posée Brij Raj Kishore 20.07.2016 - 18:06
la source

1 réponse

57

Conflits de temps entre plusieurs systèmes de démarrage

  

Les systèmes d'exploitation stockent et récupèrent l'heure dans l'horloge matérielle   situé sur votre carte mère afin qu'il puisse garder une trace du temps même   lorsque le système n'est pas alimenté. La plupart des systèmes d'exploitation   (Linux / Unix / Mac) stocke l’heure sur l’horloge matérielle sous UTC par   par défaut, bien que certains systèmes (notamment Microsoft Windows) stockent le   l'heure sur l'horloge matérielle en tant que heure locale . Cela pose des problèmes   dans un système à double amorçage si les deux systèmes visualisent l'horloge matérielle   différemment.

     

L'avantage d'avoir l'horloge matérielle comme UTC est que vous ne faites pas   besoin de changer l'horloge matérielle lors du déplacement entre les fuseaux horaires ou   lorsque l'heure d'été commence ou se termine lorsque l'UTC n'a pas   DST ou décalages horaires.

     

Changer Linux pour utiliser l'heure locale est plus facile et plus fiable que   changer Windows pour utiliser l’UTC, les systèmes Linux / Windows à double amorçage   utiliser l'heure locale.

     

Depuis Intrepid (8.10), UTC = yes est la valeur par défaut.

     

Solution 1: faire en sorte que Windows utilise UTC

     

Remarque : cette méthode n’était pas initialement prise en charge sous Windows Vista et   Server 2008, mais est revenu avec Vista SP2, Windows 7, Server 2008 R2   et Windows 8 / 8.1.

     

Pour que MS Windows calcule l’heure à partir de l’horloge matérielle comme UTC.

     

Créez un fichier nommé WindowsTimeFixUTC.reg avec le contenu suivant   puis double-cliquez dessus pour fusionner le contenu avec le registre:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
 "RealTimeIsUniversal"=dword:00000001
     

Remarque : le service de temps Windows écrit toujours l'heure locale sur le RTC   quel que soit le paramètre de registre ci-dessus à l'arrêt, il est donc pratique   pour désactiver le service de temps Windows avec cette commande (si la synchronisation de l’heure est   encore requis dans Windows utiliser une synchronisation de temps tiers   solution):

sc config w32time start= disabled
     

Inverser le changement

     

Vous pouvez créer un fichier avec le contenu suivant, puis   double-cliquez dessus pour fusionner les modifications d'origine, comme ci-dessus:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
 "RealTimeIsUniversal"=-
     

Si le service de temps Windows était désactivé, activez-le à nouveau avec le   commande:

sc config w32time start= demand
     

Solution 2: Faites en sorte que Linux utilise le temps "Local"

     

Pour indiquer à votre système Ubuntu que l’horloge matérielle est définie sur «local»   temps:

     

Systèmes pré-Ubuntu 15.04 (par exemple, Ubuntu 14.04 LTS):

     
  1. éditez / etc / default / rcS
  2.   
  3. ajoutez ou modifiez la section suivante

    # Set UTC=yes if your hardware clock is set to UTC (GMT)
    UTC=no
    
  4.   

Systèmes Ubuntu 15.04 et supérieurs (par exemple, Ubuntu 16.04 LTS):

     
  1. ouvrez un terminal et exécutez la commande suivante

    timedatectl set-local-rtc 1
    
  2.   

source: Aide d'Ubuntu

    
réponse donnée Ceda EI 20.07.2016 - 20:32
la source

Lire d'autres questions sur les étiquettes