Comment puis-je mettre à jour le noyau Ubuntu LTS?

40

Je viens d'installer Ubuntu 12.04.2 64 bits sur mon PC de bureau et je vois le noyau dans System Monitor 3.5.0-23 mais dans Ubuntu 12.04.2 sur mon portable, le noyau est 3.2.0-38. / p>

J'ai déjà essayé d’exécuter la commande sudo apt-get upgrade && sudo apt-get dist-upgrade sur mon ordinateur portable, mais il ne met pas à jour le noyau.

Comment puis-je mettre à jour le noyau pour mon ordinateur portable?

    
posée TinyTux 18.02.2013 - 06:56
la source

5 réponses

36

Les nouveaux déploiements de 12.04.2 seront installés avec un noyau mis à jour et une nouvelle pile X windows. Pour les déploiements 12.04 existants, les utilisateurs devront accepter ce qui est appelé la pile d'activation matérielle LTS . . Si vous avez déjà installé Ubuntu 12.04 avec une pile de noyau antérieure, il est recommandé de conserver cette pile plutôt que de passer à un noyau ultérieur. les nouvelles piles de noyau et X sont fournies pour l'activation du matériel non pris en charge par les noyaux antérieurs, et il n'y a généralement aucune raison de mettre à niveau une nouvelle pile si votre matériel est pris en charge par le noyau par défaut.

Pour mettre à jour le noyau 3.5 sur 12.04.2, vous devrez exécuter les commandes suivantes:

Pour le nouveau noyau:

sudo apt-get install linux-generic-lts-quantal

Pour la nouvelle pile X:

sudo apt-get install xserver-xorg-lts-quantal

AVERTISSEMENT: si vous utilisez le PPA xorg-edgers, n'installez pas le package xserver-xorg-lts-quantal, car cela entraînerait très probablement une rupture.

Référence: lien

Ceci est uniquement recommandé pour les installations matérielles x86.

Voir aussi:

réponse donnée Kevin Bowen 18.02.2013 - 07:13
la source
6

Le jeu d'instructions le plus simple que j'ai toujours utilisé pour la mise à niveau / la mise à niveau du noyau est celui de l'utilisateur ubuntuforums.org sous le nom de lykwydchykyn (URL modifié par moi pour ce post):

Allez ici: lien Téléchargez 3 (peut-être 4) debs dans un dossier quelque part:

linux-headers-VERSION-NUMBER_all.deb
linux-headers-VERSION-NUMBER_amd64.deb
linux-image-VERSION-NUMBER_amd64.deb
linux-image-extra-VERSION-NUMBER_amd64.deb   # if available

Installez les debs avec le gestionnaire de paquets que vous utilisez (est-ce que gdebi est toujours là?), ou utilisez ces commandes:

cd /path/to/folder/where/you/put/the/debs
sudo dpkg -i *.deb

Source: lien et lien

    
réponse donnée codefreak 18.02.2013 - 07:14
la source
2

Bien sûr, vous pouvez installer les noyaux 3.5.0, exécutez apt-get install linux-image-generic-lts-quantal pour installer le dernier noyau quantal 3.5.0. Ce paquet fera en sorte que vous ayez toujours le dernier noyau quantique.

Personnellement, je recommande de toute façon le noyau 3.8 (base sur amont 3.8.8) de raring.

REMARQUE: recherchez les noyaux 3.5.0 disponibles apt-cache search linux-image-3.5.0 .

BTW: Vous pouvez même télécharger manuellement les derniers noyaux principaux et les installer, par exemple 3.7.9. Toutefois, si vous installez les noyaux principaux PPA manuellement, vous devrez installer manuellement les mises à jour.

lien

    
réponse donnée Terry Wang 18.02.2013 - 07:05
la source
1

Depuis 14.04.3, vous devez installer plus de paquets sur un bureau pour obtenir toutes les dépendances triées:

Cela installe le nouveau noyau, comme auparavant, et est suffisant sur un serveur de type CLI uniquement:

sudo apt-get install linux-generic-lts-vivid

Mais avec le serveur X, vous avez besoin d’un tas de paquets que ces deux derniers recommandent:

sudo apt-get install --install-recommends xserver-xorg-lts-vivid libwayland-egl1-mesa-lts-vivid
    
réponse donnée otus 08.08.2015 - 09:19
la source
0

Pour le nouveau noyau disponible pour 12.04:

sudo apt-get install linux-image-generic-lts-saucy

Pour la pile X la plus récente disponible pour la version 12.04:

sudo apt-get install xserver-xorg-lts-raring
    
réponse donnée Hendy Irawan 30.12.2013 - 13:23
la source

Lire d'autres questions sur les étiquettes