Wifi ne fonctionne pas après la suspension après 16.04 mise à niveau

133

Cette version particulière de "ne fonctionne pas après suspension" est apparue après la mise à niveau vers 16.04. Il semble que la mise à niveau inclue une applet Wicd (ajoutée à la barre des tâches Metacity Classic Gnome avec une icône réseau normale), mais ne semble pas fonctionner après une suspension. Un sudo service network-manager restart duplique ce problème. Il faut un redémarrage complet pour que le Wifi recommence. Des idées pourquoi?

    
posée 147pm 23.04.2016 - 13:42
la source

11 réponses

160

16.04 s'exécute sur systemd. Essayez ce qui suit:

sudo systemctl restart network-manager.service

Si cela fonctionne, vous pouvez créer un script pour l’automatiser.

Ouvrez un terminal et tapez ce qui suit:

sudo nano /etc/systemd/system/wifi-resume.service Collez maintenant le script avec un clic droit. Quittez avec CTRL + X et appuyez sur Y pour enregistrer. Maintenant, pour l'activer: sudo systemctl enable wifi-resume.service

Script:

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

J'espère que ça aide. Cela fonctionne sur mon ordinateur portable.

    
réponse donnée Joakim Koed 23.04.2016 - 15:17
la source
13

Même chose avec un Lenovo X230. Ne se produit pas après chaque suspension, mais parfois.

sudo systemctl restart network-manager.service 

corrige le problème.

    
réponse donnée Martin 24.04.2016 - 15:29
la source
8

@ 147pm Avez-vous déjà eu ce travail?

J'ai constaté que j'avais un problème assez similaire, même si je suis sur Kubuntu 16.10 (basé sur KDE, pas sur Gnome), et sur un ordinateur portable HP ProBook. Et, contrairement à vous, ce n’est pas mon Wifi qui est mort après la suspension / réveil, mais mon port Ethernet. Pourtant, je me demande s'ils sont liés.

Je vois aussi que vous n'avez pas le problème sous KDE. Mais je serais intéressé de savoir si la solution ci-dessous aide sous Gnome, car la solution ne repose pas sur un gestionnaire de fenêtres, un environnement de bureau ou des applets.

Tout d’abord, confirmez simplement le redémarrage du service du gestionnaire de réseau.

$ sudo systemctl restart network-manager.service

n'a pas fonctionné pour moi.

Cependant, j'ai trouvé une réponse qui a fonctionné, grâce à la question de buzhidao et aux infos sur ne peut pas se connecter à Internet après la suspension et le commentaire de GAD3R à cet endroit.

En utilisant leurs informations, j'ai trouvé que la première recherche sur le matériel Ethernet, le pilote / module que j'exécutais, puis sur la suppression et la réinstallation de ce module, a fonctionné pour moi (mais pas pour buzhidao):

Wifi:

$ lspci -knn | grep Net -A2

Ethernet:

$ lspci -knn | grep Ether -A2

Le deuxième (ethernet) était ce que j'ai utilisé, et j'ai trouvé:

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c)
        Subsystem: Hewlett-Packard Company RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [103c:1944]
        Kernel driver in use: r8169
        Kernel modules: r8169

J'ai donc réinstallé le pilote 'r8169':

$ sudo rmmod r8169 && sudo modprobe r8169

et le tour est joué! Cela a fonctionné. Mon port / connexion Ethernet est revenu (après suspension / réveil) sans avoir à redémarrer.

(Je n’avais pas non plus de périphérique Realtek, mais un Atheros Qualcomm (mod: ath9k), ce qui explique peut-être pourquoi le wifi a continué à fonctionner après le wake-from-suspend.)

Comme vous pouvez le constater à partir de mon commentaire sur cet autre article, je me suis demandé si le problème était l’élément commun entre Buzhidao et moi-même: les dispositifs Realtek Semiconductor. Même s'ils utilisent des modules différents, ils peuvent partager un code commun? Ou même être traité différemment par le nouveau code du noyau maintenant?

Avez-vous un périphérique wifi basé sur Realtek? (en utilisant lspci ci-dessus)? Avez-vous de la chance de réinstaller le module (rmmod / modprobe ci-dessus)?

Quoi qu’il en soit, juste un coup dans le noir. Si vous avez trouvé une réponse éventuelle pour vous, faites-le nous savoir! Thx.

    
réponse donnée androclus 16.03.2017 - 23:40
la source
6

Pour redémarrer automatiquement NetworkManager après la reprise dans un environnement sans sudo access, créez un script dans /etc/pm/sleep.d (n'importe quel nom), définissez le bit exécutable via chmod +x et insérez le contenu suivant:

case "" in
    resume|thaw)
        # systemctl restart network-manager.service
        service NetworkManager restart
;;
esac

Pour moi, la ligne service a fonctionné, mais systemctl peut mieux fonctionner pour vous.

Source: lien .

    
réponse donnée krlmlr 05.11.2016 - 08:50
la source
2

Pour moi, cela semble être aléatoire, mais parfois le wifi se déconnecte simplement si je suis connecté ou ne montre pas les réseaux si je ne le suis pas. Parfois, mettre mon ordinateur en mode veille semble le déclencher, mais pas toujours.

Une combinaison de ceux-ci est généralement utilisée sans redémarrage:

  • sudo iwlist $(ifconfig | grep -Po '^w\w+') scan
  • sudo service network-manager stop; sleep 5; sudo service network-manager start
    • Le simple fait d'appeler restart ici ne semble jamais fonctionner pour moi. Il semble qu’il essaie de le démarrer avant qu’il ait fini de l’éteindre, c’est pourquoi j’ai plus de chance de faire une pause entre stop et start .
  • Désactivez le wifi dans l'interface utilisateur; attendez quelques secondes le rallumer

Aucun de ceux-ci ne semble fonctionner de manière cohérente, mais je les ai listés dans l'ordre des plus susceptibles de réussir en premier.

    
réponse donnée redbmk 20.12.2016 - 17:07
la source
2

Méthode de travail sur Ubuntu 16.04:

Créer le service: sudo nano /lib/systemd/system/wifi-resume.service

Le service appelle le programme depuis:
/etc/init.d/network-manager

Collez le code:

#/lib/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart network-manager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target 

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Activez ensuite le service:

sudo systemctl enable /lib/systemd/system/wifi-resume.service

Cela crée les liens symboliques dans les répertoires [Install] indiqués de / etc / systemd / system et active le service

Ensuite, vous pouvez vérifier le statut avec: systemctl status wifi-resume.service

    
réponse donnée cryptoboy 23.01.2017 - 01:59
la source
1

J'ai eu le même problème avec Bluetooth: après la suspension, ma souris bluetooth ne fonctionnait pas. J'ai donc trouvé la solution ci-dessus:

sudo nano /etc/systemd/system/bluetooth-resume.service

activé le nouveau service

sudo systemctl enable bluetooth-resume.service

et édité le service

#/etc/systemd/system/bluetooth-resume.service
#sudo systemctl enable bluetooth-resume.service
[Unit]
Description=Restart bluethooth at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart bluetooth.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

J'ai aussi essayé de modifier ...

sudo nano /etc/bluetooth/main.conf

et changé

AutoEnable=true

MAIS cela n'a pas fonctionné pour le "problème de reprise" et n'avait de toute façon aucun impact sur les nouveaux périphériques Bluetooth!

    
réponse donnée apos 31.08.2016 - 13:11
la source
1

J'ai eu le même problème sur mon ordinateur portable Dell Inspiron 15R avec Ubuntu 16.04. Pour moi, le script indiqué dans la deuxième réponse .

Après avoir installé le script, j'ai essayé la suspension avec la commande dans le menu en haut à droite et même en fermant la lèvre pour résoudre le problème.

Je dois dire que le problème alternait dans son comportement (c’est-à-dire qu’il fonctionnait parfois avant d’installer le script).

    
réponse donnée Alessandro D'lncal 18.01.2017 - 15:58
la source
0

Pour moi, la solution était de courir

nmcli nm sleep false

dans un terminal

    
réponse donnée tigerjack89 08.04.2017 - 13:01
la source
0

J'ai eu le même problème en me connectant à mon wifi domestique après la suspension. Essayé les diverses autres réponses suggérées qui fonctionneraient parfois mais pas toujours.

Finalement, le correctif suivant permettait de se connecter systématiquement au wifi:

1) Éditez ce fichier:

sudo vim /etc/NetworkManager/NetworkManager.conf

2) En y ajoutant ceci:

[device]
wifi.scan-rand-mac-address=no
    
réponse donnée Ray Vega 28.03.2018 - 08:09
la source
0

Maintenant probablement simple

sudo apt update
sudo apt upgrade

devrait fonctionner.

Dans mon cas, parmi les packages mis à niveau, il y avait bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.3) et après cette mise à jour, le wifi fonctionne à nouveau.

    
réponse donnée Daniel 05.08.2018 - 07:08
la source

Lire d'autres questions sur les étiquettes