Comment configurer le chrome pour ouvrir les URL d'aimant avec déluge?

36

Après la mise à niveau vers Ubuntu 11.04 (natty) à partir de 10.10, je ne peux plus ouvrir les liens magnétiques (torrent) dans Chrome, et définir deluge pour ouvrir et accepter automatiquement l’URL.

(Edit: actuellement les fichiers ".torrent" ne posent pas de problème, mais les URL des magnets , par exemple du formulaire " magnet:? xt = urn: ... ", sont maintenant le seul problème. Vous ne savez pas si quelque chose a été mis à jour ...?)

Au lieu de cela, la transmission uniquement ouvrira automatiquement torrents , les liens magnétiques, etc. Il ne semble pas y avoir de moyen de définir deluge comme client torrent par défaut . (Et il ne semble pas non plus y avoir de paramètre "application par défaut" pour que le client bittorrent remplace la transmission par un déluge.)

Notes:

  • J'ai trouvé d'anciens threads sur ce problème, et seulement un un ou tw de nouvelles versions. Les nouveaux threads semblent suggérer que xdg-open est à blâmer. Mais peu de gens semblent se heurter à ce problème, alors ... c'est peut-être juste moi?
  • Ne pas utiliser Firefox, définir manuellement les applications pour les types MIME ou les extensions ne fonctionne pas (ce n’est pas une option dans chrome / chrome, vous devez vous fier au système d’exploitation)
  • J'ai désinstallé la transmission, puis rien ne s’est passé en cliquant sur les liens torrent / magnet.
  • l'exécution à partir du shell ouvre également la transmission (pas le déluge): xdg-open "magnet:? xt = urn: bt .. & amp; tr = http: //tracker.....com/announce"

Mes gestionnaires d’URL actuels sont:

$ gconftool -a /desktop/gnome/url-handlers/magnet
command = deluge "%s"
needs_terminal = false
enabled = true

Le seul travail que j'ai (qui fonctionne) est de renommer /usr/bin/transmission-gtk{,.bak} et de créer mon propre / usr / bin / transmission-gtk:

$ cat /usr/bin/transmission-gtk
#!/bin/bash
deluge "[email protected]"

Quelqu'un d'autre a-t-il rencontré un bogue, une solution de contournement ou ...?

    
posée michael 24.05.2011 - 09:44
la source

16 réponses

17

La réponse est en fait un bogue dans le paquetage déluge (ou peut-être que le déluge est le même & tout le reste a changé autour de vous… je suppose.) Voir le sujet du forum ici pour les détails.

Fondamentalement, la configuration de la configuration de xdg-open via gconf-editor n'a rien fait pour résoudre le problème, car depuis Natty, la fonctionnalité d'ouverture de fichier est gérée par gvfs-open, qui n'utilise pas les paramètres gconf. Au lieu de cela, gvfs-open examine les fichiers ".desktop" fournis avec chaque application pour déterminer quels types de fichiers peuvent être gérés (s'ils ne sont pas installés, exécutez sudo apt-get install gvfs-bin ).

Sur le post du forum, le fichier /usr/share/applications/deluge.desktop comporte quelques problèmes; il devrait indiquer Exec=deluge-gtk %U (plutôt que simplement " Exec=deluge-gtk" ) pour que l'argument soit transmis à l'application. Deuxièmement, plutôt que simplement MimeType=application/x-bittorrent; , il devrait indiquer MimeType=application/x-bittorrent;x-scheme-handler/magnet; .

La mise à jour devrait arriver bientôt ... Voici le lien vers la fichier de bureau mis à jour si vous souhaitez effectuer le changement vous-même; il suffit de lancer sudo update-desktop-database et tout commence à fonctionner (il n'est même pas nécessaire de redémarrer chrome / chrome).

    
réponse donnée michael 30.05.2011 - 11:16
la source
31

Pour 12.04 et plus

Dans 12.04 et 13.04, deluge fait inclus x-scheme-handler/magnet=deluge.desktop; dans le fichier de bureau. Dans mon cas, la transmission ouvrait toujours des liens magnétiques. J'ai dû dire à gvfs-open de préférer le déluge avec:

gvfs-mime --set x-scheme-handler/magnet deluge.desktop

    
réponse donnée andrewsomething 10.03.2012 - 05:34
la source
7

Ubuntu

Récemment, il est également nécessaire d’ajouter la ligne suivante à ~ / .local / share / applications / mimeapps.list sous [Associations ajoutées]

x-scheme-handler/magnet=deluge.desktop;

Kubuntu

Sur Kubuntu cependant, vous devez créer le fichier suivant dans ~ / .kde / share / kde4 / services / magnet.protocol

[Protocol]
exec=deluge "%u"
protocol=magnet
input=none
output=none
helper=true
listing=false
reading=false
writing=false
makedir=false
deleting=false

Remarque: N'oubliez pas de reloger après ces modifications.

    
réponse donnée user163365 28.09.2011 - 21:36
la source
4

J'utilise Ubuntu 13.04, et après avoir installé Deluge, il ne me reste plus qu'à exécuter cette commande pour que Chromium utilise Deluge pour ouvrir des aimants:

xdg-mime default deluge.desktop x-scheme-handler/magnet

J'espère que ça aide:)

    
réponse donnée jelies 04.06.2013 - 00:09
la source
3

J'ai fait tout ça et ça n'a pas marché.

Après avoir essayé tout ce que j’ai vu, j’ai enfin réussi à ouvrir les liens magnétiques en deluge , non seulement en changeant

MimeType=application/x-bittorrent;

à

MimeType=application/x-bittorrent;x-scheme-handler/magnet;

dans /usr/share/applications/deluge.desktop , mais aussi en supprimant

x-scheme-handler/magnet;

de /usr/share/applications/transmission-gtk.desktop avant de lancer

sudo update-desktop-database
    
réponse donnée simon 28.01.2012 - 16:23
la source
2

C'était censé être un commentaire, mais je devais télécharger une photo, alors la voici:

  • Dans ma configuration, FireFox 3.6 et Chromium 11.0 ont tous deux ouvert Deluge

  • Chromium a demandé une confirmation qui nous donne une idée de ce qui se passe:

Cela montre que Chromium ne lance PAS Deluge directement ... il s'appuie sur xdg-open pour cela. Ce qui signifie que tout ce qui doit être recherché (et corrigé) est le système d'exploitation, pas le chrome. Rien à réparer ou à modifier dans le navigateur.

Ce n’est pas une réponse, mais cela concentrera vos efforts au bon endroit. Ce que vous devez réparer n’a rien à voir avec le navigateur, mais avec le système d’exploitation.

    
réponse donnée MestreLion 30.05.2011 - 11:18
la source
2

Téléchargez et installez ce script utilisateur . Maintenant, vous devriez pouvoir ajouter rapidement des fichiers torrent à Deluge 1.2+ WebUI dans Chrome!

Testé le 11.10. Pour les autres systèmes d'exploitation, vous devez essayer vous-même, mais je pense que cela fonctionnera très bien pour eux aussi.

    
réponse donnée Espen Lossius 17.02.2012 - 19:52
la source
1

Sur Ubuntu 10.04 avec Deluge et chrome, je devais faire:

gconftool -t string -s /desktop/gnome/url-handlers/magnet/command "deluge-gtk '%s'"
    
réponse donnée jpgunter 12.02.2012 - 02:24
la source
1

Je suis le 10.10, j'ai essayé un tas de choses, c'est ce qui a fonctionné:

gconftool-2 -t string -s /desktop/gnome/url-handlers/magnet/command "/usr/bin/deluge-gtk %s"
gconftool-2 -s /desktop/gnome/url-handlers/magnet/needs_terminal false -t bool
gconftool-2 -t bool -s /desktop/gnome/url-handlers/magnet/enabled true
    
réponse donnée IndigoSunrise 29.02.2012 - 08:58
la source
1

Je ne pense pas que cela résout vraiment le problème, mais au moins cela fonctionne pour moi (lubuntu 12.04):

  • Passez votre souris sur le lien de l’aimant jusqu’à ce que l’adresse de l’aimant soit affichée en bas de votre écran.
  • Cliquez avec le bouton droit de la souris et sélectionnez "Copier l'adresse du lien".
  • Ouvrez Transmission et sous "Fichier", sélectionnez "Ouvrir URL".
  • Collez l'URL dans la boîte et commencez à télécharger.

Au fait, je crains que je nécropose un peu maintenant, mais les solutions ci-dessus n'ont pas fonctionné pour moi et ma réponse pourrait être utile pour d'autres, puisque cette page était le premier résultat lorsque j'ai cherché dans ce numéro Google.

    
réponse donnée theFlyingDutchman 06.07.2013 - 00:48
la source
1

Dans Linux Mint 16 Petra, je devais modifier le fichier Transmissions.desktop dans le dossier des applications, mais aussi dans /usr/share/applications/mimeinfo.cache, plutôt que mimeapps.list

De plus, il existe un autre fichier mimeinfo.cache dans /home/[user]/.local/share/applications qui peut également être modifié, mais je suppose que cela n'affecterait que l'utilisateur actuel, où Le dossier des applications affecte tous les utilisateurs.

J'espère que ça aide.

EDIT:

Haa, il semble que cette fonctionnalité a été intégrée dans les dernières versions de Deluge. Vous pouvez aller à Edit - & gt; Préférences - & gt; Autre - & gt; et associer des liens magnétiques par défaut avec Deluge.

    
réponse donnée Jake Mitchell 02.05.2014 - 23:07
la source
0

Il semble que maintenant les dernières versions ( ppa ) de Deluge aient bien répondu aux points de la sélection. répondre. Cependant, cela n’a pas résolu mon problème avec Google Chrome qui n’a pas lancé Torrents dans mon Ubuntu Precise 12.04.

Au lieu de cela, le xdg-mime utilisé par xdg-open n'était pas défini correctement. J'ai trouvé ici une solution de travail. c'est-à-dire

$ xdg-mime default deluge.desktop x-scheme-handler/magnet
$ xdg-mime default deluge.desktop application/x-bittorrent

Puis une vérification rapide

$ xdg-mime query default x-scheme-handler/magnet
deluge.desktop
$ xdg-mime query default application/x-bittorrent
deluge.desktop

Et maintenant ça marche enfin bien.

    
réponse donnée Antonio 12.04.2014 - 22:17
la source
0
Pour moi, ce qui a fonctionné, c'est que je suis allé sur le fichier mimeapps.list et que j'ai ajouté tixati comme gestionnaire d'aimants par défaut - c'est très simple et fonctionne rapidement.

Créez ensuite le lien de raccourci sur le bureau du client bittorrent.

Allez dans ce fichier - ** (appuyez sur Ctrl + H) pour afficher / masquer les fichiers de la vue ..

/home/.local/share/applications/mimeapps.list

Ouvrez le fichier -mimeapps.list - tapez ce texte  * x-scheme-handler / magnet = tixati.desktop

cliquez sur enregistrer dans l'application.

J'utilise tixati pour torrent. Si vous utilisez un autre client bittorrent - remplacez simplement tixati par un autre - par exemple, vuze, deluge,. (téléchargez tixati depuis tixati.com)

Si vous souhaitez choisir la transmission, remplacez tixati par   transmission-gtk.desktop

    
réponse donnée frank 02.11.2015 - 02:09
la source
0

Voici la réponse de @michael_n dans un script:

# rewrite deluge's .desktop file
sudo tee /usr/share/applications/deluge.desktop > /dev/null <<'EOF'
[Desktop Entry]
Version=1.0
Name=Deluge
GenericName=BitTorrent Client
X-GNOME-FullName=Deluge BitTorrent Client
Comment=Download and share files over BitTorrent
TryExec=deluge-gtk
Exec=deluge-gtk %U
Icon=deluge
Terminal=false
Type=Application
Categories=Network;FileTransfer;P2P;GTK
StartupNotify=true
MimeType=application/x-bittorrent;x-scheme-handler/magnet;
EOF

# set association and reload
gvfs-mime --set x-scheme-handler/magnet deluge.desktop
sudo update-desktop-database

Amusant pour moi sur Ubuntu 15.10 avec les installations par défaut pour chrome et deluge.

    
réponse donnée Nicolas Marshall 05.05.2016 - 14:36
la source
-1

Mon Chrome utilisait Transmission par défaut. Je voulais utiliser qBittorrent. Sur Ubuntu 14.04, j'ai supprimé la transmission en utilisant:

sudo apt-get purge transmission-gtk

Puis j'ai "manuellement" démarré qBittorrent et l'ai refermé. La prochaine fois que j'ai cliqué sur un lien magnétique, Chrome m'a demandé de lui permettre d'appeler une application externe. J'ai permis cela et chrome a ensuite tiré qBitorrent.

Il semble donc que si vous n'avez pas besoin d'avoir plus d'un client torrent sur votre PC, en supprimant les autres et en laissant celui que vous voulez, vous pouvez forcer Chrome à utiliser le client souhaité. Un peu une solution de Chuck Norris, mais cela a fonctionné pour moi.

    
réponse donnée TheGurkha 27.09.2014 - 22:52
la source
-2
cd /usr/bin/

sudo sed 's/elif \[ x\"$GNOME_DESKTOP_SESSION_ID\" \!\= x\"\" \]\; then DE\=gnome\;/elif [ x"$GNOME_DESKTOP_SESSION_ID" != x"" ]; then DE=gnome;\n    elif [ x"$MATE_DESKTOP_SESSION_ID" != x"" ]; then DE=gnome;/g' -i xdg-*

A travaillé pour moi (Mint Mate 16 Petra).

    
réponse donnée Ben2talk 14.02.2014 - 17:08
la source

Lire d'autres questions sur les étiquettes