Impossible d'installer Skype sur Ubuntu 64 bits [dupliquer]

36

Remarque: L'application Skype pour Linux héritée (v4. *) n'est plus disponible et a été supprimée des référentiels partenaires de Canonical. Cette question et ses réponses sont donc obsolètes. Veuillez vous reporter à la nouvelle réponse de notre question d'installation canonique de Skype .

Je reçois le message suivant pendant que j'essaie d'installer Skype:

[email protected]:~$ sudo apt-get update
[email protected]:~$ sudo apt-get install skype
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype : Depends: skype-bin but it is not installable
E: Unable to correct problems, you have held broken packages

Comment puis-je résoudre ce problème?

    
posée Nidhin 10.11.2012 - 08:30
la source

10 réponses

42

12.10 et plus récent

J'ai eu le même problème et ce qui a aidé était d'activer l'architecture 32 bits en procédant ainsi:

sudo dpkg --add-architecture i386
sudo apt-get update

J'ai ensuite pu installer skype via le référentiel de partenaires Canonical:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update && sudo apt-get install skype
    
réponse donnée Willi 28.12.2012 - 15:50
la source
32

Avant tout, vous devez activer l'architecture i386 avant d'exécuter les commandes ci-dessous sur votre système Ubuntu 64 bits.

sudo dpkg --add-architecture i386

Exécutez ensuite les commandes ci-dessous sur le terminal pour installer skype .

Ubuntu 13.10

sudo sh -c "echo 'deb http://archive.canonical.com/ saucy partner' >> /etc/apt/sources.list.d/canonical_partner.list"
sudo apt-get update
sudo apt-get install skype

Ubuntu 14.04

sudo sh -c "echo 'deb http://archive.canonical.com/ trusty partner' >> /etc/apt/sources.list.d/canonical_partner.list"
sudo apt-get update
sudo apt-get install skype
    
réponse donnée Avinash Raj 28.11.2013 - 13:25
la source
3

Je suggère de supprimer skype-bin en premier et d’installer Skype comme suit.

Exécuter les commandes suivantes dans Terminal

sudo apt-get remove skype skype-bin

sudo apt-get install libxss1  

wget http://www.skype.com/go/getskype-linux-ubuntu-64/skype-ubuntu-precise_4.1.0.20-1_amd64.deb

sudo dpkg -i skype-ubuntu*.deb
    
réponse donnée Ketankumar Patel 08.12.2012 - 04:45
la source
2

skype n'est pas d'ubuntu.it est un logiciel tiers pris en charge par la fondation canonique alors éditez votre source.list en utilisant

$sudo gedit /etc/apt/source.list

puis ajoutez le lien suivant dans votre liste source

deb http://archive.canonical.com/ubuntu $(lsb_release -sc) partner
deb-src http://archive.canonical.com/ubuntu $(lsb_release -sc) partner

$(lsb_release -sc) remplace par votre nom ubuntu. Sauvegarde le. Ensuite, mettez à jour votre référentiel en utilisant

$sudo apt-get update

exécutez maintenant la commande suivante pour installer skype

$sudo apt-get install skype

cela installera skype et skype.bin.

    
réponse donnée linxbuddy 01.04.2014 - 11:21
la source
2

12.10 et plus et en particulier 17.04:

lien

Téléchargez le paquet deb

S'il n'est pas installé, installez déjà gdebi:

sudo apt update && sudo apt upgrade
sudo apt install gdebi

puis cd dans le répertoire Downloads et lancez gdebi pour le deb téléchargé:

sudo gdebi –n skypeforlinux-64.deb

(Ou pour une approche qui ne nécessite même pas l'installation de logiciels supplémentaires):

sudo dpkg -i skypeforlinux-64.deb

vous pouvez simplement faire un clic droit sur le fichier téléchargé, aller dans les propriétés et définir le programme par défaut pour ouvrir ce type de fichier à gdebi (recommandé entre-temps dans 17.04), puis double-cliquer sur le fichier et termine le chargement du fichier cliquez sur installer (vous serez invité à saisir votre mot de passe)

    
réponse donnée tatsu 10.05.2017 - 15:35
la source
0

Essayez ces commandes:

sudo apt-get install libxss1 
cd /tmp 
wget http://www.skype.com/go/getskype-linux-ubuntu-64/skype-ubuntu-precise_4.1.0.20-1_amd64.deb
sudo dpkg -i skype-ubuntu*.deb

Source: lien

    
réponse donnée To Do 06.12.2012 - 19:43
la source
0
  1. téléchargez le package skype depuis ici
  2. installez-le en double-cliquant
  3. ouvrir nautilus dans /usr/share/applications/
  4. modifiez skype.desktop (correctif pour le problème audio) et remplacez la ligne:
    Exec= skype %U par Exec = env PULSE_LATENCY_MSEC = 30 skype% U

  5. faites glisser skype.desktop et déposez-le sur la barre d'unité (cela ouvrira la même instance de skype après la fermeture de la fenêtre)

Le code complet du fichier .desktop est disponible à l'adresse: skype.desktop

    
réponse donnée tomaszkubacki 28.11.2013 - 12:41
la source
0

Ceci est un problème courant dans l’installation de Skype 64 bits

Tout d'abord, une mise à niveau est requise et consiste à créer le fichier de préférences:

sudo vi /etc/apt/preferences

et insérez les lignes suivantes:

Package: *       
Pin: release a=precise*
Pin-Priority: 2012

La priorité des broches doit être supérieure à 1000.

Ensuite, vous pouvez rétrograder les applications incriminées avec:

sudo apt-get dist-upgrade

Then you may install packages that complained about dependencies, like
sudo apt-get install ia32-libs-multiarch, or sudo apt-get install ia32-libs.

Enfin, vous devez supprimer le fichier que vous venez de créer:

sudo rm /etc/apt/preferences

Téléchargez maintenant le site Web officiel Skype (skype.com) pour la multi-architecture

puis ouvrez le paquetage descendu depuis le centre du logiciel, puis vous devriez pouvoir installer skype

    
réponse donnée Atul Jain 16.07.2014 - 14:39
la source
0

Bien que d’autres réponses ici fournissent la manière correcte d’installer Skype, vous pourriez toujours avoir la même erreur (je l’ai fait).

L'exécution de aptitude install skype pourrait être plus utile pour trouver ce qui pose problème.

Une des causes possibles est un système mis à niveau du 14.04 au 16.04.
Certains paquets d'ubuntu 14.04 ont des numéros de version qui, comparés à ceux de 16.04, sont considérés comme "supérieurs". Par exemple:

  • Ubuntu 14.04: libdrm2 2.4.67-1ubuntu0.14.04.1
  • Ubuntu 16.04: libdrm2 2.4.67-1

Lors de la mise à niveau de 14.04 à 16.04, ces paquets ne sont pas mis à niveau (et ne le seront pas plus tard) car ubuntu pense, par exemple, que 2.4.67-1ubuntu0.14.04.1 est supérieur à 2.4.67-1 .

Cela pose des problèmes lors de la tentative d’installation de leur équivalent i386 requis par skype, car la version i386 ne correspond pas à celle déjà installée avec amd64 (qui n’existait pas depuis la version 14.04).

Le même problème s'applique à libdrm-intel1, libdrm-radeon1, libdrm-nouveau2, libdrm-amdgpu1, libdrm-dev, libuv1. Cette liste n'est pas exhaustive.

Cela peut être résolu en créant un fichier (par exemple, /tmp/pin.txt ) contenant:

Package: *
Pin: release n=*
Pin-Priority: 1001

et en cours d'exécution:

sudo apt-get -o Dir::Etc::Preferences=/tmp/pin.txt dist-upgrade

Avertissement: Ceci installera la version disponible dans les référentiels pour TOUS les packages. Faites attention si vous avez installé des paquets ailleurs (assurez-vous simplement que apt-get n'essaye pas de rétrograder quoi que ce soit lorsque vous êtes invité à confirmer).

    
réponse donnée lgpasquale 10.05.2017 - 15:30
la source
-1

Installez Synaptic si vous ne l’avez pas, ouvrez-le, puis allez dans Modifier & gt; Réparer les paquets brisés. Après cela, essayez d’installer Skype.

    
réponse donnée Томица Кораћ 10.11.2012 - 09:21
la source

Lire d'autres questions sur les étiquettes