Remappage des majuscules dans 14.04 Trusty Tahr

32

J'ai vu un certain nombre de questions qui pointent vers un menu GUI pour remapper le verrouillage des majuscules, mais ce menu semble avoir disparu en 14.04. Est-ce que je ne le trouve pas, ou est-ce vraiment parti? Je sais que vous pouvez utiliser xkbmap pour le remapper, mais je ne sais pas trop comment y arriver.

Modifier

J'ai essayé les suggestions concernant la réponse acceptée pour cette question , mais rien ne semble fonctionner. D'après ce que je peux dire, le fichier .xinitrc ne semble jamais provenir. Y a-t-il un autre travail qui pourrait régler ce problème pour moi?

    
posée Eric Andres 23.04.2014 - 18:30
la source

4 réponses

27

Vous devez éditer le fichier / etc / default / keyboard et modifiez le paramètre XKBOPTIONS.

Par exemple, pour mapper capslock sur un ensemble de contrôle XKBOPTIONS="ctrl: nocaps" (source: Archlinux wiki

déconnectez-vous et reconnectez-vous pour que les modifications affectent votre système.

    
réponse donnée dwaynemac 03.04.2015 - 18:33
la source
18

Enfin, nous avons trouvé une réponse à l’interface graphique, après beaucoup de recherches sur Google: Comment échanger Escape et Caps Lock en 14.04? (On dirait que votre question a été mieux formulée et s’est révélée beaucoup plus élevée dans mes résultats de recherche.)

De la réponse liée:

  

Installez l’outil Outil GNOME Tweak (gnome-tweak-tool), sous l’onglet Typing , une option permet d’échanger Esc avec < kbd> Caps Lock . Cela a fonctionné pour moi dans Ubuntu 14.04.

Étrangement, l’arrière-plan de la fenêtre d’outil ne s’est pas rempli pour moi, alors j’ai dû ouvrir une fenêtre gedit juste pour voir le texte.

J'espère que ça aide! Même avec la fenêtre buggée, c'était beaucoup plus agréable que de jouer directement avec les paramètres xkb.

    
réponse donnée doctaphred 24.04.2014 - 23:15
la source
8

Dans mon cas, ce qui suit a fonctionné pour désactiver capslock dans Ubuntu 14.04:

setxkbmap -option caps:none

Applications de démarrage & gt; Ajouter & gt; Nom : Désactiver Capslock & gt; Commande : setxkbmap -option caps: none & gt; Ajouter .

Redémarrer et capslock est désactivé.

Pour remapper la fonction capslock sur la touche échap:

setxkbmap -option caps:escape
    
réponse donnée MC Basstard 22.09.2014 - 22:13
la source
3

Après avoir cherché suffisamment autour de moi, je pense que j'ai finalement trouvé cette incantation magique de Google pour trouver la réponse. Voici le message qui a résolu mon problème: Définir les préférences de setxkbmap au démarrage . Je viens de suivre les instructions de la réponse acceptée et j'ai ajouté 'ctrl: nocaps' aux options xkb. J'espère vraiment qu'ils vont juste ramener l'interface graphique pour changer cela ....

    
réponse donnée Eric Andres 23.04.2014 - 21:13
la source

Lire d'autres questions sur les étiquettes