Comment puis-je désactiver la mise à l'échelle de la fréquence du processeur et définir les performances du système?

34

Mon processeur tourne à 40% de sa vitesse maximale, je veux qu'il utilise 100% de la vitesse, tout le temps. J'ai cherché sur Google mais les tutoriels sont très anciens et ils diffèrent tous.

Alors, comment puis-je désactiver définitivement la mise à l'échelle de la fréquence du processeur et définir mon système en mode de performance?

S'il vous plaît, uniquement des solutions basées sur un terminal, je ne veux pas d’applets.

J'utilise Xubuntu 14.04 x64.

    
posée Removed 13.09.2014 - 20:25
la source

3 réponses

42

Après avoir lutté avec ondemand pendant un certain temps, je vais partager comment le désactiver définitivement dans Ubuntu et ses dérivés.

Installer cpufrequtils :

sudo apt-get install cpufrequtils

Puis éditez le fichier suivant (s'il n'existe pas, créez-le):

sudo nano /etc/default/cpufrequtils

Et ajoutez la ligne suivante:

GOVERNOR="performance"

Enregistrer et quitter.

Maintenant, vous devez désactiver le démon ondemand , sinon les paramètres seront écrasés après le redémarrage.

sudo update-rc.d ondemand disable

Et vous avez terminé!

Vous pouvez vérifier vos paramètres avec:

cpufreq-info

Il affichera un bloc d'informations pour chaque cœur de votre processeur. Il suffit de vérifier si tous sont en mode performance et à la vitesse maximale de votre processeur.

Mise à jour:

Le wiki Debian indique que sysfsutils est nécessaire pour conserver les paramètres lors des redémarrages, mais cela est faux. En outre, l'activation de sysfsutils rend mon système instable, il n'est donc pas recommandé.

Désolé si j'ai mal orthographié quelque chose. :)

Sources:

réponse donnée Removed 13.09.2014 - 23:13
la source
18

Je ne peux pas commenter, alors j'ai dû recourir à une nouvelle réponse. Pour des résultats immédiats, assurez-vous de faire sudo /etc/init.d/cpufrequtils restart pour que la nouvelle fréquence intervienne après avoir suivi toutes les étapes de Dennie.

    
réponse donnée Juanpi 02.02.2015 - 11:39
la source
9

Essayez ceci:

gksu gedit /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

Remplacez ondemand par performance . Répétez pour chaque noyau (augmentez cpu0: cpu1, cpu2).

Si vous rencontrez des erreurs de sauvegarde, utilisez nano editor:

sudo nano /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

Source: Éviter la mise à l'échelle de la vitesse du processeur - Exécution du processeur à pleine vitesse

    
réponse donnée Cornelius 13.09.2014 - 20:39
la source

Lire d'autres questions sur les étiquettes