Comment cacher le menu GRUB apparaissant au début du démarrage?

35

J'ai arrêté le double démarrage et je ne veux plus avoir à choisir le système d'exploitation. Je veux démarrer Ubuntu 12.04 directement sans voir le menu GRUB.

Comment puis-je y parvenir?

    
posée Alex Poulos 08.03.2012 - 09:19
la source

14 réponses

29

Vous pouvez simplement modifier les paramètres grub.

tapez le terminal

sudo -H gedit /etc/default/grub

Modifier GRUB_HIDDEN_TIMEOUT_QUIET=false en

GRUB_HIDDEN_TIMEOUT_QUIET=true

Enregistrez le fichier et quittez

Tapez sudo update-grub

Si vous n'obtenez pas le résultat souhaité, consultez ce bogue .

    
réponse donnée hingev 08.03.2012 - 09:44
la source
18

J'ai résolu ce problème en désactivant OS Prober. J'ai fait cela parce que dans /boot/grub/grub.cfg dans la partie générée par le modèle /etc/grub.d/30_os-prober , il y avait un remplacement de "timeout" à 10 et "style" au menu.

Modifiez /etc/default/grub et ajoutez cette ligne:

GRUB_DISABLE_OS_PROBER=true

J'espère que vous trouverez cela utile!

BTW, mon entier / etc / default / grub est:

GRUB_DEFAULT=0
GRUB_TIMEOUT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_DISTRIBUTOR= [...]
GRUB_DISABLE_OS_PROBER=true
GRUB_RECORDFAIL_TIMEOUT=0

Heureux codage

    
réponse donnée Agus Arias 23.10.2014 - 14:03
la source
11

J'ai essayé toutes ces astuces qui ne marchaient pas, a fini par réduire le délai d’expiration à zéro comme suit:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
    
réponse donnée Ndodemfishane 09.09.2012 - 23:42
la source
8

Vous devez modifier le fichier à /etc/default/grub pour éviter d’afficher le menu grub.

Par défaut, les entrées de ces fichiers ressemblent à ceci.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
  • Supprimez la marque # de la deuxième ligne et
  • Remplacez la ligne GRUB_HIDDEN_TIMEOUT_QUIET=false par GRUB_HIDDEN_TIMEOUT_QUIET=true .

Après les modifications, la partie requise du fichier ressemblera à ceci

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
  • Ensuite, exécutez la commande sudo update-grub dans le terminal et redémarrez pour voir le résultat.
réponse donnée Anwar 22.06.2012 - 10:27
la source
5

J'ai eu le même problème et aucun des conseils ici n'a fonctionné! Le seul moyen était de changer /boot/grub/grub.cfg manualy. À un moment donné de ce fichier, il fait passer le délai à 10! Alors, il suffit de commenter ces lignes

if [ "${timeout}" = 0 ]; then
  set timeout=10
fi

Mais vous ne pouvez plus jamais faire la mise à jour-grub, sinon elle retournera au même fichier, et le délai d'expiration sera de nouveau 10! Enregistrez le fichier (dans vi, vous devrez le forcer même si vous êtes su!). Redémarrez l'ordinateur et cela fonctionnera très bien!

    
réponse donnée user3680055 25.06.2014 - 02:47
la source
3

si vous souhaitez supprimer une entrée de démarrage, tapez simplement:

sudo update-grub

Si cela ne fonctionne pas, installez le gestionnaire de démarrage, comme ça:

sudo apt-get install startupmanager


avec gestionnaire de démarrage, vous pouvez

  1. choisir avec entrée pour démarrer,
  2. choisir la résolution et combien de temps attendre avant de démarrer,
  3. vous pouvez également choisir 0 pour le démarrage automatique par défaut entrée de démarrage
réponse donnée blade19899 08.03.2012 - 09:27
la source
3

Comme Agustin , j'ai constaté que mon problème concernait OS Prober. En faisant un pas de plus que sa solution, j'ai trouvé cet aperçu qui vous permettra d’avoir vos systèmes d’exploitation tout en masquant le menu. Il vous suffit de télécharger ces deux fichiers, de les placer dans /etc/grub.d et de leur donner les mêmes autorisations que les autres modèles de ce répertoire.

Si vous souhaitez accéder à votre système d’exploitation autre que celui par défaut, maintenez la touche Maj pendant le démarrage. Cela affichera le menu.

    
réponse donnée Neil Traft 22.11.2014 - 05:10
la source
3

J'ai trouvé une solution simple au problème.

  echo "
  set timeout_style=hidden
  set timeout=2" | sudo tee --append /etc/grub.d/40_custom 

Et mettre à jour grub. Il va écraser les paramètres de timeout dans grub.cfg, donc peu importe ce que vous avez dans / etc / default / grub. J'ai donc caché le menu qui peut être invoqué par shift pendant 2 sec.

    
réponse donnée Anton Lavrenov 31.10.2015 - 23:10
la source
2

Ajoutez la ligne suivante à /etc/default/grub :

GRUB_FORCE_HIDDEN_MENU="true"
    
réponse donnée Peque 09.07.2014 - 17:42
la source
2

J'ai vu beaucoup de gens dire que les réponses suggérées ne fonctionnaient pas pour eux. J'ai essayé plusieurs options et celui-ci a fonctionné pour moi :

Modifiez /etc/grub.d/00_header et trouvez:

if [ "${recordfail}" = 1 ]; then
  set timeout=-1

Changer en ...

if [ "${recordfail}" = 1 ]; then
  set timeout=10

Et lancez update-grub.

    
réponse donnée Scott Coates 10.07.2014 - 03:01
la source
2

pour tous ceux qui ont un splash de mots dans la ligne de commande, tout ce qui n’est pas codé en dur 0 pour le timeout ne fonctionnera pas,

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Essayez de supprimer le mot splash de la dernière ligne, de mettre à jour et de redémarrer, voilà, pas de menu:)

hth, krex

    
réponse donnée Kresimir Pendic 07.09.2014 - 09:40
la source
2

cela m'a pris du temps mais ça a payé car c'était un mélange de mes propres recherches et les réponses ci-dessus m'assurent d'abord que vos /etc/default/grub et /usr/grub/default/grub sont les mêmes. alors exécutez gksu gedit /etc/grub.d/30_os-prober près du haut sont les deux lignes que nous voulons mais pour les trouver rechercher le styke et changer cette ligne en caché alors rechercher une ligne de timeout elle devrait être comme si timeout = 0 a placé à 10 Supprimez cette partie du fichier si à la fin du fichier, assurez-vous de supprimer la fin du fichier ou votre fichier vissé et votre configuration grub devrait enregistrer quelque chose comme ceci: par exemple:

définit le démarrage par défaut de Windows 8.1 pro

GRUB_DEFAULT="Windows 8 (loader) (on /dev/sda1)"

définit une fenêtre de cinq secondes pour frapper shift afin que je puisse démarrer Ubuntu

GRUB_HIDDEN_TIMEOUT=5
GRUB_HIDDEN_TIMEOUT_QUIET=true

correctif principal pour erreur juste au cas où

GRUB_TIMEOUT=0

définit le style sur caché

GRUB_TIMEOUT_STYLE=hidden

Trucs Ubuntu par défaut

GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
    
réponse donnée Darian 18.12.2014 - 05:16
la source
0

Essayez à vos risques et périls et en dernier recours!

J'ai essayé de modifier /etc/default/grub et d'exécuter sudo update-grub sans résultat.

Terminé l'édition de /boot/grub/grub.cfg à la main, spécifiquement,

...
### END /etc/grub.d/00_header ###

set timeout=0
saved_entry="Ubuntu"
save_env saved_entry

### BEGIN /etc/grub.d/05_debian_theme ###
...
    
réponse donnée Epigene 14.01.2018 - 05:27
la source
-1
GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=5
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR="lsb_release -i -s 2> /dev/null || echo Debian"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Set this if you hide grubmenu at boot! hidden-timeout has to be 0-10
# NOT recommend with dual-boot systems
# Type ESC/ENTER at boot to make grub-menu visible again! 
# in this case hidden-timeout has to be 3-10
GRUB_DISABLE_OS_PROBER=true

résout le problème! s.grub2 @ubuntuusers! ; -)

Il est également possible de rendre le menu grub visible à nouveau au démarrage!

IMPORTANT si vous avez un crash et que vous voulez démarrer un noyau plus ancien (et stable)!

(Testé avec Linux Mint 17.3 Rosa basé sur Ubuntu 14.04)

    
réponse donnée chalee 11.07.2016 - 19:43
la source

Lire d'autres questions sur les étiquettes