Comment désactiver le bouton de veille sur mon clavier?

31

J'ai un "bouton d'alimentation" sur mon clavier qui active le mode veille ou veille prolongée. Je n'arrive pas à trouver le mappage de cette clé dans "Paramètres système", "Clavier", "Système", "Gestion de l'alimentation", "Configuration config" ou similaire (où je pourrais le trouver avant l'unité). ce bouton?

Je ne veux pas désactiver l’hibernation / le sommeil, c’est simplement cette touche qui s’aggrave par accident et qui devient très ennuyeuse.

    
posée KillianDS 23.03.2012 - 11:13
la source

3 réponses

41

Désactivez le bouton Suspendre dans votre système

gsettings set org.gnome.settings-daemon.plugins.power button-suspend "nothing"

Revenir à la valeur par défaut

gsettings set org.gnome.settings-daemon.plugins.power button-suspend "suspend"

Désactivez le bouton de veille de votre système

gsettings set org.gnome.settings-daemon.plugins.power button-sleep "nothing"

Revenir à la valeur par défaut

gsettings set org.gnome.settings-daemon.plugins.power button-sleep "hibernate"

Désactiver le bouton de mise en veille prolongée dans votre système

gsettings set org.gnome.settings-daemon.plugins.power button-hibernate "nothing"

Revenir à la valeur par défaut

gsettings set org.gnome.settings-daemon.plugins.power button-hibernate "hibernate"

Les paramètres ci-dessus ne désactivent pas les fonctions de votre système, vous pouvez toujours utiliser le menu de la roue dentée pour mettre en veille / suspendre, cela désactive uniquement le clavier et les autres boutons de votre ordinateur.

    
réponse donnée Bruno Pereira 23.03.2012 - 16:39
la source
28

Dconf Editor est le remplacement recommandé de l'éditeur gconf pour Unity. Vous pouvez obtenir dconf dans le centre de logiciels ou en tapant sudo apt-get install dconf-tools dans le terminal.

Avec l'éditeur Dconf, accédez à org gnome settings-daemon plugins power . Vous pouvez y modifier le bouton de veille, ainsi que de nombreux autres boutons de votre clavier.

    
réponse donnée James 24.03.2012 - 00:03
la source
4

Avez-vous également essayé celui-ci?

gsettings set org.gnome.settings-daemon.plugins.power button-suspend "nothing"

J'ai fait tous les 3 de la question liée à et il a corrigé cela pour moi (x86 sur 12.04).

EDIT: Voici une seule commande qui fait tout 3:

for x in button-{suspend,sleep,hibernate}; do 
  gsettings set org.gnome.settings-daemon.plugins.power $x "nothing";
done
    
réponse donnée Ed Brannin 10.03.2013 - 22:04
la source

Lire d'autres questions sur les étiquettes