Ubuntu 16.04 n'émettra pas de son sur les écouteurs Bluetooth

35

J'essaie d'utiliser les écouteurs mt SONY MDR-XB950BT sur Ubuntu 16.04 sans avoir de chance. J'ai réussi à les connecter mais il ne semble pas que je puisse réellement les écouter. J'ai essayé de régler la sortie audio sur le casque, mais le son ne cesse de sortir des haut-parleurs. J'ai également installé Pulse Audio Volume Control, mais cela ne semble pas faire de différence. J'ai brièvement réussi à l'obtenir pour que le son de test puisse être lu à travers les écouteurs, mais lorsque j'ai essayé de regarder une vidéo en ligne, la vidéo ne pouvait même pas être lue avant que je modifie le périphérique de sortie audio.

Quelqu'un at-il des conseils / expérience avec ce genre de chose? Toute aide serait grandement appréciée.

    
posée Chris 28.04.2016 - 13:36
la source

8 réponses

46

J'ai résolu ce problème en installant blueman

Dans blueman, cliquez avec le bouton droit sur le casque et sélectionnez «profil audio» - & gt; «Lecture haute fidélité»

Il y a peut-être de meilleurs profils mais cela fonctionne pour moi.

J'ai lancé blueman depuis le terminal avec sudo apt-get install blueman , puis j'ai exécuté blueman et l'ai verrouillé au lanceur.

    
réponse donnée user141510 01.06.2016 - 00:25
la source
19

J'ai récemment effectué une mise à niveau vers Ubuntu 16.04 et j'ai rencontré le même problème en essayant de connecter mon UE Boom 2. Quelques recherches approfondies sur Google indiquent que ce problème persiste avec 16.04 depuis sa sortie en avril 2016.

Néanmoins, je suis tombé sur cette discussion et j'ai réussi à résoudre le problème avec les suggestions d’Emmentaler et de Brian Peacock.

Tout d’abord, avec mon UE Boom 2 connecté, je suis passé dans "Paramètres son" et je me suis assuré que le mode "sortie" était réglé sur "Headset Head Unit (HSP / HFP)", PAS "High Fidelity Playback (A2DP Sink)" . S'assurer que la sortie est de qualité médiocre est le seul moyen de garantir une connexion réussie. Ensuite, j'ai installé blueman sudo apt-get install blueman puis redémarré.

À partir de là, j'ai cliqué sur l'icône bluetooth d'origine dans la barre de menus, je suis passé à "UE Boom 2" et j'ai vérifié que la "connexion" était réglée sur OFF.

Après cela, j'ai cliqué sur la nouvelle icône bluetooth dans la barre de menus fournie par blueman et sélectionné "devices". Le "UE Boom 2" apparaît dans la fenêtre lorsqu'il est détectable. Maintenant, cliquez sur "Setup ..." en haut de la fenêtre. Étant donné le choix de la connexion, sous "Connect to:", j'ai sélectionné "Audio Sink". Cela a pris quelques essais, mais cela a fini par fonctionner.

Une fois la connexion établie, fermez la fenêtre de configuration et revenez aux paramètres audio. Vous devriez maintenant être en mesure de basculer le mode de sortie sur "Lecture haute fidélité (récepteur A2DP)" sans perdre le son. C'est maintenant le processus que j'utilise pour démarrer mon UE Boom 2 chaque fois que je dois l'utiliser.

Votre kilométrage peut varier, mais j'espère que cela fonctionne pour tous ceux qui en ont besoin. Ce bug m'a rendu fou toute la journée.

TLDR: connectez-vous en utilisant un bluetooth standard, définissez la connexion sur "On", réglez la sortie sur "HSP / HSF" dans les paramètres audio (assurez-vous que cela fonctionne), définissez la connexion sur "Off". Ensuite, configurez le périphérique en utilisant blueman, connectez-le comme un "Audio Sink". Maintenant, retournez dans les paramètres son et changez la sortie en "A2DP".

    
réponse donnée ConsistencyPls 28.09.2016 - 12:23
la source
17

J'utilise SONY MDR-XZ770BN et je n'ai eu aucun problème avec Ubuntu 14.04 en utilisant le bluetooth par défaut. Après l'installation de 16.04, le dissipateur haute fidélité A2DP ne fonctionnait pas. Le problème a été résolu après l'installation du gestionnaire Blueman et la sélection de l'option Audio Sink. Vous rencontrez toujours quelques problèmes mineurs, car je dois parfois éteindre et allumer le bluetooth avant de réussir, mais tout se passe bien. Essayez-le et peut-être que cela fonctionne aussi pour vous :)

P.S. Après avoir recherché quelques réponses sur le Web, il semble que les problèmes Bluetooth soient toujours présents dans Ubuntu. Ce serait formidable si elle est finalement réparée: D

    
réponse donnée Rado V. 04.05.2016 - 01:23
la source
9

Je sais que c’est une réponse tardive, et les réponses sont excellentes, mais juste pour clarifier les choses pour les personnes un peu confuses quant aux réponses comme je l’étais, voici un guide étape par étape:

  1. installer blueman à partir des dépôts officiels:
    sudo apt-get install blueman
  2. ouvrez le gestionnaire de bluetooth, depuis le menu des applications ou l’icône de la barre d’affichage.
  3. Sélectionnez votre appareil et suivez l’assistant pour le connecter (c’est vraiment facile, et vous pouvez également faire cette étape en utilisant les paramètres Bluetooth intégrés de votre gestionnaire de bureau)

  4. Après avoir connecté votre périphérique Bluetooth, cliquez avec le bouton droit sur son nom dans blueman et sélectionnez Audio Profiles & gt; High Fidelity Playback (A2DP Sink) aime ça:

J'espère que ça aide.

    
réponse donnée Iman Akbari 12.10.2016 - 20:27
la source
4

J'ai eu le même problème avec mes écouteurs Phillips BT sur Ubuntu-MATE 16.04.

Voici comment je l’ai résolu après que les écouteurs aient été découverts / appariés, etc.

  • Commencer à jouer de l'audio

  • Blueman : écouteurs connectés via l'option "Audio Sink", définissant "Audio Profile" sur "High Fidelity Playback". Marquer le casque comme "Trusted" dans le menu "Device" (ou en cliquant avec le bouton droit de la souris).

  • Préférences audio d'Ubuntu : dans l'onglet "Matériel", désactivez "Audio intégré" et réglez le casque (même identifiant que celui de Blueman) sur HSP / HFP. Dans l'onglet "Sortie", sélectionnez le casque (encore une fois, même identifiant que celui figurant dans Blueman).

Un peu délicat, mais a fait le travail. Activer à nouveau le son intégré une fois le casque branché n'a pas eu d'effet négatif sur la lecture et le son a été lu normalement après la déconnexion du casque. :)

    
réponse donnée Brian Peacock 21.07.2016 - 22:59
la source
1

Go à *** Paramètres audio *** et définir le mode: sur "Lecture haute fidélité (récepteur A2DP)" de "Unité principale du casque (HSP / HFP)"

Accédez à Paramètres audio et définissez le mode: sur "Lecture haute fidélité (récepteur A2DP)" depuis "Unité principale du casque (HSP / HFP)"

Le problème est la qualité du son et le support de la version Bluetooth.

    
réponse donnée Suresh Parmar 11.09.2017 - 20:31
la source
0

J'étais sur Ubuntu 15.04. Pendant ce temps, j'avais déjà le problème avec mon Sony MDR-ZX550BN. Le problème était parfois, Ubuntu refusait de jouer du son via AD2P. Ce que j'ai fini par faire, c'était de désunir le périphérique (le retirer de la liste des périphériques Bluetooth), puis de le réparer. Ça marchait.

Puis je suis passé à Xenial Xerus (16.04). J'ai toujours eu le même problème mais plus fréquemment. J'ai installé Blueman depuis le magasin Ubuntu et le problème a disparu.

TL; DR: installez Blueman avec le périphérique déjà associé.

    
réponse donnée Numéro Cinq AD 13.08.2016 - 00:47
la source
0

Voici ce qui a fonctionné pour moi:

  1. Installé Blueman

Et pour chaque fois que je veux l'utiliser:

  1. Connectez-vous à un casque Blueman (cliquez avec le bouton droit de la souris et cliquez sur le casque ou les mains libres)
  2. Clic droit dans Blueman - & gt; Profil audio - & gt; Off
  3. Déconnectez-vous dans Blueman (cliquez avec le bouton droit de la souris et cliquez sur le casque ou les mains libres)
  4. Connectez-vous à nouveau (voir 1)
  5. Clic droit dans Blueman - & gt; Profil audio - & gt; Lecture haute fidélité - Evier A2DP)

Cela a été le seul moyen de fonctionner 100% du temps.

    
réponse donnée mmalmeida 28.07.2017 - 15:28
la source

Lire d'autres questions sur les étiquettes