Faire en sorte que les couleurs du terminal gedit soient les mêmes que celles du terminal par défaut

31

Je viens de mettre à jour vers 11.10 et maintenant mon terminal embarqué dans gedit ne correspond pas à mon terminal par défaut. Je déteste regarder un terminal blanc et noir. Est-ce que quelqu'un sait comment faire correspondre le terminal intégré au terminal par défaut?

Ceci est une capture d'écran:

Je veux que mon terminal embarqué dans gedit corresponde à mon terminal par défaut.

    
posée Hugo 16.10.2011 - 18:10
la source

6 réponses

36
  1. Assurez-vous que les packages suivants sont installés:

  2. Ouvrez gconf-editor et accédez à apps n gnome-terminal et sélectionnez un profil:

  3. Ouvrez maintenant dconf-editor et accédez à org ome gnome ➜ gedit ➜ plugins ➜ terminal et décochez la touche use-theme-colors :

  4. À partir de gconf-editor, copiez les valeurs de

    • couleur d'arrière-plan
    • couleur de premier plan
    • palette

    vers les touches correspondantes dans dconf-editor. Le terminal embarqué devrait maintenant correspondre à un gnome-terminal normal.

réponse donnée Isaiah 20.10.2011 - 01:20
la source
18

Ceci est pour gedit 3

Même problème ici blanc sur gris clair.

J'ai modifié manuellement /usr/lib/gedit/plugins/terminal.py . Le terminal utilisé est xterm.

Rechercher:

fg = context.get_color(Gtk.StateFlags.NORMAL)
bg = context.get_background_color(Gtk.StateFlags.NORMAL)

Je remplace par

fg = Gdk.RGBA(0, 0, 0, 1)
bg = Gdk.RGBA(1, 1, 1, 1)

Info: fg = texte noir, bg = fond blanc

    
réponse donnée John 10.07.2012 - 16:10
la source
4

Assurez-vous de ne pas cocher Utiliser les couleurs du thème du système , alors cela devrait fonctionner:

    
réponse donnée htorque 14.04.2011 - 22:11
la source
1

Ouvrez gconf-editor et accédez à apps->gnome-terminal->profiles->Default

  • Décochez l'option use-theme-colors.
  • Définir la couleur de premier plan: #FFFFFF
  • Définir la couleur d'arrière-plan: # 000000

Cela définira le texte en blanc et l'arrière-plan en noir. Cela définira cela pour le terminal et le terminal intégré, si vous souhaitez utiliser des couleurs différentes pour chacun, faites-le à la place.

Ouvrez gconf-editor et accédez à apps->gedit-2->plugins

  • Créer une nouvelle clé nommée use_theme_colors
  • Définissez le type sur: Booléen
  • Définissez la valeur sur: False
  • Créer une nouvelle clé nommée foreground_color
  • Définissez le type sur: String
  • Définissez la valeur sur: #FFFFFF
  • Créer une nouvelle clé nommée background_color
  • Définissez le type sur: String
  • Définissez la valeur sur: # 000000

Modifiez le fichier /usr/lib/gedit-2/plugins/terminal.py

Sous la ligne:

GCONF_PROFILE_DIR = "/apps/gnome-terminal/profiles/Default"

Ajouter une nouvelle ligne:

GCONF_GEDIT_DIR = "/apps/gedit-2/plugins"

Puis remplacez les lignes:

if not gconf_get_bool(self.GCONF_PROFILE_DIR + "/use_theme_colors"):
fg_color = gconf_get_str(self.GCONF_PROFILE_DIR + "/foreground_color", None)
bg_color = gconf_get_str(self.GCONF_PROFILE_DIR + "/background_color", None)

Avec:

if not gconf_get_bool(self.GCONF_GEDIT_DIR + "/use_theme_colors"):
fg_color = gconf_get_str(self.GCONF_GEDIT_DIR + "/foreground_color", None)
bg_color = gconf_get_str(self.GCONF_GEDIT_DIR + "/background_color", None)

Vous pouvez maintenant définir les couleurs du terminal intégré uniquement, avec les clés créées dans apps->gedit-2->plugins

    
réponse donnée Gary 12.11.2015 - 14:33
la source
1

Inspectant terminal.py pour Ubuntu 16.04, il semble qu’il charge un certain profil hérité:

def get_profile_settings(self):
    profiles = self.settings_try_new("org.gnome.Terminal.ProfilesList")

    if not profiles:
        default_path = "/org/gnome/terminal/legacy/profiles:/:" + profiles.get_string("default") + "/"
        settings = Gio.Settings.new_with_path("org.gnome.Terminal.Legacy.Profile",
                                              default_path)
    else:
        settings = Gio.Settings.new("org.gnome.gedit.plugins.terminal")

    return settings

En inspectant org.gnome.terminal.legacy.profiles: en dconf-editor , il y avait un tel profil. Après la suppression avec:

dconf reset -f /org/gnome/terminal/legacy/profiles:/

Je pourrais modifier les paramètres de org.gnome.gedit.plugins.terminal et les appliquer. Pour background-color , j'ai dû désactiver use-theme-colours en premier.

    
réponse donnée muru 16.01.2017 - 06:52
la source
0

dans 13.04, le chemin de gconf-editor vers les propriétés a été remplacé par: org - & gt; gnome - & gt; gedit - & gt; terminal

    
réponse donnée Nico Grunfeld 26.07.2013 - 01:35
la source

Lire d'autres questions sur les étiquettes