Comment puis-je désactiver le pavé tactile lors de la frappe? Sur Ubuntu 16.04, syndaemon ne fonctionne pas

37

Je souhaite désactiver le pavé tactile lors de la frappe. J'ai essayé ceci:

syndaemon -i 1 -d -t -K

Il convient de désactiver le toucher et le défilement sur le pavé tactile pendant 1 seconde et d'ignorer les combinaisons modificateur + touches, mais après avoir défini syndaemon comme décrit, rien n'est changé. Le touchpad est toujours actif et très agaçant.

J'utilise Ubuntu 16.04 sur un Dell Precision 5510.

    
posée marsUbuntux 17.05.2016 - 11:13
la source

7 réponses

33

Vous pouvez avoir deux pilotes de pavé tactile en cours d'exécution, où syndaemon interagirait avec le mauvais. J'ai eu le même problème sur un Dell XPS 13 et ce fil ( lien ) m'a aidé.

Si vous voyez également deux périphériques à pavé tactile, essayez d’en désactiver un. Comme vous avez un ordinateur différent, les instructions contenues dans le lien peuvent ne pas vous être applicables à la lettre.

À partir du message auquel il est fait référence, la procédure est la suivante:

ouvrez le fichier /usr/share/X11/xorg.conf.d/51-synaptics-quirks.conf en tant que root avec votre éditeur de texte Insérer le texte suivant:

# Disable generic Synaptics device, as we're using
# "DLL0704:01 06CB:76AE Touchpad"
# Having multiple touchpad devices running confuses syndaemon
Section "InputClass"
Identifier "SynPS/2 Synaptics TouchPad"
      MatchProduct "SynPS/2 Synaptics TouchPad"
      MatchIsTouchpad "on"
      MatchOS "Linux"
      MatchDevicePath "/dev/input/event*"
      Option "Ignore" "on"
EndSection

Redémarrez ou redémarrez Xorg avec la commande sudo systemctl restart lightdm Le crédit va à ddarling d'ubuntuforums.org.

Depuis janvier 2018, la base de connaissances de Dell est Problèmes concernant le pavé tactile / souris Ubuntu . La page décrit ce correctif pour désactiver le "TouchPad SynPS / 2 SynPS / 2" et suggère également de passer à libinput plutôt qu’à synaptics en tant que pilote du mousepad.

    
réponse donnée vanadium 17.06.2016 - 16:02
la source
29
sudo add-apt-repository ppa:atareao/atareao
sudo apt-get update
sudo apt-get install touchpad-indicator
  • Ouvrez l'indicateur du pavé tactile et cliquez sur l'icône correspondante.
  • Vous pouvez modifier les préférences (dans l'onglet Action) pour "désactiver le pavé tactile lors de la saisie"

Salut!

    
réponse donnée cpn 30.09.2016 - 04:57
la source
8

J'utilise Ubuntu 17.10 et j'ai essayé différentes solutions suggérées ici qui ne fonctionnent généralement pas. spécialement le logiciel indicateur de pavé tactile lors du démarrage dans Ubuntu 17.10 vient de désactiver le pavé tactile et je n’ai trouvé aucun moyen de le réactiver sans avoir à redémarrer un ordinateur portable. maintenant, j'ai trouvé cette solution qui, je pense, fonctionne encore plutôt bien: utilisez simplement cette commande,

synclient PalmDetect=1

Cela évitera au moins de taper inutilement sur le pavé tactile, ce qui donnera finalement une vie meilleure.

    
réponse donnée tareqalam 26.11.2017 - 03:08
la source
2

Après avoir examiné les options de 'xinput', j'ai trouvé une solution simple et efficace pour désactiver le pavé tactile Synaptics avec Ubuntu 16.04 et Lubuntu 16.04

Dans une fenêtre de terminal, donnez-vous un accès administratif en entrant 'sudo -s' et en entrant votre mot de passe.

À l'aide de votre éditeur favori, tel que leafpad ou gedit, créez un nouveau fichier script:

leafpad /usr/local/bin/tpadoff

et insérez ce qui suit:

#!/bin/bash
#/usr/local/bin/tpadoff - turn off touchpad
xinput --disable  'SynPS/2 Synaptics TouchPad'

Enregistrez le fichier et quittez l'éditeur. Puis entrez la commande:

chmod 755 /usr/local/bin/tpadoff

pour rendre le fichier exécutable. Vous pouvez répéter la procédure pour créer un fichier tpadon. Il suffit de remplacer le paramètre - --disable 'par' --enable '.

Une fois terminé, "quittez" la fenêtre du terminal pour désactiver l'accès administrateur.

Vous pouvez créer des entrées sur le bureau en ouvrant une nouvelle fenêtre de terminal et en utilisant votre éditeur favori (dans cet exemple, j'utilise de nouveau le bloc-notes):

cd Desktop
leafpad tpadoff.desktop

et insérez le texte suivant: [Entrée du bureau] Nom = TouchPad Off Commentaire = Pavé tactile éteint Exec = / usr / local / bin / tpadoff Terminal = faux Type = Application

Enregistrez le fichier et quittez l'éditeur. Puis entrez la commande suivante:

 chmod 775 tpadoff.desktop 

Vous pouvez également répéter la création d'un tpadon.desktop en remplaçant toutes les références "off" par "on".

Une fois l'opération terminée, vous disposez de deux méthodes pour désactiver (et éventuellement activer) le pavé tactile en double-cliquant sur une icône du bureau ou en entrant "tpadoff" dans une fenêtre de terminal.

Si votre pavé tactile est différent, vous devrez peut-être utiliser 'xinput' dans une fenêtre de terminal pour trouver la syntaxe exacte de votre pavé tactile. Editez ensuite le fichier '/ usr / local / bin / tpadoff' pour qu'il corresponde à ce que xinput a signalé.

    
réponse donnée jakester 11.07.2017 - 21:37
la source
1

Pour les utilisateurs de Kubuntu ...

Sous Kubuntu 16.04 - pour désactiver le pavé tactile lors de la frappe, je devais désélectionner la case à cocher intitulée "Désactiver les taps et le défilement uniquement" sous paramètres - > périphériques d'entrée - > pavé tactile > Activer / désactiver le pavé tactile. Cela peut sembler évident mais ...

    
réponse donnée user1806949 22.02.2017 - 17:11
la source
1

Après des mois de recherche d’une solution, j’ai décidé d’écrire un simple programme Python pour désactiver le pavé tactile lors de la frappe. Ajout du programme aux applications de démarrage pour qu’il soit exécuté à chaque démarrage de votre ordinateur. Vous devez exécuter xinput list pour déterminer l'id de votre clavier. Dans mon cas, il s'agit de 17.

xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft® Nano Transceiver v1.0    id=11   [slave  pointer  (2)]
⎜   ↳ Microsoft Microsoft® Nano Transceiver v1.0    id=12   [slave  pointer  (2)]
⎜   ↳ DLL082A:01 06CB:76AF Touchpad             id=14   [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=18   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Microsoft Microsoft® Nano Transceiver v1.0    id=10   [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                      id=13   [slave  keyboard (3)]
    ↳ Intel Virtual Button driver               id=15   [slave  keyboard (3)]
    ↳ Intel HID events                          id=16   [slave  keyboard (3)]
    **↳ AT Translated Set 2 keyboard                id=17   [slave  keyboard (3)]**
    ↳ Dell WMI hotkeys                          id=19   [slave  keyboard (3)]
    ↳ Microsoft Microsoft® Nano Transceiver v1.0    id=20   [slave  keyboard (3)]

Voici le programme

import time 
import subprocess
import threading

def main():
    subprocess.call('gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true', shell=True)
    p = subprocess.Popen('xinput test 17', shell=True, stdout=subprocess.PIPE, stderr=subprocess.PIPE)
    clickTime = [0, 0]
    def checkTime():
        keys = [37, 50, 62, 64, 105, 108, 133]
        while True:
            out = p.stdout.readline()

            if len(out) < 1:
                break
            key = int(out.split()[-1])
            if key not in keys:
                clickTime[0] = time.time()

    t = threading.Thread(target=checkTime)
    t.start()

    lastTime = 0
    touchpad = True
    while True:
        inactive = time.time() - clickTime[0]
        # print ('inactive for', inactive)
        if inactive > 1:            
            if not touchpad:
                print ('Enable touchpad')
                subprocess.call('gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click true', shell=True)
            touchpad = True
        else:
            if touchpad:
                print ('Disable touchpad')
                subprocess.call('gsettings set org.gnome.desktop.peripherals.touchpad tap-to-click false', shell=True)
            touchpad = False
        time.sleep(0.5)

    retval = p.wait()

if __name__ == '__main__':
    main()
    
réponse donnée tunght_53 06.12.2017 - 14:01
la source
0
xinput list |
while read line; do
    if [[ $line == *Touchpad* ]]; then
        tid="$(echo $line | cut -d '=' -f 2 | cut -c 1-2)"
        xinput set-prop $tid "Device Enabled" 0
    fi
done

ou plus précisément

xinput list | sed -nre 's/^.*Touchpad.*\sid=(\S+).*$//p' | xargs -I{} -- xinput set-prop {} 'Device Enabled' 0
    
réponse donnée 21.09.2018 - 06:12
la source

Lire d'autres questions sur les étiquettes