Ma carte graphique ATI est-elle prise en charge dans Ubuntu?

42

J'ai une carte graphique ATI et je veux savoir si elle est prise en charge et quel type de pilotes dois-je utiliser pour obtenir les meilleures fonctionnalités.

Ma carte est-elle prise en charge dans Ubuntu et quels pilotes fonctionneront avec ma carte?

    
posée Bruno Pereira 31.10.2011 - 19:57
la source

4 réponses

54

Matériel officiellement pris en charge

Pour vérifier si votre carte est prise en charge, consultez ce site .

Si votre carte n'y figure pas, elle est probablement trop récente et n’est tout simplement pas prise en charge par les pilotes ATI.

Installation des pilotes

Avant d’installer les pilotes dont vous avez besoin pour installer certaines dépendances sur votre système, faites-le en exécutant cette commande

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases

Paquets binaires officiels d'Ubuntu

Pour installer les paquets fglrx fournis par Ubuntu, ouvrez un terminal et installez-le en utilisant

sudo apt-get install fglrx fglrx-amdcccle

ou recherchez l'utilitaire Additional Drivers dans votre tableau de bord et installez l'un des pilotes détectés dans la liste.

La dernière version fournie par l’outil Additional Drivers d’Ubuntu (jusqu’à la date de cette édition) est 11.10.

Binaires ATI officiels du site ATI

Pour installer les derniers pilotes ATI 15.9, les utilisateurs signalent que la mise à jour de leurs pilotes résout certains problèmes avec Unity et Gnome-Shell

Vous devrez supprimer tous les packages fglrx actuels de votre système et télécharger le pilote depuis le site ATI.

Supprimez les pilotes fglrx si vous les avez déjà installés (si l’une de ces erreurs retourne, par exemple: fichier introuvable , package introuvable ignorez-le)

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

Téléchargez le dernier pilote ATI (la version actuelle est 15.9)

wget http://www2.ati.com/drivers/linux/amd-driver-installer-15-9-x86.x86_64.run

Si vous avez un système 64 bits, installez-le avant tout

sudo apt-get install ia32-libs

Une fois téléchargé, accédez à l’emplacement du fichier et définissez-le comme exécutable

cd /path_of_the_file
chmod 755 amd-driver-installer-15-9-x86.x86_64.run

Pour Ubuntu 32/64 bits, utilisez ces étapes pour installer

sh ./amd-driver-installer-15-9-x86.x86_64.run --buildpkg Ubuntu/oneiric
sudo dpkg -i fglrx*.deb

Une fois le pilote installé, vous devez démarrer un nouveau fichier xorg.conf avec cette commande

sudo aticonfig --initial -f

Redémarrer

sudo reboot


Revient aux pilotes open source

Après l’installation des pilotes à partir des paquets deb

Supprimez toutes les traces de fglrx de votre système:

sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

Supprimez votre xorg.conf

sudo rm /etc/X11/xorg.conf

Réinstaller xorg

Pour les systèmes 32 bits

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx libgl1-mesa-dri

Pour les systèmes 64 bits

sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:i386 libgl1-mesa-dri:amd64 xserver-xorg-core

Configurer Xorg

sudo dpkg-reconfigure xserver-xorg

Redémarrer:

sudo reboot

Après le redémarrage, tous les paquets fglrx auront disparu, vous utiliserez ceux par défaut.

Après l’installation des pilotes à partir des fichiers binaires ATI

Supprimez tous les fichiers de pilote ATI:

sudo sh /usr/share/ati/fglrx-uninstall.sh

Supprimez votre xorg.conf

sudo rm /etc/X11/xorg.conf

Réinstaller xorg

Pour les systèmes 32 bits

sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx libgl1-mesa-dri

Pour les systèmes 64 bits

sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:i386 libgl1-mesa-dri:amd64 xserver-xorg-core

Configurer Xorg

sudo dpkg-reconfigure xserver-xorg

Redémarrer:

sudo reboot

Après le redémarrage, tous les pilotes fglrx seront partis, vous utiliserez ceux par défaut.

    
réponse donnée Bruno Pereira 22.02.2016 - 04:34
la source
5

J'ai trouvé que le pilote ouvert par défaut fonctionnait mieux avec ma carte ATI (5450). J'avais installé un pilote propriétaire recommandé par Ubuntu, mais il y avait des problèmes de blocage lors de l'arrêt. J'ai désinstallé le pilote propriétaire et je ne remarque aucune différence de performance, mais je ne l’utilise que pour les effets Compiz, pas de jeux.

    
réponse donnée Marty Fried 16.01.2012 - 21:14
la source
2

Il existe au moins trois pilotes disponibles avec les nouvelles cartes ATI. C'est le pilote open source. C'est fiable mais pas toujours le plus rapide. Ensuite, le pilote fglrx est fourni avec le système d'exploitation ou depuis jockey. Il fonctionne plus vite et plus proprement. Et puis il y a le pilote fglrx téléchargeable sur ATI.

Les pilotes open source sont en fait assez bons. Essayez celui-là en premier.

    
réponse donnée anttir 07.11.2011 - 21:17
la source
2

De nombreuses cartes vidéo ATI fonctionnent bien avec Ubuntu automatiquement. Pour vérifier que l'accélération 3D fonctionne avec votre carte, consultez la section intitulée «Introduction à l'accélération vidéo 3D». Si cela ne fonctionne pas, cette procédure devrait l'activer.

Installez le package xorg-driver-fglrx à partir du référentiel restreint (voir Chapitre 2, Ajout, suppression et mise à jour d'applications).

Vous devez maintenant configurer l’ordinateur pour utiliser le nouveau pilote, donc exécutez cette commande dans un terminal:

sudo dpkg-reconfigure xserver-xorg Lorsque le dialogue apparaît et vous demande si vous souhaitez détecter automatiquement votre vidéo, choisissez Oui.

Lorsqu'on vous demande de sélectionner un pilote, choisissez fglrx.

Suivez les instructions restantes, le cas échéant.

Redémarrez votre machine pour que les modifications prennent effet.

    
réponse donnée user32849 08.11.2011 - 09:40
la source

Lire d'autres questions sur les étiquettes