Comment désactiver complètement l'écran de veille et la gestion de l'alimentation?

41

Je cherche une méthode pour désactiver l'économiseur d'écran et powermanager mais à partir de la ligne de commande.

Je sais que cela peut se faire via l’écran de l’interface graphique - mais est-ce possible via la ligne de commande ou via un éditeur de configuration?

Voici le mode gui (via l’application "screen" ou "brightness and lock"):

    
posée Takkat 16.10.2011 - 09:24
la source

9 réponses

36

pour 11.10

Désactiver le plug-in Power de GNOME Settings Deamon à partir de la ligne de commande:

gsettings set org.gnome.settings-daemon.plugins.power active false

Vous pouvez également utiliser dconf-editor du package dconf-tools:

Pour l’économiseur d’écran:

gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

Ou encore via dconf-editor :

    
réponse donnée htorque 16.10.2011 - 09:34
la source
6

Créez une documentation en texte brut dans votre dossier personnel et copiez-la.

#!/bin/bash
sleep 10 &&
xset s 0 0
xset s off
exit 0

Enregistrez le document sous "screensaver_off.sh" (sans les guillemets), puis ouvrez un terminal et entrez

chmod +x screensaver_off.sh

Ouvrez ensuite les applications de démarrage à partir du tableau de bord, cliquez sur le bouton Ajouter, nommez votre application de démarrage et entrez votre commande en tant que:

"sh /home/$LOGNAME/screensaver_off.sh"

Ajoutez ensuite une description et cliquez sur Ajouter, Redémarrer et sur Terminé, plus de suppression d’écran.

Vous devez le faire pour chaque utilisateur lorsque les paramètres par défaut sont rétablis après la déconnexion ou le redémarrage.

    
réponse donnée dginsd 09.11.2012 - 01:45
la source
5

Vous pourriez constater que la solution ci-dessus est nécessaire, mais pas suffisante. L'écran peut encore être masqué après 10 minutes. C'est un paramètre par défaut compilé dans Xorg.

Pour le désactiver pour la session en cours, exécutez:

xset s off

Vous pouvez mettre ceci dans votre fichier .xsession pour le désactiver à chaque connexion.

    
réponse donnée Thomas 21.10.2012 - 11:34
la source
4

Vous pouvez accéder aux préférences système. Il y a un programme appelé "Brightnes and lock" (je ne suis pas sûr de comment il s'appelle en anglais. Regardez ma capture d'écran) Dans ce menu, vous pouvez définir, lorsque le verrouillage est activé,

    
réponse donnée rechengehirn 27.06.2012 - 22:48
la source
4

Après avoir lu d’énormes quantités de messages sur le forum, j’ai finalement réussi à m'en débarrasser en configurant crontab pour qu’il s'exécute toutes les 4 minutes.

DISPLAY=:0.0 xset s activate

vous pouvez laisser DISPLAY=:0.0 , si vous vous êtes connecté avec ssh en tant qu'utilisateur qui utilise gnome.

xset s off n'a pas aidé dans mon cas. Je dois l'exécuter toutes les 4 minutes pour éviter que l'économiseur d'écran ne se déclenche toutes les 5 minutes. :)

    
réponse donnée Tuipveus 12.04.2014 - 01:04
la source
3

Voici une solution qui a fonctionné pour moi. Le problème que je rencontrais était la mise à niveau de Ubuntu 12.04 vers 12.10 et vers Gnome 3.6, l'écran devenait noir pendant 5 minutes, même si je n'avais pas de paramètres classiques pour un économiseur d'écran actif, inutile de dire que c'était énervant.

Voici la solution que j'ai utilisée et cela a fonctionné (et j'ai essayé beaucoup de choses différentes, en passant trop de temps à chercher sur startpage.com (google)

Faites défiler jusqu'à "Aucun écran de veille dans GNOME 3.2".

lien

    
réponse donnée aquarius 19.10.2012 - 22:07
la source
3

Décocher l’écran Dim pour économiser de l’énergie est possible avec

gsettings set org.gnome.settings-daemon.plugins.power idle-dim false

et en réglant "Désactiver après" sur "Jamais" avec

gsettings set org.gnome.desktop.session idle-delay 0

La dernière commande était tout à fait suffisante pour mes besoins.

    
réponse donnée Mojo 30.08.2014 - 15:16
la source
2

Désactiver l'économiseur d'écran sous environnement Linux à partir de VNC Viewer

    
réponse donnée Abhijeet 18.11.2015 - 04:14
la source
2

Vous n'avez pas spécifié si vous souhaitez une solution permanente ou une solution temporaire. Si vous souhaitez désactiver l'écran de veille et la gestion de l'alimentation, par ex. 2 heures, vous pouvez simplement inhiber ces fonctionnalités.

En pratique, vous pouvez simplement lancer

systemd-inhibit sleep 2h

Vous pouvez également choisir d’empêcher l’économiseur d’écran et la gestion de l’alimentation jusqu’à la fin d’un processus donné. Par exemple,

systemd-inhibit wget "https://example.com/files/huge-download.dat"

inhiberait l’économiseur d’écran et la gestion de l’alimentation jusqu’à ce que le téléchargement soit terminé.

Voir man systemd-inhibit pour plus de détails. Il vous permet de désactiver uniquement les fonctionnalités sélectionnées et de définir la chaîne visible de l'utilisateur pour expliquer pourquoi ces fonctionnalités sont inhibées (intéressant si votre système a plusieurs utilisateurs).

    
réponse donnée Mikko Rantalainen 03.06.2017 - 11:19
la source

Lire d'autres questions sur les étiquettes