Changer le moniteur principal

31

Comment modifier mon moniteur principal sans utiliser la ligne de commande?

    
posée trampster 04.08.2010 - 23:22
la source

11 réponses

17

Tant qu’Ubuntu Brainstorm Idea # 17526 n’aura pas vu le jour, les utilisateurs non-NVIDIA n'auront aucun moyen de changer l’écran principal (pas seulement de déplacer les panneaux) sans recourir à la ligne de commande.

Modifier 2014-05-30: Cette réponse est un peu démodée maintenant. Ubuntu Brainstorm n'existe plus. Et d'autres réponses à cette question ont de meilleures solutions, à la fois pour Ubuntu et d'autres distributions.

Dans MATE, "Préférences" affiche un bouton "Définir par défaut". C'est ce que vous recherchez.

Dans GNOME 3, "Settings & gt; Display" n'a pas de bouton "Make Default". Au lieu de cela, il a une barre qui ressemble à une barre d’outils en haut de l’un des écrans. Faites-le glisser sur l'affichage que vous voulez être principal.

Je crois que Unity est similaire à GNOME 3, mais la barre d’outils est sur le côté - je ne sais pas avec certitude; Je ne cours pas Unity moi-même.

Dans KDE, sous "Paramètres système & gt; Affichage et surveillance", il y a une étoile sur chaque écran sur laquelle vous pouvez cliquer pour définir celle qui est principale.

Modifier 2015-02-25: Il est réconfortant de savoir que les environnements de bureau Linux progressent.

Ubuntu GNOME 14.10 fonctionnalités GNOME 3.12. Ouvrez Affiche et choisissez l'affichage secondaire. Une liste à gauche vous permet de régler l'affichage sur "Primary", "Secondary Display" (sélectionné), "Mirror" ou "Turn Off".

Unity n’a plus d’équivalent de bureau principal. Vous pouvez définir le "placement de lanceur" sur l’un ou l’autre de vos affichages.

Ubuntu MATE et Kubuntu sont inchangé.

    
réponse donnée kaapstorm 06.04.2011 - 10:26
la source
12

J'avais des problèmes avec le moniteur principal qui se réinitialisait au redémarrage. Devenait assez ennuyeux. J'ai donc fait quelques recherches et j'ai pu trouver une solution personnelle.

Sélectionnez d’abord votre écran principal.

Assurez-vous de sauvegarder vos paramètres, puis fermez.

Ensuite, vous devez éditer le fichier de configuration des moniteurs.

gedit ~/.config/monitors.xml

Recherchez l’écran que vous souhaitez rendre primaire et changez en

<primary>yes</primary>

Et assurez-vous de changer l'autre moniteur en

<primary>no</primary>

Enregistrez maintenant les fichiers et redémarrez.

Exemple de configuration

<monitors version="1">
  <configuration>
      <clone>no</clone>
      <output name="DVI-I-0">
      </output>
      <output name="DVI-I-1">
      </output>
      <output name="TV-0">
      </output>
      <output name="DVI-I-2">
          <vendor>SYN</vendor>
          <product>0x0022</product>
          <serial>0x00000326</serial>
          <width>1360</width>
          <height>768</height>
          <rate>60</rate>
          <x>0</x>
          <y>312</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>no</primary>
      </output>
      <output name="DVI-I-3">
          <vendor>ACI</vendor>
          <product>0x24f2</product>
          <serial>0x01010101</serial>
          <width>1920</width>
          <height>1080</height>
          <rate>60</rate>
          <x>1360</x>
          <y>0</y>
          <rotation>normal</rotation>
          <reflect_x>no</reflect_x>
          <reflect_y>no</reflect_y>
          <primary>yes</primary>
      </output>
  </configuration>
</monitors>

Maintenant, lorsque vous redémarrez l'affichage doit être sélectionné comme principal.

Ma configuration est la suivante:

  • Ubuntu 12.04.1 (64 bits)
  • nVidia GTX 260 (en utilisant les derniers pilotes)
réponse donnée mywebslave 25.09.2012 - 19:41
la source
6

Travaillé pour Xubuntu 14.04 Trusty tahr nvidia gtx 760 en utilisant le pilote propriétaire 331.38 sur x86_64.

"Gestionnaire de paramètres" - & gt; "Session et démarrage" - & gt; Registre "Application Autostart" - & gt; ajouter la commande suivante:

 xrandr --output HDMI-0 --primary

spécifiez vous-même le titre afin de le reconnaître si vous modifiez ultérieurement. Vous pouvez lui donner des arguments supplémentaires.

Pour savoir quel moniteur est celui que vous pouvez appeler xrandr -q sur la ligne de commande ou installer arandr (disponible également dans le gestionnaire de paramètres) pour répertorier les moniteurs.

    
réponse donnée keiki 17.04.2014 - 20:55
la source
4

Pour la plupart des cartes vidéo:

Accédez au panneau de préférences des moniteurs. Sur une installation de bureau par défaut, c'est: Système - Préférences - Moniteurs

Décochez la case "Même image dans tous les moniteurs" et cliquez sur "Appliquer".

Maintenez la touche Alt enfoncée et faites glisser les panneaux supérieur et inférieur vers l’écran que vous souhaitez voir apparaître.

Pour les cartes vidéo NVidia:

Exécutez l’outil de configuration de NVidia. Sur une installation de bureau par défaut avec les pilotes propriétaires NVidia activés, ceci est: Système - Administration - Paramètres du serveur NVIDIA X

Sélectionnez "Configuration de l’affichage du serveur X".

Choisissez l’écran que vous voulez utiliser comme écran principal et cochez "Rendre cet écran principal à l’écran X" et appuyez sur "Appliquer".

    
réponse donnée fader 04.08.2010 - 23:33
la source
3

Le moyen le plus rapide est de simplement changer les câbles à l’arrière de l’ordinateur.

    
réponse donnée David Anderson 01.08.2017 - 16:10
la source
2

Je viens de supprimer ~ / .config / moniteurs.xml et de me déconnecter puis de revenir dans Paramètres / Moniteurs et de ré-enregistrer. Cela a créé un nouveau fichier monitor.xml - et cela a résolu le problème.

    
réponse donnée Kylea 07.03.2013 - 22:19
la source
1

Dans Ubuntu, cela peut être résolu comme suit:

Cliquez sur l'icône d'engrenage dans le lanceur Unity (la barre située à gauche de l'écran). L'icône est intitulée Paramètres système

Regardez dans la section Matériel et cliquez sur l’icône Affichages

Désactiver les affichages miroir (facultatif)

Cliquez sur l'un des rectangles d'affichage et faites glisser les affichages dans l'ordre de votre choix

Définissez les autres options souhaitées. Par exemple, vous pouvez configurer le programme de lancement uniquement sur un seul écran.

Cliquez sur Appliquer

Vous aurez maintenant la configuration du moniteur principal souhaitée, le tout sans utiliser la ligne de commande mentionnée dans votre question.

    
réponse donnée Snap Shot 01.05.2013 - 19:27
la source
1

Dans Unity avec 14.04LTS rien de cela ne fonctionne. Le monitor.xml est bien écrit et le puits principal et les positions sont bien définis, mais lors du redémarrage, il ignore le primaire et la position.

Cela semble aider lien

Bien que je ne puisse pas exécuter le script suggéré pour le redémarrer. J'ai ajouté la commande pour l'exécuter au démarrage mais cela ne semble pas fonctionner. Mais après le redémarrage même si j'augmente le délai d'exécution; Si je lance manuellement le script, il corrige les moniteurs.

    
réponse donnée kaf 09.01.2015 - 12:03
la source
0

Pour les déplacer tous en même temps, éteignez le moniteur secondaire, confirmez-le et rallumez-le - et tous les programmes seront sur le moniteur principal.

    
réponse donnée user222389 05.12.2013 - 14:32
la source
0

Dans le gestionnaire d’affichage, les deux moniteurs doivent être affichés côte à côte. Vous pouvez faire glisser le côté gauche vers la droite pour basculer le moniteur principal entre eux.

    
réponse donnée orezvani 15.07.2014 - 08:04
la source
-1

Avec Ubuntu 16.04.2, je devais définir, en premier lieu, l’écran principal par la commande xrandr:

xrandr  --output  Monitor_ref°  --primary

puis faites glisser l’écran de droite vers la gauche.

Le fichier ~/.config/monitor.xml a ensuite été mis à jour.

Je n'ai trouvé aucune autre solution, sans ligne de commande.

° Monitor_ref peut faire référence à différentes sorties VGA-0, DVI-0 etc. La sortie de xrandr -q les listera.

    
réponse donnée Pascaltech 08.05.2017 - 18:08
la source

Lire d'autres questions sur les étiquettes