16.04 Problèmes de connexion wifi LTS avec l'adaptateur Realtek

116

Après avoir installé 16.04 LTS, j'ai découvert plusieurs problèmes avec la connexion wifi.

Premièrement, le wifi ne se reconnecte pas normalement après un sommeil ou une veille prolongée. Parfois, l'icône du réseau se transforme en "flèches haut et bas" (je ne sais pas à quoi ça sert) après le réveil mais est toujours connecté. Parfois, le réseau est simplement perdu et il n’affiche aucun réseau dans la liste, il est donc tout simplement impossible d’utiliser le wifi.

J'ai d'abord essayé de redémarrer le gestionnaire de réseau en exécutant sudo service network-manager restart . Cela a fonctionné mais n'était pas une résolution permanente.

Ensuite, selon un autre sujet, j'ai ajouté SUSPEND_MODULES="iwlwifi" à

/etc/pm/config.d/config

Après cela, le problème de reconnexion semble être résolu (peut se reconnecter automatiquement et l'icône ne change plus). Cependant, je trouve que la connexion wifi est perdue de manière aléatoire (environ toutes les 30 minutes) même lorsque l'ordinateur est en marche et que l'icône réseau reste l'état connecté lorsque la connexion est perdue.

Un autre problème après l’ajout du code est que lorsque je mets mon ordinateur en veille, l’écran s’éteint une seconde, puis se rallume pendant environ 5 secondes (pendant lesquelles le système coupe la connexion wifi). Et puis l’ordinateur s’endort après ce processus inhabituel en deux phases.

Plz trouvez les informations sur les cartes sans fil ci-dessous

*-network               
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 00
       serial: b0:c0:90:5c:1c:d5
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.4.0-21-generic firmware=N/A ip=192.168.0.8 latency=0 link=yes multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 ioport:d000(size=256) memory:df200000-df203fff

00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 07)
00:01.0 PCI bridge: Intel Corporation Sky Lake PCIe Controller (x16) (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 06)
00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-H Thermal subsystem (rev 31)
00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA controller [AHCI mode] (rev 31)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (2) I219-V (rev 31)
01:00.0 VGA compatible controller: NVIDIA Corporation GK208 [GeForce GT 730] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GK208 HDMI/DP Audio Controller (rev a1)
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
03:00.0 Non-Volatile memory controller: Samsung Electronics Co Ltd NVMe SSD Controller (rev 01)

Mise à jour du 05/01/2016: Je ne sais pas ce qui s'est passé mais le problème s'aggrave maintenant. La connexion Wifi se perd environ toutes les 5 minutes et je dois me reconnecter ou redémarrer le gestionnaire de réseau.

    
posée Lixu 25.04.2016 - 07:13
la source

9 réponses

43

Finalement, j'ai pu résoudre les problèmes après avoir essayé un certain nombre de méthodes différentes.

  1. Obtenez des détails sur votre carte sans fil PCI en exécutant sudo lshw -class network
  2. Obtenez les informations relatives au modèle de votre carte en fonction de la gamme de produits.
    Par exemple, comme vous pouvez le voir dans la description de la question, le message suivant indique product: RTL8723BE PCIe Wireless Network Adapter , donc le modèle de ma carte est RTL8723BE

    Ou product: RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller donc le modèle de ma carte est RTL8101/2/6E

  3. Donnez l’autorisation sudo chmod 755 /etc/pm/config.d/

  4. Ouvrez ou créez config et ajoutez SUSPEND_MODULES="rtl8723be" (remplacez rtl8723be par votre propre numéro de modèle)
    Ensuite, exécutez
    echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
    (notez que lors du remplacement de rtl8723be avec ma carte qui est RTL8101/2/6E je ne devrais taper que .../modprobe.d/RTL8101.conf et que /2/6E ne devrait pas être écrit)

Enfin, redémarrez votre système.

Maintenant, votre système devrait pouvoir se reconnecter automatiquement après le sommeil, et la connexion wifi n'a jamais été perdue une fois pour toutes.

"Les flèches haut / bas sont probablement un bug de gestionnaire de réseau qui fait que le gestionnaire de réseau pense que le périphérique wifi est en réalité Ethernet.", selon Jeremy31. voir les informations sur le bogue ici Vous devriez être en mesure de résoudre ce problème en installant NetworkManager-1.2.0.

Merci à Jeremy31 d’avoir fourni les solutions.

    
réponse donnée Lixu 06.05.2016 - 05:09
la source
37

J'ai exactement le même problème. Après s'être réveillé, le wifi fonctionne toujours mais les réseaux ne s'affichent pas. Je résous le problème en redémarrant le gestionnaire de réseau.

sudo service network-manager restart

Encore très ennuyeux. J'espère qu'ils vont bientôt résoudre ce problème.

    
réponse donnée eldosoa 28.04.2016 - 06:25
la source
30

C'est un bogue à coup sûr. Bug a été déposé à lien

    
réponse donnée Shinjan 02.05.2016 - 19:22
la source
10

Informations complémentaires: J'ai exactement le même problème que celui décrit dans OP, mais uniquement le problème où l’icône de l’applet nm se transforme en flèches et n’affiche pas les informations wifi. Le wifi fonctionne toujours quand cela se produit.

$ killall nm-applet && nm-applet & 

Est-ce que le truc pour obtenir l’affichage de l’icône à nouveau, c’est juste une solution de contournement pour le moment, au cas où quelqu'un voudrait le mettre dans un script.

Peut confirmer ce problème sur deux ordinateurs distincts exécutant le package xubuntu-desktop.

En outre, les deux ordinateurs sur lesquels j'ai exécuté les dernières cartes wifi Intel. (quelque chose comme AC-7260)

    
réponse donnée Joel Cressy 26.04.2016 - 04:40
la source
6

J'avais le même problème. J'ai corrigé le problème de suspension en créant ce script sur /etc/systemd/system/wifi-resume.service (celui que l'OP envoyait ne fonctionnait que pour la session active ; au redémarrage, il devait être rappelé):

#/etc/systemd/system/wifi-resume.service
#sudo systemctl enable wifi-resume.service
[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Ensuite, lancez simplement cette commande dans le terminal pour l'activer: sudo systemctl enable wifi-resume.service . Cette solution provient de une autre réponse à la question askubuntu , et fonctionne à la fois après la suspension et après le redémarrage.

Cependant, même après que cela a été corrigé, j'obtiens le même comportement que celui qui se produisait lors de la veille lorsque j'essaye de changer les réseaux wifi : le wifi est pratiquement mort, avec les deux flèches, et l'applet dit " périphérique pas prêt ." Je peux redémarrer le wifi en émettant sudo service network-manager restart , mais je ne peux pas changer de réseau.

Est-ce que quelqu'un d'autre fait l'expérience de ceci et / ou a une solution?

    
réponse donnée Rsync 29.04.2016 - 03:20
la source
2

J'utilise LinxuMint 18 Mate (ubuntu16.04) et je suis tombé sur le même problème.

Tout le reste ne fonctionnait pas pour moi sur mon thinkpad T440S.

La seule solution de contournement qui semble fonctionner jusqu’à présent est la mise à niveau du noyau vers la version 4.6.3

  • Accédez à ce site .

  • Obtenez les fichiers suivants:

    linux-headers-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    linux-headers-4.6.3-040603_4.6.3-040603.201606241434_all.deb
    linux-image-4.6.3-040603-generic_4.6.3-040603.201606241434_amd64.deb
    
  • Depuis un terminal, accédez au dossier contenant les fichiers ci-dessus et exécutez:

    sudo dpkg -i *.deb
    sudo reboot
    

Si vous utilisez Virtualbox, exécutez this sudo /sbin/vboxconfig

Si vous souhaitez les supprimer, exécutez:

sudo dpkg --purge linux-headers-4.6.3-040603 linux-headers-4.6.3-040603-generic 

Après quelques tests, la situation est presque la même, j'ai eu le wifi, mais mon nm-applet est incapable de voir tout le WIFI autour de moi. Donc, je ne sais pas si c'est une bonne solution de contournement: -)

    
réponse donnée SteF 09.08.2016 - 11:28
la source
2

Il n’ya pas de solution du tout mais j’ai trouvé un script qui m'a aidé à rester wlan:

#!/bin/bash

# Ping you most used DNS Server and reconnect on fail


while true; do
  if ! ping -c 1 -w 1 8.8.8.8 > /dev/null; then

    # with "sudo iwconfig" you can examine your name of 'wlan0'
    nmcli d connect wlan0

  fi
  sleep 2;
done

pour lancer automatiquement ce script, ouvrez simplement gnome-session-properties et ajoutez-le à la liste.

Le script complet (sans reconnexion) est disponible sur cette page Web .

    
réponse donnée Steffomio 17.10.2016 - 21:28
la source
1

Définissez le code de pays WIFI pour le domaine réglementaire actuel de Kernels s’il n’est pas défini

iw reg get

Pour le définir

sudo nano /etc/default/crda
REGDOMAIN=<ISOCODE>

Redémarrer.

    
réponse donnée Janghou 11.05.2016 - 11:34
la source
1

juste pour ajouter la réponse acceptée (avec quatre étapes)

pour une raison quelconque, une seule étape me suffisait, même si je ne sais pas ce que cela signifie:

echo "options rtl8723be fwlps=N" | sudo tee /etc/modprobe.d/rtl8723be.conf
    
réponse donnée nyxee 24.09.2017 - 02:13
la source

Lire d'autres questions sur les étiquettes