Webcam intégrée non détectée après la mise à jour vers 14.04

33

Hier, j'ai mis à jour mon Thinkpad T530 d'Ubuntu 13.10 à 14.04 (les deux x64). Depuis lors, la webcam intégrée ne fonctionne plus. J'ai essayé de l'utiliser avec Skype et Google Hangouts, mais il est indiqué qu'aucun périphérique vidéo n'est trouvé. J'ai trouvé des solutions mais elles n'ont pas fonctionné. La première chose que j'ai faite a été de vérifier si la webcam intégrée est activée dans les paramètres bios. Puis j'ai trouvé ceci " Comment puis-je faire fonctionner ma webcam avec Ubuntu 14.04? "mais je n'ai pas de périphérique / dev / video *.

Quelqu'un peut-il me dire quoi faire? Merci.

    
posée user278520 06.05.2014 - 11:10
la source

7 réponses

35

Je sais que depuis longtemps vous avez posté.

avec lspci get:

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)

La solution consistait à activer la webcam avec les clés: fn + CAM dans mon cas f10 .

J'espère que cela aide. Cordialement.

    
réponse donnée user256908 18.04.2015 - 01:08
la source
16

J'ai finalement compris ça. Pendant longtemps, je pensais que la caméra Web de mon ordinateur portable était cassée. Il ne s'est même pas présenté lors de l'exécution d'un lsusb ... et ce n'est pas le cas, car la touche de fonction de la caméra Web de l'ordinateur portable ajoute / supprime le périphérique comme s'il était physiquement connecté / déconnecté .

Vous devez taper Fn+<Camera Key> sur votre clavier, puis vous verrez ce qui suit dans les journaux du noyau:

[22219.057985] msi_wmi: Unknown event received [22219.509572] usb 3-1.4: new high-speed USB device number 6 using ehci-pci [22219.646222] usb 3-1.4: New USB device found, idVendor=5986, idProduct=055c [22219.646229] usb 3-1.4: New USB device strings: Mfr=3, Product=1, SerialNumber=2 [22219.646233] usb 3-1.4: Product: BisonCam, NB Pro [22219.646237] usb 3-1.4: Manufacturer: Generic [22219.646239] usb 3-1.4: SerialNumber: 200901010001 [22219.649336] uvcvideo: Found UVC 1.00 device BisonCam, NB Pro (5986:055c) [22219.652486] input: BisonCam, NB Pro as /devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.4/3-1.4:1.0/input/input19

Voici à quoi ressemble la clé sur mon MSI WS-60. Cela varie d'un ordinateur portable à l'autre. Frappez-le et vous devriez regarder /dev/video0 apparaître et disparaître.

    
réponse donnée djsumdog 08.11.2015 - 22:44
la source
9

Installez les packages de pilotes de webcam et les logiciels nécessaires

sudo apt-get install cheese build-essential linux-headers-'uname -r'
    
réponse donnée user224082 14.06.2014 - 16:09
la source
1

Vous pouvez essayer GTK UVC video viewer . Ce logiciel est disponible en software center . Ensuite, allez à Videos et sélectionnez le device . J'ai deux appareils connectés à mon ordinateur. Je garde mon appareil mobile actif, car l'appareil affiche Symphony FT45 . Dans votre cas, choisissez le default device . Cela pourrait résoudre votre problème. Amusez-vous bien.

.

    
réponse donnée mr_azad 17.06.2014 - 14:16
la source
1

J'ai eu un problème similaire - il sera probablement résolu lors de la mise à jour et de la mise à niveau de votre ordinateur.

essayez cette commande:

lsmod            

Dans cet écran, vous trouverez le nom du périphérique, son numéro, la troisième colonne signifie que votre périphérique est activé ou non (0 signifie qu’il n’est pas activé). Voir la capture d'écran ci-dessous:

Pour activer cet appareil, utilisez cette commande:

modprobe <name of the device>

votre noyau lancera automatiquement l'activation après le redémarrage.

Vous pouvez également le faire manuellement via ce fichier /etc/rc.d/rc.modules

    
réponse donnée user297975 05.07.2014 - 11:13
la source
1

Dans mon cas (Lenovo Ideapad Y500, elementaryOS), l’installation des paquets suivants a résolu le problème:

sudo apt-get install libsbigudrv2 libsbigudrv0
    
réponse donnée Kiefer 13.10.2016 - 13:24
la source
0

Si vous changez le gestionnaire d’affichage de Mint de mdm en lightdm votre son et votre vidéo ne fonctionneront pas. J'ai tout essayé sur n'importe quel site Web mais rien n'a fonctionné. Je suis juste revenu à mdm de lightdm et la webcam vidéo était de retour et fonctionnait correctement.

    
réponse donnée peter 13.06.2016 - 08:55
la source

Lire d'autres questions sur les étiquettes