Comment configurer nVidia Optimus / Bumblebee en 14.04

31

Les méthodes précédentes que j'ai utilisées pour configurer Bumblebee sur les distributions basées sur 13.10 ne fonctionnent pas sous Ubuntu 14.04 . Comment configurer Bumblebee et Bumblebee GUI en Ubuntu 14.04 ?

    
posée Pavak Paul 22.04.2014 - 06:12
la source

6 réponses

37

Pour installer bumblebee dans Ubuntu 14.04, exécutez ces commandes dans le terminal

sudo apt-get install bumblebee bumblebee-nvidia primus nvidia-331

Maintenant, vous devez installer Bumblebee GUI pour gérer les applications à ouvrir avec nVidia. Voici les instructions:

Installer l'indicateur d'application Python:

sudo apt-get install python-appindicator

Installer Git:

sudo apt-get install git

Créez un répertoire pour git:

mkdir git && cd git

Découvrez le référentiel:

git clone https://github.com/Bumblebee-Project/bumblebee-ui.git
cd bumblebee-ui
sudo ./INSTALL

Accédez aux applications de démarrage et ajoutez bumblebee-indicator

Maintenant, redémarrez.

    
réponse donnée Pavak Paul 09.12.2015 - 12:40
la source
10

Je suis confronté au même problème depuis un certain temps. J'ai dû faire référence à de nombreux articles en ligne, mais je n'ai jamais eu d'aide. J'ai donc écrit un article sur mon blog et j'ai eu une réponse très positive. De nombreuses personnes ont confirmé que le message était utile. J'ai affiné le blog pour le rendre encore plus facile à utiliser. On pourrait facilement copier et coller les commandes du blog et ça marche bien.

J'ai un ordinateur portable Lenovo Z5070 avec Nvidia 820M et j'ai testé la solution plusieurs fois en installant différentes versions d'Ubuntu 14.04 14.10 et maintenant 15.04. Je voulais juste partager comment j'ai résolu le problème.

Fondamentalement, l’installation de Bumblebee avec Nvidia est la plus délicate avec Ubuntu en raison de la manière dont Bumblebee fonctionne en tant que technologie. Dans le meilleur des cas, il suffirait d’installer le logiciel.

Il suffit que vous utilisiez les pilotes Nvidia-Current qui sont à la version 304, je suppose. Cependant, si vous installez une autre version, vous avez certainement besoin d'aide. C'est là que l'article de blog ci-dessous peut vous aider.

Veuillez vous référer à ici!

L’un de mes messages précédents a été supprimé car la solution Compete n’a pas été publiée. Cependant, je ne suis pas un idiot ou un spammeur. Vous trouverez ci-dessous les détails techniques à 100% relatifs à la mise en œuvre de la solution.

Le dépôt officiel d'Ubuntu ne contient que des pilotes anciens et obsolètes. Je ne l'utilise pas moi-même et je vous suggère de faire de même si vous voulez le dernier pilote NVIDIA sans aucun problème.

Étapes: -

  1. La première étape après l'installation d'Ubuntu est d'installer toutes les mises à jour. Vous pouvez utiliser le programme de mise à jour du logiciel ou simplement exécuter:

    sudo apt-get update && sudo apt-get upgrade
    
  2. Ajoutez le ppa Xorg-edgers en utilisant

    sudo apt-add-repository ppa:xorg-edgers/ppa 
    

    puis

    sudo apt-get update
    sudo apt-get upgrade && sudo apt-get dist-upgrade
    

    C'est l'étape la plus importante. Si vous manquez cela, vous verrez un écran noir après le redémarrage. S'il vous plait, faites ceci car nous utilisons le xorg-edgers ppa. Nous devons nous assurer que tous les paquets requis pour bumblebee et nvidia proviennent du ppa.

  3. Maintenant, installez les pilotes bumblebee et Nvidia avec

    sudo apt-get install bumblebee bumblebee-nvidia primus nvidia-349
    
  4. Ajoutez l’utilisateur actuel au groupe de sécurité bumblebee.

    sudo adduser $USER bumblebee
    

    Pour Ubuntu 15.04 uniquement: vous devez activer manuellement le démon bourdon en utilisant

    sudo systemctl enable bumblebeed'
    
  5. Cela prendra en charge l'installation du logiciel requis sur votre système. Nous devons le configurer. Je peux vous assurer que si vous avez suivi ces étapes jusqu'à présent, la configuration devrait être un jeu d’enfant.

    Nous commençons par activer bbswitch et intel i915 Driver.

     sudo -H gedit /etc/modules 
    

    Ubuntu 15.04: le fichier est /etc/modules-load.d/modules.conf

    Ajoutez ces deux lignes

    i915
    bbswitch
    
  6. Modifiez le fichier de configuration de bumblebee.

    sudo -H gedit /etc/bumblebee/bumblebee.conf
    
    1. ligne 22:

      Driver=nvidia
      
    2. ligne 55:

      KernelDriver=nvidia-349
      
    3. ligne 58:

      LibraryPath=/usr/lib/nvidia-349:/usr/lib32/nvidia-349
      
    4. ligne 61:

      XorgModulePath=/usr/lib/nvidia-349/xorg,/usr/lib/xorg/modules
      
  7. En plus de cela, il y a un autre fichier à éditer.

    sudo -H gedit /etc/modprobe.d/bumblebee.conf
    

    Ajoutez cette ligne à la fin.

    blacklist nvidia-349
    

    Maintenant, vous pouvez reboot . Après le redémarrage, utilisez sudo apt-get install mesa-utils si mesa-utils n'est pas déjà installé.

    primusrun glxinfo | grep OpenGL
    

    Cela devrait vous dire que nvidia-349.16 pilote est utilisé.

Veuillez noter que nvidia-349 est le dernier pilote au moment de la rédaction de ce document. Vous pouvez utiliser une autre version de pilote, en remplaçant le nombre approprié si nécessaire (faites particulièrement attention lors de la modification des fichiers).

    
réponse donnée Rajat Pandita 18.05.2015 - 06:03
la source
5

Je viens d'installer le NVIDIA GTX880M depuis mon ASUS ROG G750JZ via cette URL (site français) Forum Ubuntu FR

Version courte:

sudo apt-get install nvidia-331 nvidia-settings nvidia-prime mesa-utils vdpau-va-driver

Pour l'unité 8 dans Ubuntu

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install prime-indicator
sudo reboot

Après le redémarrage, vous pouvez voir le logo d'Intel ou de NVIDIA dans l'indicateur de votre barre système et vous pouvez basculer entre les deux.

Vous pouvez tester la vitesse de votre carte vidéo avec glxgears.

  • Mon retour de carte Intel +/- 60 fps
  • Mon retour de carte Nvidia +/- 20.000 images / seconde:)

Si vous rencontrez le problème avec prime comme une erreur popup vide dans le panneau nvidia-settings, vous pouvez voir le bogue dans Launch Pad 1310023 . J'ai rencontré un problème similaire et je peux les corriger avec ça:

sudo update-alternatives --config x86_64-linux-gnu_gl_conf
sudo ldconfig -n
sudo update-initramfs -u

puis redémarrez et voyez si cela fonctionne

    
réponse donnée olituks 12.06.2014 - 01:27
la source
1

J'oserai ne pas répondre directement à la question, mais pour proposer une autre solution. J'ai fait une nouvelle installation d'Ubuntu 14.04 la semaine dernière, après sa sortie.

Et je viens de suivre les étapes décrites ici

Pour faire court, je viens de suivre ces étapes:

sudo apt-get purge bumblebee*
sudo apt-get purge libvdpau-va-gl1
sudo apt-get install nvidia-319 nvidia-settings-319 nvidia-prime

Même s'il existe un pilote plus récent, la dernière version de nvidia-settings est 319, j'ai donc suivi les étapes exactes, mais assurez-vous de lire l'article complet car d'autres étapes sont suggérées en cas d'erreur.

:)

    
réponse donnée Adrian Ramirez 25.04.2014 - 23:05
la source
1

Bumblebee ne fonctionne pas pour au moins certaines personnes le 14.04. Si tel est votre cas, vous pouvez utiliser le paquet nvidia-prime décrit dans une autre réponse: Fonctionnement des graphiques hybrides nvidia-prime GT650M

    
réponse donnée monotasker 11.06.2014 - 02:47
la source
1

Pour que bumblebee fonctionne aussi, vous devez l'installer, comme il est mentionné sur le wiki et sur d'autres réponses. ici.

sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic

Toutefois, si votre carte n'est pas prise en charge par les pilotes par défaut (304 au moment de la rédaction de ce document), vous devrez prendre des mesures supplémentaires. J'écris ceci ici parce qu'après de nombreuses heures de frustration, j'ai finalement trouvé une réponse.

Tout d’abord, vous devez installer les derniers pilotes sudo apt-get install nvidia 346 au moment de la rédaction.

Ensuite, vous devez éditer le fichier /etc/bumblebee/bumblebee.conf et remplacer toutes les instances de "nvidia-current" par "nvidia-346". Cela est également couvert dans d'autres réponses .

Ceci, cependant, fera toujours démarrer la machine sur un écran noir. Le problème est que le module NVIDIA est en cours de chargement avant celui d'Intel. Bumblebee crée un fichier /etc/modules/modprobe.d/bumblebee.conf qui liste les nvidia-modules en noir. Ce fichier n'a cependant pas été mis à jour depuis longtemps. Par conséquent, vous devez ajouter les éléments suivants à la fin de ce fichier:

# 346
blacklist nvidia-346
blacklist nvidia-346-updates
blacklist nvidia-experimental-346

Après un redémarrage, vous devriez être prêt à partir. Bien sûr, n'oubliez pas de remplacer "346" par la version du pilote que vous utilisez.

J'ai ouvert un bogue dans le tableau de bord et j'espère que cela sera bientôt corrigé .

    
réponse donnée Stunts 29.10.2015 - 18:33
la source

Lire d'autres questions sur les étiquettes