Comment désactiver la connexion automatique dans LightDM?

33

Je jouais avec les "comptes utilisateurs" et définissais d’une manière ou d’une autre la connexion automatique. Maintenant, quand je lance mon PC, il ne reste plus qu'un seul bouton nommé "login". En cliquant sur ce bouton, vous me connectez directement à mon PC.

Il n’ya pas de musique ou aucun mot de passe n’est demandé lors de la connexion. En guise d’effet secondaire, il me demande séparément le mot de passe du trousseau de clés

Comment désactiver la connexion automatique et rétablir l’identification du mot de passe de connexion / trousseau comme précédemment?

REMARQUE: Tentative de désactivation de la connexion automatique depuis Paramètres système & gt; Les comptes d'utilisateurs ne fonctionnent pas.

Ceci est le contenu de mon /etc/lightdm/lightdm.conf (où j'ai commenté le autologin pour mon nom d'utilisateur mgandhi ):

[SeatDefaults]
greeter-session=unity-greeter
user-session=ubuntu
#autologin-user=mgandhi
    
posée iammilind 22.02.2012 - 06:30
la source

13 réponses

3

Ok, enfin le problème est résolu. J'ai reçu un courriel d'un visiteur occasionnel de l'échange de piles, M. Rafter. Voici le chemin:

  • Exécuter sudo grep nopasswd /etc/*
  • Cela affichera au moins 2 lignes:

    /etc/group:nopasswdlogin:x:112:'<login name>'   
    /etc/gshadow:nopasswdlogin:!::'<login name>'
    
  • Modifiez ces fichiers avec sudo et supprimez uniquement <login name> de ces lignes et enregistrez.

  • Allez dans "Comptes d'utilisateurs" et désactivez la connexion automatique
  • Redémarrez l’ordinateur et maintenant il devrait vous demander à nouveau le mot de passe!
réponse donnée iammilind 21.05.2012 - 05:01
la source
56
gksudo gedit /etc/lightdm/lightdm.conf 

Il affiche du texte comme suit:

[SeatDefaults]  
greeter-session=unity-greeter  
user-session=ubuntu  
autologin-user=username

Solution

  1. Ce <username> correspond à votre nom d'utilisateur particulier qui est automatiquement connecté avec ou sans mot de passe. Supprimez ce nom d'utilisateur et entrez le nom d'utilisateur administratif ou laissez-le vide.
  2. Arrêtez le système. Il retournera à l'écran de sélection de connexion. Mettez simplement le système hors tension et remettez-le en marche.
réponse donnée maxeye 13.06.2012 - 02:07
la source
10

J'ai eu le même problème et il a été résolu par la commande:

sudo gpasswd -d USER nopasswdlogin

où vous devez changer USER par votre nom d'utilisateur.

    
réponse donnée Sell 22.05.2012 - 22:17
la source
9

Configuration du système

Désactiver la connexion automatique

    
réponse donnée One Zero 22.02.2012 - 06:40
la source
5
gksu gedit /etc/lightdm/lightdm.conf

Vous devriez voir quelque chose de similaire à ceci:

[SeatDefaults]
autologin-guest=false 
autologin-user=username
autologin-user-timeout=0
autologin-session=lightdm-autologin
greeter-session=unity-greeter
user-session=ubuntu

Supprimez ou mettez un # au début de chaque ligne contenant l’authentification, puis sauvegardez / quittez et redémarrez pour tester.

    
réponse donnée duffydack 22.02.2012 - 19:15
la source
3

Il est rare que la réponse de @duffydack ne vous corresponde pas ... essayez ceci:

sur un terminal faire:

sudo vi /etc/gdm/custom.conf

ou

sudo nano /etc/gdm/custom.conf

Votre fichier devrait maintenant ressembler à ceci:

[daemon]
AutomaticLoginEnable=false
AutomaticLogin=craig
TimedLoginEnable=false
TimedLogin=craig
TimedLoginDelay=10
DefaultSession=gnome-2d

éditez AutomaticLoginEnable=true à AutomaticLoginEnable=false

c'est une autre option.

    
réponse donnée maniat1k 27.02.2012 - 23:16
la source
3

Accédez à votre terminal et entrez ceci:

passwd

Il vous demandera avec votre nouveau mot de passe Unix et résolu.

Puis, plus tard, vous pouvez accéder à votre compte d'utilisateur et modifier quoi que ce soit.

    
réponse donnée Mar Cejas 27.02.2012 - 13:52
la source
3

J'ai trouvé une réponse:

  • Démarrage avec le CD live Ubuntu.
  • Modifiez lightdm.conf en tant que root.
  • Commentez (avec #) autologon de l'utilisateur.
  • Enregistrez et redémarrez le système.
  • Écran de démarrage de l’utilisateur, sélectionnez Ubuntu et entrez le mot de passe.
  • Démarrez sur le bureau Ubuntu habituel.
réponse donnée David 03.07.2012 - 09:55
la source
3

Je suis en cours d'exécution 12.10 et j'ai tout essayé dans ce fil et rien n'a fonctionné. Finalement, j'ai essayé de supprimer les lignes suspectes dans lightdm.conf et j'ai réussi:

  • Exécutez gksu gedit /etc/lightdm/lightdm.conf

  • Je ne me souviens plus de la ligne exacte car je l'ai depuis supprimée, mais c'est quelque chose comme autologin-lightdm=true . Supprimez-le.

J'espère que ça marche!

    
réponse donnée Jacob Riley 12.01.2013 - 15:13
la source
0

Paramètres système & gt; Comptes utilisateur. Sélectionnez votre utilisateur et désactivez la connexion automatique.

    
réponse donnée Jo-Erlend Schinstad 22.02.2012 - 06:41
la source
0

Ouvrez le fichier / etc / group ( vi /etc/group ) et trouvez le groupe ' nopasswdlogin '. vous verrez votre nom d'utilisateur dans ce groupe. commentez cette ligne (en insérant # avant) ou supprimez simplement la ligne.

Cela devrait le faire.

    
réponse donnée user2234564 07.09.2013 - 21:59
la source
-1

Depuis toi jouait avec "comptes utilisateurs" et j'ai fait la même erreur, je suis entré dans le même trou.

Restez cool.

Il vous suffit de configurer votre système sans mot de passe lorsque vous "jouez".

C'est pourquoi votre système se connecte (automatiquement ou non) sans demander de mot de passe, et c'est la même raison pour laquelle le système de trousseau de clés le demande (la cause n'est pas reçue du système).

Donc, action jackson:

  1. Vérifiez ce dont je parle. Allez dans Menu dans la barre supérieure et choisissez le 1er élément ( Changer de compte d'utilisateur ... ) et le bouton Connexion (que signifie "Vous êtes déjà connecté et aucun utilisateur ne peut choisir". (OH!)
  2. Après avoir cliqué sur Connexion, puis sur Bureau, choisissez à nouveau dans la barre de menus supérieure la commande de déconnexion et déconnectez-vous. Vous verrez un bouton avec votre nom d'utilisateur, pas de bouton "login".
  3. Corriger les choses: définir un nouveau mot de passe. Définissez le même ancien, pour que le trousseau de clés ne soit plus confus, ou il vous demandera à nouveau le mot de passe, après vous être connecté avec le mot de passe fourni. Accédez au même menu de l'élément 1 et choisissez le dernier élément maintenant ( Comptes d'utilisateurs ... ) et sur cette interface graphique, déverrouillez le bouton correspondant sans fournir de mot de passe du tout (il suffit d'entrer fonctionne avec un ancien passe ..), puis LE GRAND TRICK MAGIQUE

CLICK THE PASSWORD BOX (c'est un bouton caché, oh diable UI)

cela ouvre une boîte de dialogue (!) où vous avez probablement appuyé sur l'option "login sans mot de passe" ET avec l'option de connexion automatique activée (en dehors de cette boîte de dialogue, sur l'écran User Accounts). SO: ...

Lorsque vous indiquez à l’ordinateur de se connecter sans mot de passe (ITS PAS identique à Connexion automatique), il fait exactement cela, connectez-vous sans mot de passe. Donc, mot de passe = rien. Le porte-clés devient alors fou. (aha!) Alors, choisissez la bonne option maintenant:

Définissez un mot de passe maintenant

et après avoir fait tous les trucs de mot de passe d’entrée, appuyez simplement sur Entrée, désactivez la connexion automatique, pour ressentir à nouveau le plaisir d’avoir un mot de passe, et si vous voulez le réactiver, un mot de passe à nouveau. = D

J'espère que cela vous aidera à résoudre votre problème. C'était une bonne leçon pour moi. Mauvaise interface utilisateur pour Ubuntu -1 dans ce cas.

    
réponse donnée H_7 03.03.2012 - 18:12
la source
-1

Mon /etc/lightdm/lightdm.conf était fondamentalement vide:

[SeatDefaults]  
user-session=

Il a travaillé avec:

sudo gpasswd -d USER nopasswdlogin
    
réponse donnée user2434119 25.12.2013 - 22:45
la source

Lire d'autres questions sur les étiquettes