14.04 - Le gestionnaire de réseau a cessé de fonctionner

29

Lorsque j'ai démarré mon ordinateur portable, il y avait aucun service réseau , ainsi que aucune icône réseau dans la barre supérieure . Cela donne une erreur lorsque je lance le système d'exploitation comme "Désolé, Ubuntu 14.04 a rencontré une erreur interne" . Lorsque je clique sur détails, il indique que l'erreur est survenue dans le chemin d'accès de l'exécutable usr/sbin/NetworkManager . De même, lorsque j'essaie d'entrer Network dans System Settings , il est dit "les services réseau du système ne sont pas compatibles avec cette version"

Comment puis-je résoudre ce problème choquant?

p.s. Je n'ai pas installé de packages / applications tiers liés au réseau. Seules les mises à jour du système sont installées.

    
posée talha06 13.05.2016 - 07:57
la source

4 réponses

26

J'ai le même problème aujourd'hui.

TLDR: downgrade libnl3 ou upgrade network-manager .

Conformément à cette réponse , le problème est qu’une correction dans libnl3 a provoqué une régression dans network-manager . Ensuite, ce n'était qu'un bogue pour les paquets -proposed , mais je suppose que le bogue a été suffisamment testé pour pouvoir être introduit dans Ubuntu ordinaire;).

Le moyen le plus sûr consiste à faire un pas en arrière et à installer les versions antérieures de libnl-3-200 libnl-genl-3-200 libnl-route-3-200 (voir les détails dans ladite réponse).

Cela vous laisse des paquets dégradés. N'oubliez pas de ne pas les mettre à niveau tant qu'une mise à niveau pertinente de network-manager n'est pas disponible.

Sinon (je l'ai fait), vous pouvez prendre une longueur d'avance et installer une version plus récente de network-manager : pour amd64 ou pour i386 . Vous pouvez télécharger le package sur un système différent et le passer avec une clé USB. Ou téléchargez-le avec votre smartphone et transmettez-le via USB.

Installez-le avec:

sudo dpkg -i network-manager_*.deb

Vous pouvez essayer d’obtenir une mise en réseau en redémarrant NetworkManager:

sudo service network-manager restart

Mais je devais redémarrer pour que l'applet systray soit rétablie.

    
réponse donnée tamkderplar 13.05.2016 - 10:44
la source
9

Cette méthode fonctionne si vous pouvez vous connecter par câble Ethernet.

Utilisez le mode de récupération intégré à Ubuntu pour mettre à niveau Network Manager.

Étape 1

Utilisez la touche fléchée vers le bas pour sélectionner Options avancées pour Ubuntu et appuyez sur Entrée

Étape 2

Utilisez la touche fléchée vers le bas pour sélectionner le dernier noyau Linux avec le mode de récupération et appuyez sur Entrée

J'ai utilisé Ubuntu, avec Linux 4.2.0-36-generic (mode de récupération)

Etape 3

Utilisez la touche fléchée vers le bas pour sélectionner Réseau Activer la mise en réseau et appuyez sur Entrée

Étape 4

Appuyez sur Entrez pour OK pour remonter le système de fichiers

Étape 5

Utilisez la touche fléchée vers le bas pour sélectionner dpkg Réparer les paquets cassés et appuyez sur Entrée

Étape 6

Il vous sera demandé de télécharger le dernier Network Manager avec Continuer [O / n] . Entrez la lettre y pour "yes" et appuyez sur Enter . Quand toutes les opérations seront terminées, il sera dit

  

Terminé. S'il vous plaît appuyez sur Entrée

Appuyez donc sur Entrez à nouveau.

Étape 7

Sélectionnez Reprendre Reprendre le démarrage normal et appuyez sur Entrée

Étape 8

Appuyez sur Entrez et continuez à démarrer. À l’écran de connexion, ne vous connectez PAS à la place, faites un redémarrage NORMAL (cliquez sur l’icône d’arrêt en haut à droite de l’écran).

Après le redémarrage du PC, connectez-vous.

Les connexions réseau étaient de retour lorsque j'ai effectué ces étapes.

    
réponse donnée Jit 13.05.2016 - 16:29
la source
3

Vous pouvez le faire de cette façon pour résoudre le problème:

Télécharger le fichier:

  • libnl-3-200_3.2.21-1_XXX.deb
  • libnl-route-3-200_3.2.21-1_XXX.deb
  • libnl-genl-3-200_3.2.21-1_XXX.deb

    OS 32 bits: XXX = i386 || OS 64 bits: XXX = amd64

Lien: lien

À eux dans un dossier et installez-les avec la commande:

  

sudo dpkg -i lib * .deb

Puis redémarrez. Fait: 3

    
réponse donnée Vickute 13.05.2016 - 10:31
la source
2

Je ne recommanderais pas de mettre à niveau des paquets ou d’installer de nouveaux paquets à la main - cela entraînera inévitablement des problèmes de version par la suite. La meilleure solution à ce problème consiste simplement à mettre à niveau le package network-manager .

La première chose à faire est de vous connecter manuellement à Internet; tant que network-manager est mort, cela ne signifie pas que vous ne pouvez pas vous connecter.

1 . Ouvrez un terminal et éditez le fichier interfaces :

sudo pico /etc/network/interfaces

Ajoutez les lignes suivantes, elles indiquent que l’interface eth0 ne doit plus être gérée:

allow-hotplug eth0
iface eth0 inet dhcp

2 . Avec cela, la connexion peut être lancée manuellement:

sudo ifup eth0

Notez qu'il n'y aura pas de notification dans le panneau - il s'agit d'une connexion manuelle. Essayez-le avec ping ou lancez votre navigateur internet.

3 . Mettez maintenant à jour les métadonnées apt :

sudo apt-get update

Et mettez à jour le package network-manager :

sudo apt-get upgrade network-manager

4 . Assurez-vous que la version 0.9.8.8-0ubuntu7.3 est installée:

apt-cache show network-manager

5 . Maintenant, éditez à nouveau le fichier interfaces et supprimez ou commentez les lignes ajoutées à l'étape 1.:

sudo pico /etc/network/interfaces

6 . Enfin, redémarrez le système.

    
réponse donnée Luís de Sousa 17.05.2016 - 09:50
la source

Lire d'autres questions sur les étiquettes