ATTENTION: les packages suivants ne peuvent pas être authentifiés. 'apt-key update' ne fonctionne pas

31

J'essaye d'installer bitcoind simplement en faisant sudo apt-get install bitcoind , mais je reçois cette erreur en disant que les paquets suivants n'ont pas pu être authentifiés:

libdb5.1++ libcrypto++9 bitcoind

Je peux simplement les installer sans les authentifier, mais comme ce programme peut gérer de l'argent, j'aimerais qu'ils soient les bons. J'ai donc trouvé cette solution ici sur AskUbuntu, qui suggère de procéder comme suit:

$ sudo apt-key update
$ sudo apt-get update

Après la première commande, il répertorie quatre touches dont il est dit que toutes restent inchangées. La deuxième commande fait simplement comme d'habitude, mais elle se termine par un message indiquant qu'il y avait une erreur GPG. Après quelques blabla, on dit alors que les signatures suivantes sont invalides (traduites librement du néerlandais):

BADSIG 16126D3A3E5C1192 Ubuntu Extras Archive Automatic Signing Key <[email protected]>
BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <[email protected]>

Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible:

NO_PUBKEY 1F968B3903D886E7

Et les suggestions suivantes étaient invalides:

BADSIG E585066A30C18A2B Opera Software Archive Automatic Signing Key 2013 <[email protected]>

Et le fait d’obtenir des données à l’adresse suivante a échoué:

 http://extras.ubuntu.com/ubuntu/dists/precise/Release

Quelqu'un sait-il ce que je peux faire pour résoudre ce problème?

    
posée kramer65 04.01.2014 - 00:36
la source

2 réponses

22

Vous devez ajouter la clé de pub manuellement.

La commande est

sudo apt-key adv --recv-key --keyserver keyserver.ubuntu.com «key number»

où «numéro de clé», vous devez le remplacer par la clé manquante.

Par exemple dans cette erreur que vous avez reçue

NO_PUBKEY 1F968B3903D886E7

vous pouvez faire

sudo apt-key adv --recv-key --keyserver keyserver.ubuntu.com 1F968B3903D886E7
sudo apt-get update

De cette façon, vous téléchargerez cette clé dans votre trousseau de clés à partir du serveur de clés (keyserver.ubuntu.com)

À propos de l'erreur BADSIG, consultez cette réponse ici

    
réponse donnée Nick Thom 04.01.2014 - 00:49
la source
1

Peut-être pas la réponse directe, mais il est nécessaire de mettre à jour le programme: update-manager-core . Si des utilisateurs obtiennent l'erreur que les packages ne peuvent pas être authentifiés lors de l'exécution de gestionnaire de mises à jour , la mise à jour de ce programme met également à jour update manager et fournit une réponse très rapide.

BTW, j'ai utilisé synaptic pour effectuer cette mise à jour, si cela peut vous aider. Une fois la mise à jour traitée, le gestionnaire de mises à jour fonctionnait normalement.

voir 1204_HWE_EOL dans le wiki Ubuntu

    
réponse donnée Ricgal 11.03.2015 - 21:11
la source

Lire d'autres questions sur les étiquettes