Pourquoi Xorg prend-il autant de mémoire et de CPU?

30

J'ai récemment réinstallé Ubuntu 11.04 Natty après une panne de disque dur massive.

Maintenant, pour une raison quelconque, compiz et Xorg décident que c'est une idée amusante de commencer à consommer ma mémoire vive et mon CPU - Go en Go. Démarre à des montants normaux, mais monte rapidement à 1-2 + Go et commence à utiliser la majeure partie de mon processeur. Cela ne s'est jamais produit auparavant, mais aucun de mes matériels n'a vraiment changé. La seule différence étant que j'ai installé 11.04 proprement, alors qu'auparavant j'avais mis à jour depuis 10.10.

Par exemple: Redémarré mon ordinateur hier soir. Seul le programme en cours d'exécution est Transmission. Revenez ce matin - Xorg utilise 1,5 Go de RAM et plus de 50% de mon processeur. Il n'y a rien d'autre en cours d'exécution ou installé. Je n'ai activé aucun plug-in de Compiz. Qu'est-ce que donne?

J'utilise la version 11.04 sur un processeur 4x AMD Athlon (tm) II X4 640 avec 8 Go de RAM. J'utilise le GPU ATI Radeon HD3300 intégré avec le pilote AMD Catalyst 11.5 - mais ce problème se produit également avec les pilotes fglrx intégrés 11.4 AND.

Je peux donner d’autres journaux ou sysinfo si nécessaire.

    
posée Philippe Fenderson 22.05.2011 - 19:39
la source

5 réponses

6

Mon Xorg ne consommait pas beaucoup de processeurs, mais environ un jour après, l’ordinateur était saturé, il était gonflé à 1,2 gigaoctets de mémoire. La seule façon de corriger cela était un redémarrage difficile. Après avoir essayé de désactiver les pilotes NVidia, de passer à la cannelle, de passer à gdm et enfin de me débarrasser de la foutue (c'était juste pour que je me sente mieux), j'ai remarqué que lorsque je passais à un tty de console , F6) pendant un redémarrage du service gdm / lightdm, il y avait beaucoup de messages d'erreur défilant sur l'écran. Notez que je n'avais fait que passer à ALT + F1, je ne m'étais pas encore connecté.

Les messages signalaient que ma carte tuner TV USB n'était pas correctement initialisée. Ces messages continuaient à défiler comme si le système était bloqué dans une boucle infinie en essayant en permanence d’initialiser la carte tv (et bien sûr son échec à chaque fois). Comme prévu, dès que j'ai déconnecté la carte TV usb, les messages ont cessé, mais à mon grand étonnement, Xorg a cessé de gonfler aussi. Juste pour être sûr, j'ai reconnecté le tuner TV USB et les messages d'erreur sont apparus, et encore une fois, Xorg a commencé à gaver de mémoire comme un SUV se remplissant dans une station-service.

Mais, juste avant que les villageois (les utilisateurs d'ubuntu a.k.a.) soient sur le point de briser leur équipement usb dysfonctionnel et de casser le fournisseur de matériel usb dysfonctionnel, il y a un changement soudain dans le scénario. Ce n'est pas réellement la carte tv usb qui a causé tous ces problèmes. La carte tv n'était que le symptôme et non la source du problème. L'intrigue se corse...

Ayant utilisé cette carte tv auparavant sans incident, j'ai mieux regardé le message d'erreur se plaignant de la carte tv. Il y avait une autre ligne se plaignant du port USB du hub usb, où j'ai branché ma carte tv. Hmmm, je venais d'acheter ce hub. Alors j'ai essayé de brancher la carte tv dans un port USB directement sur la carte mère. Et tout a bien fonctionné! Pas de messages d'erreur, et pas de ballonnement Xorg. Donc, à la fin, le problème était le suivant:

Xorg a consommé de la mémoire à cause des erreurs d'initialisation d'un périphérique USB (et dans mon livre, c'est un bug sérieux). Étant donné que beaucoup de personnes signalent des problèmes avec Xorg dans Ubuntu 12.04, je suggère que vous jetiez également un œil à vos périphériques USB. Mon tv-card n’a pas pu être initialisé lorsqu’il était branché sur mon nouveau hub usb, et c’était la cause du problème. Le mettre dans un port USB séparé sur la carte mère a résolu le problème.

P.S. Le hub usb est probablement compatible avec Linux ou devrait être remplacé par un autre qui a son propre adaptateur au lieu d’être alimenté par le bus USB de l’ordinateur (voir Le concentrateur USB ne fonctionne pas correctement Ubuntu 12.04 ). Ma web-cam ne fonctionne pas non plus lorsque je le branche sur le hub. Cela fonctionne si branché sur un port USB sur la carte mère. Toutefois, notez que lorsque je le branche dans le hub usb, dmesg signale que la webcam est correctement reconnue et initialisée (bien que cheese ne me donne qu’une image noire) et qu’il n’ya aucun message d’erreur, Xorg ne pas remplir la mémoire de l'ordinateur.

P.P.S. J'invite les villageois désemparés à se rassembler devant la grange à un œil de Tim, pour lancer leurs hubs usb dysfonctionnels dans un grand feu de joie festif. Lorsque l'incendie s'est accumulé, nous lancerons également le fournisseur de concentrateur USB. De la bière gratuite pour tout le monde! Mua ha ha ha ha (rire profond de la voix)

: -)

    
réponse donnée ahat 06.11.2012 - 10:46
la source
2

Si vous utilisez Compiz dans un environnement classique, essayez d'installer Compiz Fusion Icon et sélectionnez l'option appropriée pour l'intégration du gestionnaire de fenêtres ...

Le jeu par défaut est:

  • Compiz
  • Metacity
  • Xfvm

existe également une option pour:

  • Rendu indirect

Compiz inclut propre gestionnaire de fenêtres et fonctionne mieux avec des capteurs matériels, en cas d'utilisation de "jeu différent de" plugins / paramètres sélectionnés / activés / désactivés " dans Gestionnaire de paramètres CompizConfig .

Options

Metacity et Xfvm destinées respectivement à GNOME (Classic) et Xfce .

Bien que cela dépende du choix du jeu de configuration de Compiz et des fournisseurs de matériel, il peut donner des résultats très différents.

L'icône Compiz Fusion permet de réactiver rapidement les gestionnaires, mais ce n'est pas une solution, mais un bon outil de testeur, à mon avis ...

D'autres solutions peuvent également être utiles en utilisant des capteurs-lm mis à jour depuis

lien

en raison de la mise à niveau de votre système contre certains pilotes qui ne sont pas "au courant":)

Certains pilotes lisent des données à partir de capteurs matériels avec des valeurs incorrectes en utilisant d'anciennes bibliothèques de capteurs ... la vitesse du ventilateur a doublé etc.

  

Faites attention lors de la mise à niveau de lm-sensors et complétez cette procédure avec prudence!

réponse donnée swift 27.12.2011 - 00:08
la source
1

J'ai eu un problème similaire avec Kubunutu 11.10. J'ai résolu le problème en désactivant les effets de fantaisie. J'ai aussi ajouté un ppa pour les mises à jour de xorg ( lien ), mais cela n’a pas été le cas pour moi. faites la différence.

Mon problème est probablement dû au fait que le pilote Matrox n’est pas pris en charge par la version 11.10, ainsi que la version 3 du noyau.

    
réponse donnée Ian Wood 16.12.2011 - 15:40
la source
1

J'ai le même problème, mais lorsque iSatt System Monitor affiche toutes les propositions, il a été montré que xorg utilisait la moitié du processeur. J'ai été irrité par ce bogue .

Mais dans le commentaire 8, il s’en est tiré avec:

sudo rmmod ums_realtek

Cela a fonctionné pour moi et cela a fait que xorg n'utilisait que 5 à 10% de processeurs, mais cela n'aidait pas sur l'utilisation de processeurs mystiques.

    
réponse donnée NatureShade 17.11.2012 - 13:20
la source
0

Il y a une fuite de mémoire dans votre xorg, il est difficile de dire exactement quel est le problème sans que vous publiez vos journaux xorg à partir de / var / log / et de vos erreurs utilisateur xorg dans votre dossier personnel (utilisez show ).

La meilleure suggestion que je puisse vous proposer est de réinstaller une version d'Ubuntu qui fonctionne. Essayez d'abord avec une clé USB ou un CD-ROM et laissez-le fonctionner quelques instants. Essayez de trouver le bon point et restez avec ça.

    
réponse donnée Martin Owens -doctormo- 22.09.2011 - 14:57
la source

Lire d'autres questions sur les étiquettes