Comment configurer une adresse IP statique dans Ubuntu Server 12.04?

31
sudo apt-get update 
sudo apt-get upgrade
  1. ifconfig

  2. sudo nano /etc/network/interfaces

    auto eth0
    iface eth0 inet static
    address 192.168.1.150
    netmask 255.255.255.0
    network 192.168.2.0
    broadcast 192.168.1.255
    gateway 192.168.2.1
    safe
    
  3. sudo nano /etc/resolv.conf

    Do not edit this file by hand --your changes will be overwritten
    # I add this 
    nameserver 8.8.8.8
    nameserver 8.8.4.4
    
  4. sudo apt-get remove dhcp-client

  5. sudo /etc/init.d/networking restart

    *Running /etc/init.d/networking restart is deprecated because it may 
    not enable again some interfaces
    *Reconfiguring network interfaces...
    ssh stop/waiting
    ssh start/running,process 1438
    

Où est l'erreur? Je ne suis pas paresseux. Je l'ai googlé pendant 3 jours mais sans résultats. J'ai tout essayé.

Après le redémarrage, le fichier /etc/resolv.conf clignote à l’état d’origine.

    
posée bemonolit 27.08.2012 - 12:13
la source

3 réponses

16

Cela comporte deux questions indépendantes:

resolv.conf entrées réinitialisées après un redémarrage

Le mode de fonctionnement de /etc/resolv.conf a été modifié dans Ubuntu 12.04. Ceci est dû à l'implémentation de foundations-p-dns-resolving  comme décrit ici lien pour surmonter certaines limitations de resolv.conf statique.

Ici vous pouvez obtenir plus de détails: lien

Vous pouvez remplacer la nouvelle fonctionnalité en supprimant le lien symbolique /etc/resolv.conf et en créant un fichier nommé /etc/resolv.conf . Mais avant cela, référez-vous au lien que j'ai donné ci-dessus et voyez pourquoi il est fortement déconseillé.

Conflit entre l’adresse IP et le réseau et la passerelle (configuration d’une adresse IP statique) En outre, comme pgschk l’a souligné, votre adresse IP ne correspond pas aux entrées de la passerelle et du réseau. Mais cela ne fait pas que /etc/resolv.conf passe à l'état d'origine, mais la raison que j'ai mentionnée ci-dessus.

    
réponse donnée Jamess 27.08.2012 - 14:37
la source
6

Votre adresse de passerelle se trouve dans un sous-réseau différent de votre adresse IP locale:

adresse 192.168. 1 .150 passerelle 192.168. 2 .1

L’adresse réseau a également été spécifiée dans le sous-réseau .2 également:

réseau 192.168. 2 .0

Utilisez-vous le sous-réseau 192.168.1 / 24 ou 192.168.2 / 24?

Modifier: A propos de votre resolv.conf: Ce fichier est principalement mis à jour par différents packages (en fonction de votre configuration). Essayez de spécifier les serveurs de noms dans votre fichier / etc / network / interfaces:

dns-nameservers 8.8.8.8 8.8.4.4

    
réponse donnée pgschk 27.08.2012 - 14:24
la source
1

Vous pouvez essayer cette option:

  • Supprimez /etc/resolv.conf , puis créez un nouveau resolv.conf .

  • sudo nano /etc/resolv.conf après l'ajout de l'indicateur:

  • sudo chattr +i /etc/resolv.conf - avec cet indicateur +i , même root ne peut pas toucher ce fichier. Mais si vous voulez changer le serveur de noms, changez l'indicateur pour être:

  • sudo chattr -i /etc/resolv.conf puis ajoutez votre nouveau nameserver .

Ensuite, essayez de redémarrer et de voir ce qui se passe:).

J'espère que cela résout votre problème.

    
réponse donnée Hary Gembul 02.05.2013 - 06:41
la source

Lire d'autres questions sur les étiquettes