Comment réparer le démarrage très lent d'Ubuntu?

32

Quand je lance ma nouvelle copie d’Ubuntu sur ma plate-forme personnalisée avec 4 Go de mémoire vive DDR3 et un processeur Intel Core i7 de 3 GHz, cela prend environ une minute et demi à l’écran de chargement violet, puis après la connexion il faut un certain temps pour que les icônes apparaissent à l'écran. Cet ordinateur pourrait fonctionner et démarrer Windows 7 plus rapidement, donc j'ai un problème ici.

    
posée Neal 16.04.2011 - 19:19
la source

8 réponses

18

Je vérifierais System & gt; Administration & gt; Journal Viewer & gt; Messages . Il peut montrer quelque chose de retard ou de décrochage avant d’avoir un arrière-plan du processus lors du démarrage. Le journal a un horodatage avec secondes. Recherchez les lacunes excessives dans les secondes ,, etc. et les éléments répétés. Si votre boîte a été démarrée plusieurs jours de suite, vous pourrez peut-être comparer les journaux précédents.

    
réponse donnée peck 16.04.2011 - 22:31
la source
18

Le plus simple serait d'ouvrir le terminal et d'écrire "dmesg" pour rechercher les lacunes proposées par Peck. La sortie serait moins verbeuse que celle des messages. Vous verrez les horodatages entre crochets "[]".

Ceci est clairement un bug. Avec ce système, vous ne devriez pas avoir un démarrage de plus de 10 secondes.

    
réponse donnée AlMehdi 03.05.2011 - 04:54
la source
7

Installez bootchart et pybootchartgui et téléchargez le fichier .png dans /var/log/bootchart .

Quoi qu’il en soit, il vous montrera la procédure complète du système jusqu’au démarrage complet. Désactiver les packages longs mais non requis. Installez l'application bug pour cela.

Tous ces paquets peuvent être installés de cette manière:

sudo apt-get install bootchart pybootchartgui

Exécutez également la commande:

sudo sed -i 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/*.desktop

Maintenant, ouvrez "Applications de démarrage" et décochez tout ce que vous ne souhaitez pas charger lors du démarrage.

    
réponse donnée TomKat 23.10.2012 - 14:28
la source
5

Vous pouvez commencer par désactiver certains services au démarrage, tels que Bluetooth et Remote Desktop et Gnome Login Sound.

Allez à Système & gt; Administration & gt; Applications de démarrage pour désélectionner les éléments à exécuter au démarrage et voir si vous remarquez un changement dans le temps de démarrage.

    
réponse donnée scouser73 16.04.2011 - 22:11
la source
4

J'ai résolu ce problème en entrant dans le BIOS puis en désactivant l'option du contrôleur ACHI SATA et en définissant le contrôle SATA en mode "compatibilité". Cela a bien fonctionné pour mon Toshiba NB200!

    
réponse donnée Papadopoulos Geοrgios 23.10.2012 - 14:02
la source
3

Croyez-le ou non c'est la sortie du texte.

ouvrez un terminal et lancez:

sudo nano /etc/default/grub

changez la ligne:

GRUB_CMDLINE_LINUX_DEFAULT=""

à

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

exécuter:

sudo update-grub2

Il a réduit de 10 secondes mon temps de démarrage de 15 secondes.

    
réponse donnée Cory 03.07.2014 - 00:00
la source
0

La désinstallation de hp-lip 3.14.1 a aidé avec le même problème. J'ai utilisé Ubuntu-Tweek pour tout nettoyer.

J'utilise Ubuntu 12.04. hp-lip était requis pour mon imprimante (HP Envy 4500).

    
réponse donnée user252311 25.02.2014 - 22:16
la source
-2

dans le menu du BIOS, changez le contrôleur SATA en compatible. travaillé sur Lenovo z500. ce n'est pas un miracle, mais cela stimule considérablement le démarrage. tuez également TOUTES les applications de démarrage. Les environnements de bureau n'ont aucune importance, du moins pas beaucoup. sur mon ordinateur, Unity, Gnome Shell et XFCE prennent presque le même temps pour démarrer, alors ne vous efforcez pas de changer votre DE.

    
réponse donnée Iman Akbari 14.10.2013 - 22:19
la source

Lire d'autres questions sur les étiquettes