Comment activer l'accès root ssh sur Ubuntu 14.04

118

Je voudrais activer l’accès racine ssh sur Ubuntu 14.04. L'édition du /etc/ssh_config (PermitRootLogin yes) n'a rien affecté.

    
posée user283163 19.05.2014 - 15:48
la source

5 réponses

178

Il ne suffit pas d’ajouter un mot de passe pour root pour Ubuntu 14.04 Server.

Vous devez également modifier /etc/ssh/sshd_config et commenter la ligne suivante:

PermitRootLogin without-password

Juste en dessous, ajoutez la ligne suivante:

PermitRootLogin yes

Puis redémarrez SSH:

service ssh reload

Pour Ubuntu 16.04.1 LTS (GNU / Linux 4.4.0-59-générique x86_64), PermitRootLogin without-password a été remplacé par PermitRootLogin prohibit-password .

    
réponse donnée bdep 27.06.2014 - 23:12
la source
36

Vous devez configurer un mot de passe pour le compte root, puis cela fonctionnera.

sudo passwd

Entrez le même mot de passe deux fois.

P.S. Après avoir modifié / etc / ssh / sshd_config, n'oubliez pas de recharger le serveur openssh.

sudo service ssh reload
    
réponse donnée cioby23 19.05.2014 - 15:51
la source
16

Avec le serveur Ubuntu 14.04.

Définir le mot de passe

sudo passwd

Modifications dans / etc / ssh / sshd_config

Modifier PermitRootLogin

PermitRootLogin yes

Vous devrez peut-être aussi vérifier la valeur de PasswordAuthentication. S'il est défini sur no, définissez-le sur yes

PasswordAuthentication yes

Puis redémarrez SSH:

service ssh restart

    
réponse donnée Pandurang Patil 01.02.2017 - 10:27
la source
3

Pour 14.04, vous devriez commenter la ligne dans / etc / ssh / sshd_config

#StrictModes yes
    
réponse donnée Jitendra 03.08.2014 - 19:55
la source
-1

Pour moi, aucune de ces étapes n’a fonctionné, j’ai même essayé quelque chose que je n’aurais jamais essayé d’utiliser pour autre chose qu'un jouet vm: PermitRootLogin without-password

La seule chose qui a fonctionné pour moi était de désactiver le module PAM pour cela:

UsePAM no

Cette option est normalement à la toute fin du fichier. Pour être honnête, je ne connais pas les inconvénients réels de cela, mais comme vous n'êtes pas censé autoriser la connexion root en ligne, je suppose que c'est correct pour un dev-vm privé.

Néanmoins, définissez toujours un mot de passe fort. Non, ce n'est pas une exception. Pas même seulement cette fois ...

    
réponse donnée Kjellski 27.08.2014 - 21:31
la source

Lire d'autres questions sur les étiquettes