Comment démarrer en mode texte réel?

30

J'ai trouvé des moyens de désactiver gdm ou lightdm ou ce que 11.10 utilise, mais je ne peux pas trouver un moyen d'obtenir un véritable démarrage en mode texte. Je veux voir passer tous les messages du noyau au démarrage, pas un écran violet stupide.

J'ai finalement arrêté le gestionnaire de bureau, mais maintenant je reçois un écran violet pendant un moment, puis il passe à TTY1. Après cela, j'obtiens environ la moitié de l'écran des messages du noyau (la fin de la séquence de démarrage; des éléments sur l'exécution des scripts d'initialisation, etc.) et l'invite de connexion. Je l'ai fait en changeant GRUB_CMDLINE_LINUX_DEFAULT et GRUB_CMDLINE_LINUX en text en /etc/defaults/grub .

En fait, ma principale question est la suivante: qu'est-ce qui met cet écran violet malsain en place au démarrage et comment le désactiver?

    
posée Caleb1994 02.01.2012 - 19:37
la source

4 réponses

33

Modifier dans /etc/default/grub

# Stops the ubuntu purple screen
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

# Uncomment to disable graphical terminal (grub-pc only) 
GRUB_TERMINAL=console

Ensuite, exécutez un sudo update-grub .

    
réponse donnée shantanu 02.01.2012 - 19:54
la source
3

Pour vous assurer que cet écran violet malsain ne s'affiche plus après le démarrage, procédez comme suit sur le fichier /etc/default/grub :

  • sudo vi /etc/default/grub
  • Appuyez sur i pour accéder au mode d'édition vi.
  • Décommentez la ligne qui lit #GRUB_TERMINAL=console en supprimant le premier #
  • Appuyez sur Esc pour quitter le mode d'édition vi.
  • Tapez : w q pour enregistrer la modification apportée au fichier /etc/default/grub et quitter vi
  • Mettez à jour /boot/grub/grub.cfg pour que votre modification soit appliquée en exécutant sudo update-grub

    Si votre ordinateur utilise systemd, vous devez indiquer à systemd d'ignorer l'interface graphique de connexion par défaut:

  • sudo systemctl enable multi-user.target --force

  • sudo systemctl set-default multi-user.target


  • Redémarrez votre ordinateur: sudo reboot

Maintenant, cet écran mauve violet ne sera plus jamais affiché.

N'oubliez pas que vous devez mettre à jour /boot/grub/grub.cfg pour que vos modifications soient appliquées.

    
réponse donnée Daniel Okwufulueze 09.12.2016 - 11:23
la source
1

Dans l'éditeur de menu de démarrage Grub (c'est-à-dire le menu qui s'affiche lorsque votre ordinateur démarre), vous pouvez essayer de commenter la ligne "load_video".

    
réponse donnée VeeTheSecond 16.11.2013 - 05:55
la source
1

Vous pouvez également empêcher le noyau de modifier les modes vidéo, ce qui peut être problématique, surtout si l’invite de connexion n’est pas visible ou si elle est partiellement masquée. Ajoutez le paramètre GRUB_CMDLINE_LINUX_DEFAULT="nomodeset" à / etc / default / grub:

#GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
#GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR='lsb_release -i -s 2> /dev/null || echo Debian'
#for text mode boot up... and also uncomment the "console" terminal
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"
#GRUB_CMDLINE_LINUX="text"
GRUB_TERMINAL=console
    
réponse donnée PrgWiz 02.11.2016 - 16:46
la source

Lire d'autres questions sur les étiquettes