Unité manquante? Impossible de voir les panneaux supérieurs ou latéraux [dupliquer]

30

Je viens de supprimer certains effets en utilisant ccsm, je suis passé au pilote propriétaire AMD, j'ai redémarré et après ma connexion, le panneau d’unité n’est plus là. Si j'appuie sur la touche windows ou la touche alt, rien ne se passe. Je peux appuyer sur Ctrl + Alt + T pour obtenir un terminal (et ainsi lancer des applications via la ligne de commande).

Est-ce que quelqu'un sait comment je peux résoudre ce problème? Quels journaux dois-je publier ici pour obtenir de l'aide?

Modifier # 1:

Comme suggéré par @cprofitt, je viens de lancer:

dconf reset -f /org/compiz/ && setsid unity

Je vois des messages compiz dans le terminal maintenant:

unity-panel-service: no process found
compiz (core) - Info: Loading plugin: core
compiz (core) - Info: Starting plugin: core
compiz (core) - Info: Loading plugin: ccp
compiz (core) - Info: Starting plugin: ccp
compizconfig - Info: Backend     : gsettings
compizconfig - Info: Integration : true
compizconfig - Info: Profile     : unity
compiz (core) - Info: Loading plugin: composite
compiz (core) - Info: Starting plugin: composite
compiz (core) - Info: Loading plugin: opengl
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  155 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  23
  Current serial number in output stream:  23
compiz (core) - Info: Unity is not supported by your hardware. Enabling software rendering instead (slow).
X Error of failed request:  BadRequest (invalid request code or no such operation)
  Major opcode of failed request:  155 (ATIFGLEXTENSION)
  Minor opcode of failed request:  66 ()
  Serial number of failed request:  23
  Current serial number in output stream:  23
compiz (core) - Info: Unity is not supported by your hardware. Enabling software rendering instead (slow).
compiz (core) - Info: Starting plugin: opengl
Compiz (opengl) - Fatal: glXQueryExtensionsString is NULL for screen 0
compiz (core) - Error: Plugin initScreen failed: opengl
compiz (core) - Error: Failed to start plugin: opengl
compiz (core) - Info: Unloading plugin: opengl
compiz (core) - Info: Loading plugin: compiztoolbox
compiz (core) - Info: Starting plugin: compiztoolbox
compiz (core) - Error: Plugin 'opengl' not loaded.
    
posée hafichuk 22.10.2012 - 04:36
la source

6 réponses

51

Essayez ce qui suit:

Tapez ce qui suit dans un terminal:

dconf reset -f /org/compiz/

alors

setsid unity

S'il s'agit d'un problème lié aux paramètres Unity qui réinitialiseront votre configuration par défaut.

J'espère que ça aide.

    
réponse donnée cprofitt 22.10.2012 - 04:45
la source
10

J'ai eu ce même problème ce matin et après des heures de dépannage, j'ai compris quel était le problème. Le problème est avec Compiz, mais vous ne pouvez pas simplement fermer Compiz et le redémarrer, le problème sera toujours là. ce que j'ai fait est la connexion et bien sûr l'unité ne sera pas affichée.

Appuyez simplement sur Ctrl + Alt + T pour ouvrir un terminal et tapez ccsm pour charger le gestionnaire de paramètres Compiz Config.

Maintenant, vous devez rechercher le plug-in Unity d'Ubuntu, cliquez dessus et vous remarquerez qu'il n'est pas activé, activez-le, et qu'il provoquera des conflits avec les fenêtres, lisez-les et cliquez sur les options vouloir et l'unité seront de retour!

Pour moi, quand j'ai cliqué sur activer et fermer cette fenêtre, cela n'a pas fonctionné la première fois mais je l'ai fait une deuxième fois, et ça a fonctionné!

    
réponse donnée Christopher Champion 01.09.2013 - 14:09
la source
5

J'ai donc fini par réinstaller lightdm & amp; ubuntu-desktop selon Impossible d'installer des pilotes propriétaires ATI dans 12.10

sudo apt-get purge fglrx lightdm && sudo apt-get install lightdm ubuntu-desktop

Et puis redémarré

D'après ce que je peux dire, le pilote AMD est maintenant installé.

[email protected]:~$ fglrxinfo 
display: :0.0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 5700 Series 
OpenGL version string: 4.2.11903 Compatibility Profile Context

[email protected]:~$ fgl_glxgears 
Using GLX_SGIX_pbuffer
1499 frames in 5.0 seconds = 299.800 FPS
1663 frames in 5.0 seconds = 332.600 FPS
    
réponse donnée hafichuk 22.10.2012 - 05:15
la source
3

J'ai installé Ubuntu avec l'installateur Windows sur un Compaq Presario 7000US (ancien ordinateur) sur lequel j'exécute actuellement WinXP. Je suis tombé sur ce problème et j'étais sur le point d'abandonner Ubuntu à cause de ce même problème.

Lorsque j'ai essayé sudo apt-get purge fglrx , il est retourné avec une note disant que le paquet n’avait pas été supprimé car il n’était pas installé, alors je l’ai fait

sudo apt-get install fglrx

Il a téléchargé le paquet et l'a installé. Après que cela ait été fait, la barre latérale (est-ce que c'était son nom?) Est apparue.

Cela semble un peu lent mais maintenant cela me donne plus d’incitation à continuer à travailler sur cette machine.

    
réponse donnée Gmo 10.02.2013 - 07:08
la source
3

J'ai eu le même problème: passer de 12.04 à 12.10 puis à 13.04. L'unité était brisée et ne faisait que rétablir l'unité

dconf reset -f /org/compiz/
setsid unity

n'était pas utile. J'ai essayé de faire ce que hafichuk a expliqué plus haut:

sudo apt-get purge fglrx lightdm && sudo apt-get install lightdm ubuntu-desktop

puis

dconf reset -f /org/compiz/
setsid unity

et alors cela a fonctionné.

    
réponse donnée minja 08.12.2013 - 17:52
la source
0

J'essayais presque toutes les suggestions affichées dans le forum.

Mon cas était similaire (pas de post-installation de l'interface graphique sur VMware Workstation).

Et la solution a été pour moi .....

sudo lightdm
    
réponse donnée Shyam Sunder Akula 30.08.2013 - 23:48
la source

Lire d'autres questions sur les étiquettes