Comment désactiver GDM et la sélection graphique des utilisateurs?

30

La nouvelle Ubuntu est dotée d’un GDM complètement impossible à maîtriser. Est-il possible de le désactiver?

Il n’est pas activé dans les services, le script de démarrage de GDM est supprimé, il est supprimé de update.rc mais il démarre toujours.

Comment désactiver GDM et la sélection graphique des utilisateurs?

    
posée Kristina Brooks 01.05.2010 - 23:48
la source

9 réponses

22

Dans Ubuntu 10.04, vous devez vous référer à la documentation pour Upstart qui gère le démarrage des tâches et des services lors du démarrage, l’arrêtant lors de l’arrêt et de la supervision. les pendant que le système fonctionne.

Début de la poignée de démarrage de gdm, vous devez donc modifier /etc/init/gdm.conf

sudo vi /etc/init/gdm.conf    # or use nano if vi is unfamiliar

Le niveau d'exécution par défaut dans Ubuntu 10.04 est 2, vous devez donc changer cette ligne

stop on runlevel [016]

ajouter "2" dans la liste des niveaux d’exécution

stop on runlevel [0126]

Vous pouvez maintenant redémarrer le système.

    
réponse donnée freedev 18.07.2010 - 16:43
la source
15

Faites:

sudo dpkg-divert  --rename --add /etc/init/gdm.conf

Quelles impressions:

Adding 'local diversion of /etc/init/gdm.conf to /etc/init/gdm.conf.distrib'

Cela vous permettra de désactiver GDM tout en empêchant les mises à niveau de package de remettre le fichier en place et en permettant au package GDM de mettre à niveau le fichier de configuration.

Dans le cas de 11.x et ci-dessus, lightdm est utilisé à la place de GDM. J'ai plutôt utilisé la commande:

sudo dpkg-divert --rename --add /etc/init/lightdm.conf

Pour annuler, remplacez le renommer et ajoutez-le avec une suppression.

    
réponse donnée Erik 08.02.2011 - 16:00
la source
12

Les versions récentes d’Ubuntu utilisent upstart au lieu de SysV init.

Renommez /etc/init/gdm.conf en /etc/init/gdm.disabled .

Pour Kubuntu, renommez /etc/init/kdm.conf en /etc/init/kdm.disabled .

    
réponse donnée Florian Diesch 03.05.2010 - 03:30
la source
11

J'ai trouvé cette discussion très utile:

La solution que j'ai trouvée qui fonctionnait de manière cohérente était post 30 by iscatel:

  

bien, cela désactive le son, comme l’a souligné un article précédent, mais voici:

     

dans /etc/default/grub , commentez (en plaçant # au début de la ligne)

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
     

et ajouter

GRUB_CMDLINE_LINUX_DEFAULT="text"
     

alors

sudo update-grub2
     

cela passera du "texte" au noyau au démarrage   ligne, désactivant gdm.

si ça ne marche toujours pas, vous pouvez

echo "manual" > /etc/init/gdm.override

et réessayez. J'ai utilisé le serveur Ubuntu 12.04 32 bits avec le noyau GNOME et cela a fonctionné pour moi.

    
réponse donnée Jonathan 29.05.2010 - 01:14
la source
4

Suivez les instructions de @freedev sur la défaillance du serveur . :

$ sudo nano /etc/init/gdm.conf

Et changez pour:

stop on runlevel [0126]

Aussi

$ sudo nano /etc/init/tty1.conf

Et changez pour:

stop on runlevel [!345]

Notez les 2 manquants dans le tty1.conf. C'est pour que tty1 soit opérationnel et puisse se connecter à la première console. Pas besoin de jouer avec GRUB.

    
réponse donnée lucian303 08.05.2011 - 06:04
la source
2

Vous pouvez passer à un autre gestionnaire d’affichage (kdm ou xdm étant les deux alternatives les plus répandues, mais il y en a beaucoup plus, voir Wikipedia ). Juste aptitude install celui que vous voulez utiliser, exécutez dpkg-reconfigure gdm et sélectionnez-le dans la liste.

    
réponse donnée minaev 04.05.2010 - 20:18
la source
2

Pourquoi ne pas simplement le supprimer?

apt-get remove gdm
    
réponse donnée Andrew Schulman 07.11.2011 - 10:01
la source
2

Les réponses précédentes (à partir de 20160611) concernant les niveaux d’exécution ne concernent que les versions d’Ubuntu utilisant Upstart. Ubuntu 16.04 est passé du démarrage à systemd . Pour démarrer sur la console, plutôt que sur X, vous devez modifier la cible par défaut à initialiser de graphical à multi-user :

sudo systemctl enable multi-user.target --force
sudo systemctl set-default multi-user.target

Puis redémarrez. Pour annuler ceci:

sudo systemctl set-default graphical.target

Et puis redémarrez.

    
réponse donnée mrm 12.06.2016 - 03:50
la source
1

Pour ceux qui arrivent sur ce sujet, suivez les instructions de freedev, mais au lieu d'arrêter gdm au niveau d'exécution 2, vous devriez l'empêcher de démarrer sur le niveau d'exécution 2:

Modifier /etc/init/gdm.conf

$ sudo vi /etc/init/gdm.conf

Modifier cette ligne

and runlevel [!06]

Par cette ligne

and runlevel [!026]

Vous pouvez également exclure d'autres niveaux d'exécution (3, 4 et 5)

    
réponse donnée Fabien 04.07.2012 - 15:45
la source

Lire d'autres questions sur les étiquettes