Les pilotes NVIDIA ne fonctionnent pas après la mise à niveau. Pourquoi ne puis-je voir que terminal?

33

Ce soir, je suis passé à 11.04. Problèmes. Une fois la mise à niveau terminée, j'ai redémarré mon ordinateur comme il me l'a dit. Lorsque j'ai dépassé l'ubuntu 11.04 (points orange sur fond violet), il est simplement allé au terminal et m'a demandé de me connecter. J'ai essayé de redémarrer le serveur X avec "sudo service gdm restart" mais aucun écran n'a été affiché. Il m'est arrivé d'avoir quelques pilotes NVIDIA dans mon fichier de téléchargements, alors j'ai essayé ces derniers, mais le "script d'installation" a échoué.

Après tout cela, j'ai démarré Ubuntu en mode sécurité graphique. J'ai alors décidé de voir ce qui se passerait si je retirais le pilote propriétaire. En faisant cela et en redémarrant mon Ubuntu démarré en mode graphique "yay!". Donc, sans les pilotes Nvidia, je peux enfin voir autre chose qu'un terminal, mais j'ai besoin de ces pilotes NVIDIA pour mon travail. Alors qu'est-ce que je peux faire? J'ai essayé d'installer les nouveaux pilotes NVIDIA linux sur le site Web de NVIDIA et j'ai essayé d'installer le pilote recommandé via des "pilotes supplémentaires", mais les deux ont entraîné mon blocage dans le terminal.

Si vous pouvez m'aider ou me conseiller, VEUILLEZ LE FAIRE! Je suis vraiment dans une très mauvaise situation ...

    
posée Sixthlaw 28.04.2011 - 17:50
la source

7 réponses

30

Vous devrez démarrer en mode récupération puis émettre apt-get remove --purge nvidia-current sur le terminal racine, suivi de apt-get install nvidia-current - pour reconstruire le pilote nvidia du nouveau noyau. J'ai eu ce problème aussi quand j'ai mis à niveau.

Veuillez ne pas installer les pilotes sur le site Web de nVidia btw! Vous pourriez causer de sérieux problèmes si vous essayez ensuite d'installer le pilote recommandé ultérieurement sans supprimer proprement le précédent.

Modifier: Vous devrez exécuter ces commandes à partir d'un terminal. Je ne peux pas garantir un résultat parfait, car je me base sur ce que j'ai trouvé via Internet et depuis la mémoire.

Le problème que vous rencontrez est dû à des composants de mode utilisateur et des modules de noyau différents. Pour y remédier, le module nvidia du noyau doit être reconstruit. Ceci est supposé se produire au redémarrage, mais ce n’est souvent pas le cas.

Vous devez d’abord installer les en-têtes du noyau Linux:

  • sudo apt-get install linux-headers-generic

Ensuite, vous devrez lancer dkms pour supprimer l’ancien module du noyau nvidia:

  • sudo dkms remove nvidia

Puis lancez:

  • sudo apt-get install nvidia-current
  • cela devrait le faire installer correctement, donc tout ce que vous avez à faire est de lancer sudo nvidia-xconfig and reboot.
  • Si vous obtenez toujours une erreur concernant la version du module, exécutez: sudo dkms build nvidia

Cela devrait résoudre le problème.

Désolé si les choses sont un peu confuses, j'ai essayé de reconstituer le processus que je devais utiliser au mieux de ma mémoire :)! Si vous rencontrez des problèmes, n'hésitez pas à me le faire savoir (et si quelqu'un détecte des problèmes avec les instructions, merci de me le faire savoir dès que possible) !!!!

Mise à jour:

J'ai trouvé une autre cause possible. Il est possible que Nouveau ne soit pas sur liste noire et que nvidia-current ne se soit pas placé dans le fichier .conf utilisé pour choisir votre pilote d'affichage. Voici comment le réparer:

NB:

Avant de continuer, assurez-vous d’avoir le pilote nvidia-current des référentiels. Le téléchargement du pilote à partir du site Web de nvidia peut entraîner des problèmes ultérieurement, car il n'utilise pas le format de paquet debian et laisse des éléments pouvant entrer en conflit avec des installations ultérieures. Veillez donc à en effacer les traces, puis installez le pilote standard à partir des repos Ubuntu. Si vous ne le faites pas, vous obtiendrez une incompatibilité de pilote, et cette correction sera inutile.

  • Si vous êtes bloqué sur la console, connectez-vous et installez le pilote nouveau X.org: sudo apt-get install xserver-xorg-video-nouveau
  • Redémarrez votre ordinateur (vous aurez des graphiques fonctionnels, yay! Mais c'est temporaire).
  • Ouvrez gedit en tant que root: gksu gedit .
  • De gedit open /etc/modprobe.d/blacklist.conf .
  • Ajoutez cette ligne en bas: blacklist nouveau .
  • Enregistrez le fichier et ouvrez /etc/modprobe.d/nvidia-graphics-drivers.conf .
    • Ajoutez ces lignes:
        

      liste noire nouveau
        liste noire lbm-nouveau
        liste noire nvidia-173
        liste noire nvidia-96
        alias nvidia nvidia-current

    •   
  •   
  • Enregistrez maintenant ce fichier et fermez gedit.
  •   
  • Exécuter:   
    • sudo nvidia-xconfig ,
    •   
    • et ensuite:
    •   
    • sudo apt-get remove xserver-xorg-video-nouveau ,
    •   
    • suivi de:
    •   
    • sudo shutdown -r now .
    •   
  •   
  • Lorsque votre système redémarre, vous devriez avoir des pilotes NVIDIA fonctionnels.
  •   
  Au fait, ce problème de ne pas mettre en liste noire le nouveau semble exister dans les nouveaux pilotes (nvidia-current), alors je suggère après avoir corrigé le problème que vous attendiez une mise à jour sur ce bogue (je vais bientôt signaler le bogue) ).

Solution alternative: Si vous avez installé les pilotes NVIDIA à partir de leur site Web, vous devez démarrer dans un terminal texte (maintenez-le enfoncé pour voir le menu grub et sélectionnez le mode de récupération de la dernière version du noyau avec les pilotes NVIDIA), puis sélectionnez le ligne de commande en tant qu'option root)

Exécutez ensuite le script d’installation de NVIDIA que vous avez exécuté pour installer les pilotes NVIDIA à partir de leur site Web. par exemple. sudo ./NVIDIA-Linux-x86-290.10.run --uninstall . (Votre version peut différer.)

Vous n'aurez pas besoin d'exécuter la commande "sudo dkms remove nvidia", car cela ne s'applique pas à votre cas.

    
réponse donnée RolandiXor 28.04.2011 - 18:42
la source
12

C'est pourquoi je recommande toujours d'installer Ubuntu comme une installation propre au lieu de faire une mise à niveau. Ceci est juste mon avis mais j'ai toujours eu un problème ou autre en faisant des mises à niveau. Aucun problème lors d'une installation propre.

Pour ce que j'ai lu sur les autres réponses, vous avez installé le pilote Nvidia à partir du site Nvidia. Même si cela fonctionne bien et etc., NE LE FAITES PAS! Celui qui entre dans les référentiels Ubuntu a été testé et c'est celui qui est recommandé.

Dans votre cas, vous devrez faire plusieurs choses.

Étape 1 - Désinstallez le pilote nvidia que vous installez et ne l’installez plus jamais. Cela vous évitera d'avoir CE problème spécifique que ... ehem .... quelqu'un l'a aussi eu (Me;)) vous devez également supprimer les modules et tous les fichiers de configuration qu'il laisse. Si je ne me trompe pas, alors les pilotes nvidia du site Web de Nvidia ont un fichier binaire de désinstallation. Exécuter cela et assurez-vous qu'il n'y a pas d'autres fichiers NVIDIA à gauche.

MISE À JOUR - Pour désinstaller un pilote Nvidia installé à partir du site Nvidia, vous avez l’une des options suivantes:

  • Certains suggèrent de désinstaller en utilisant le même installateur.
    Exemple: NVIDIA-Linux-x86-1.0-8178.run --uninstall
  • D'autres suggèrent d'utiliser l'installateur Nvidia.
    Exemple: nvidia-installer --uninstall

CONSEIL - Essayez de taper - help à la fin du fichier exécutable binaire de Nvidia pour voir si cela montre de l’aide. Pages telles que lien et lien donne une idée de la procédure à suivre pour désinstaller le pilote Nvidia du site Nvidia.

Etape 2 - Redémarrez et vérifiez que vous n’avez RIEN de rien. Supprimez le fichier xorg.conf car vous en ferez bientôt un nouveau. Redémarrez.

Étape 3 : installez les pilotes Nvidia recommandés. sudo apt-get install nvidia-current ou sudo apt-get reinstall nvidia-current (Si vous l'avez déjà installé, je vous recommande de désinstaller puis de le réinstaller.)

Étape 4 : créez le fichier xorg.conf du pilote recommandé par Nvidia. nvidia-xconfig . Cela créera le fichier xorg.con avec les options nécessaires pour votre carte vidéo nvidia. Redémarrez à nouveau.

Jusqu'à cette étape, j'aurais besoin de commentaires si vous aviez un problème. Pour une solution plus générale, n'hésitez pas à lire ce guide: Comment installer les pilotes Nvidia?

    
réponse donnée Luis Alvarado 29.04.2011 - 02:26
la source
7

J'ai aussi eu un problème avec les pilotes nvidia et j'ai fait tout ce que je pouvais trouver (également dans les autres réponses):

  • supprimer les pilotes précédemment installés et réinstaller
  • démarrer via failsafeX et activer le pilote
  • en utilisant le pilote précédent ( 173 )
  • J'ai ajouté UNITY_FORCE_START=1 à /etc/environment comme mentionné ici (car les GeForce 7300/7400 sont sur liste noire, mais j'ai une GeForce Go 7100)

Mais tout a échoué. Donc, en dernier ressort (j'aurais dû y penser plus tôt), j'ai étudié les fichiers X-logfiles. Dans mon /var/log/Xorg.0.log , j'ai trouvé que nvidia avait des problèmes pour allouer la mémoire:

[    14.055] (EE) NVIDIA(0): Failed to allocate primary buffer: out of memory.
[    14.055] (EE) NVIDIA(0):  *** Aborting ***

Apparemment, il s’agit d’un bogue connu et je devais faire ce qui suit pour y remédier:

  • éditer /etc/default/grub
  • trouvez l’option GRUB_CMDLINE_LINUX et ajoutez nopat , donc pour moi cela ressemblait à

    GRUB_CMDLINE_LINUX="nopat"

  • exécutez sudo update-grub

Enfin, tout a bien fonctionné pour moi :) J'espère que ça aide.

    
réponse donnée nathanvda 29.04.2011 - 11:30
la source
2

Notez que le noyau ci-dessous pointe vers une version précédente d'Ubuntu. Le nouveau noyau avec Ubuntu 11.10 est 3.0.0.12. J'ai eu le même problème avec être mis en mode de commande et Xserver échouant tout en étant incapable de trouver le pilote nvidia_173. Je me suis alors rendu compte que la mise à niveau ne mettait pas à jour mon MBR vers la version 3.0.0.12. J'ai utilisé EasyBCD pour mettre à jour le fichier, redémarré et tout allait bien. Ces types de pannes de pilotes peuvent se produire quand ils sont à des niveaux mixtes, bien sûr. Mon conseil, après la mise à niveau, assurez-vous que vous exécutez le nouveau noyau, initrd, vmlinuz, ... ce que vous avez.

DKMS make.log for nvidia-current-270.41.06 for kernel 2.6.38-8-generic (x86_64)
Sat May 14 20:48:39 EDT 2011

The C compiler 'cc' does not appear to be able to
create executables.  Please make sure you have 
your Linux distribution's gcc and libc development
packages installed.

*** Failed CC sanity check. Bailing out! ***

make: *** [select_makefile] Error 1

J'ai compris que le cc (alias pour gcc) utilisé dans mon / usr / bin n'était pas la même version que le fichier gcc trouvé dans ce même répertoire, indépendamment de tous les paquetages de développement déjà installés sur ma machine. J'ai dû faire un lien symbolique pour pointer vers le fichier gcc.

sudo mv /usr/bin/cc /usr/bin/cc.old
sudo ln -s /usr/bin/gcc /usr/bin/cc

Après cela, la réinstallation du paquet nvidia-current a fait l'affaire.

Cordialement

    
réponse donnée Steven Rosato 15.05.2011 - 04:12
la source
2

Ma mise à niveau 11.04 a également démarré uniquement dans une fenêtre de terminal. Puis j'ai trouvé ce site. J'ai commencé à faire ce que Roland Taylor a recommandé, d'abord je l'ai fait

sudo apt-get install linux-headers-generic

Puis j'ai essayé de faire:

sudo dkms remove nvidia 

Mais il a échoué en se plaignant que la commande était incomplète, que j'avais besoin de -m et de -v et de la version

J'allais réessayer mais j'ai remarqué que l'écran contenait des informations de journal de la première commande indiquant qu'il avait installé le nvidia-current lorsque j'ai installé les en-têtes génériques, alors j'ai pensé, je me demande ce que ça va faire si Je redémarre maintenant? Donc je l'ai fait et le bureau X s'est bien passé. Donc, une seule commande a résolu mon problème d'installation.

    
réponse donnée Johngee 02.05.2011 - 17:21
la source
0

Cela a fonctionné pour moi.

1) Passez au terminal F1 en appuyant sur Ctrl + Alt + F1.

2) Exécutez les commandes suivantes.

sudo /etc/gdm stop
sudo apt-get install linux-headers-$(uname -r) linux-image-$(uname -r)
wget -O /tmp/nvidia.run http://us.download.nvidia.com/XFree86/Linux-x86/280.13/NVIDIA-Linux-x86-280.13.run
# Make sure to allow the script to uninstall all existing drivers.
sudo sh /tmp/nvidia.run
sudo /etc/gdm start
    
réponse donnée Rune Kaagaard 20.09.2011 - 10:20
la source
0

Si vous rencontrez ce problème, assurez-vous que Optimus (la technologie de changement de carte graphique de Nvidia) est désactivée dans le BIOS.

    
réponse donnée Sam Youtsey 05.01.2012 - 17:08
la source

Lire d'autres questions sur les étiquettes