Est-il normal que compiz consomme 40% de mon processeur sans autres programmes en cours d'exécution?

29

Lorsque je n’ai pas d’autres programmes en cours d’exécution, compiz occupe au moins 40% de mon processeur.
Est-ce normal? Si c'est normal, y a-t-il un moyen de réduire ce pourcentage?

    
posée Jiskya 29.04.2012 - 07:16
la source

8 réponses

6

Edit: depuis Ubuntu 12.10 ce n’est plus une option, car Unity-2D a été supprimé avec quantique.

J'ai les mêmes problèmes avec l'utilisation du processeur à cause de compiz. Ma solution de contournement consistait à passer d'une session d'Ubuntu à Ubuntu 2D.

    
réponse donnée Eugene Manuilov 28.05.2012 - 11:36
la source
13

J'ai eu le même problème que la charge du processeur est passée à 70% ~ 80% et cela m'a bouleversé longtemps après la mise à niveau à 12.04 à partir de 10.04.

Et réinitialiser les paramètres compiz à leur valeur par défaut ou supprimer ~/.compiz-1 & amp; Les dossiers ~/.config/compiz-1 ne fonctionnaient pas.

Mais après avoir décoché la case "Sync to VBlank" sous OpenGL dans ccsm (Gestionnaire de paramètres CompizConfig), la charge du processeur chute immédiatement à 1%.

J'espère que cela vous aidera, vous et d'autres gars ...

Désolé pour ma mauvaise expression (je suis un étudiant de Chine).

    
réponse donnée Chaos John 22.02.2013 - 12:50
la source
6

eu le même problème. Compiz constamment à environ 40% (CPU AMD, ATI 58xx, 12.04). Ensuite, j'ai suivi cet article lien et l'utilisation du processeur est tombée en dessous de 10%. J'espère que ça aide.

MODIFIER avec les instructions:

Sauvegardez simplement (renommez) les répertoires ~/.compiz-1 et ~/.config/compiz-1 et laissez-les être créés à nouveau avec les paramètres par défaut (vous devrez vous déconnecter et vous reconnecter).

mv ~/.compiz-1 ~/.compiz-1.BACKUP
mv ~/.config/compiz-1 ~/config/.compiz-1.BACKUP

Après avoir redémarré et confirmé que tout fonctionne comme prévu, vous pouvez simplement supprimer ces sauvegardes (sauf si vous en avez besoin).

rm -Rfv ~/.compiz-1.BACKUP
rm -Rfv ~/config/.compiz-1.BACKUP

Cela aide aussi de faire un unity --reset

    
réponse donnée ECII 17.06.2012 - 19:14
la source
3
  1. Installez compizconfig-settings-manager . Exécutez-le en tapant ccsm dans le tiret.

  2. Dans la fenêtre principale de l'application, cliquez sur le lien inférieur avec le libellé Préférence .

  3. Dans l'onglet Profil, cliquez sur le bouton Réinitialiser .

  4. Déconnectez-vous et reconnectez-vous.

J'espère que cela aidera

    
réponse donnée Anwar 17.06.2012 - 19:37
la source
3

apparemment, il y a un bogue avec la base de cartes ATI sur ce site: lien

sur ce site, il y a quelques étapes:

  1. installez compizconfig-settings-manager (CCSM)
  2. naviguez vers opengl puis changez le filtre de texture en Fast et décochez la synchronisation avec VBlank
  3. fermez CCSM puis redémarrez Ubuntu

archiver le moniteur du système, espérons que compiz n'aura plus besoin de beaucoup de CPU.

    
réponse donnée whale_steward 01.06.2013 - 15:17
la source
2

La nouvelle version de Compiz et du plug-in Unity ont des modifications majeures qui lui permettent de se comporter différemment. Dans mon cas, je devais restaurer les paramètres par défaut de compiz afin de le faire fonctionner correctement après la mise à niveau vers la version 12.04.

J'ai une carte ATI Radeon HD5750, et j'ai vraiment noté une amélioration des performances (après avoir corrigé le compiz) par rapport à 11.10.

    
réponse donnée Simón 29.04.2012 - 08:05
la source
1

Je me suis rendu compte que sur mon ordinateur portable avec les graphiques NVIDIA 8600M GS et le package de pilotes nvidia-340 propriétaire, compiz utilisait toujours tout le processeur qu'il pouvait obtenir d'un seul cœur. Avec aucune autre activité sur mon ordinateur, cela signifie une valeur proche de 100% sur un cœur, tandis que l'autre prend en charge toutes les autres charges. Top rapporte également près de 100% pour le compiz lui-même.

Bien sûr, il semble qu'un seul thread reste actif, donc sur un PC quad core, vous obtiendrez une charge de 25% et 16% sur un i7 6 cœurs.

L’ordinateur entier était lent au point de retarder la saisie de texte.

J'ai lancé "pilotes supplémentaires", l'interface ubuntu intégrée qui installe le pilote propriétaire, et on m'a proposé un choix de versions de pilotes NVIDIA, plus nouveau, le pilote open source.

A la toute fin de la liste, j'ai remarqué "nvidia-340-update", qui est le même pilote NVIDIA propriétaire de 340.96, et j'ai décidé de l'essayer. Le 8600M GS n'est pas pris en charge dans les versions ultérieures du pilote. J'ai laissé l'installateur compiler tout, redémarré lorsqu'on le lui avait demandé, et l'utilisation élevée du processeur de compiz avait disparu!

Si cela fonctionne pour vous, cette solution convient mieux à l'infrastructure linux-restrictions-modules qu'à la gestion manuelle d'un pilote NVIDIA. Il remplace nvidia-340 par nvidia-340-update.

    
réponse donnée user3806 08.06.2016 - 00:41
la source
1

J'ai trouvé le même problème sur Ubuntu 15.04. Mon ordinateur portable avait beaucoup de retard, et j'ai vu que compiz était toujours jusqu'à 25% de la charge du processeur. J'ai d'abord cherché autour des pilotes mais j'ai finalement constaté que compiz tombe à 3% dès qu'aucune application Web n'est ouverte. J'avais l'habitude d'utiliser twitter et facebook avec les webapps natives (intégrées dans oxyde).

Comme je n’utilise que Firefox, Compiz ne dépasse pas 5% du processeur.

J'espère que ça aide.

    
réponse donnée bastienho 10.09.2015 - 10:17
la source

Lire d'autres questions sur les étiquettes