GDBus.Error lors de l'activation du second écran

29

J'ai connecté un écran externe à mon ordinateur portable, mais celui-ci ne s’étendait pas automatiquement, comme il le faisait il ya environ un an (ancienne version d’Ubuntu).

Je suis allé aux paramètres d'affichage. L'écran y figurait (résolution correcte, nom de marque, etc.). Mais quand je mets l'interrupteur sur «on» et que je clique sur «apply», j'obtiens cette erreur:

Failed to apply configuration: %s

GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface 'org.gnome.SettingsDaemon.XRANDR_2' on object at path /org/gnome/SettingsDaemon/XRANDR

Ca a été comme ça pendant quelques mois maintenant, mais j'aimerais vraiment pouvoir utiliser à nouveau un écran / beamer externe.

Des idées?

Merci.

    
posée Maurice 10.08.2012 - 11:48
la source

7 réponses

29

dconf write /org/gnome/settings-daemon/plugins/xrandr/active true n'a rien fait et arandr a l'air assez incompréhensible pour moi. Si vous êtes autrement bloqué, cela vaut la peine d'essayer xrandr. La documentation est ici: lien

Et j'ai pu résoudre ce problème en faisant:

xrandr --current
xrandr --output VGA1 --off
xrandr --output VGA1 --auto --right-of LVDS1

Laissez-moi vous expliquer ceci:

La première commande consiste à voir quels écrans je me suis connecté.

$ xrandr --current
Screen 0: minimum 320 x 200, current 3200 x 1080, maximum 8192 x 8192
LVDS1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 261mm x 163mm
1280x800       60.0*+
1024x768       60.0
800x600        60.3     56.2  
640x480        59.9  
VGA1 connected 1920x1080+1280+0 (normal left inverted right x axis y axis) 509mm x 286mm
1920x1080      60.0*+
1280x1024      60.0  
1440x900       59.9  
1280x800       59.8  
1152x864       75.0  
1024x768       70.1     60.0  
800x600        60.3     56.2  
640x480        66.7     60.0  
720x400        70.1  
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)

Il y a beaucoup de données superflues, mais je n'ai besoin que des noms des deux écrans. Je vois:

LVDS1 connected

et

VGA1 connected

Et je pense que l'on peut supposer que VGA est le moniteur externe. Alors je l'éteins

xrandr --output VGA1 --off

et de nouveau sur

xrandr --output VGA1 --auto --right-of LVDS1

et lorsque je déplace mon curseur sur le bord droit de l'écran de l'ordinateur portable, il apparaît sur le moniteur externe. Succès.

    
réponse donnée Andrew Farrell 10.06.2013 - 19:22
la source
6

Appeler:

dconf write /org/gnome/settings-daemon/plugins/xrandr/active true

résolu le problème pour moi.

Selon votre carte graphique, son outil de configuration spécifique peut également effectuer la configuration à double écran, par ex. nvidia-settings, ... an

    
réponse donnée Matthias 07.09.2012 - 11:52
la source
1

Je suis venu ici avec des problèmes sur les paramètres d'affichage après l'installation de Cinnamon dans Xubuntu. Cela m'a donné deux boîtes de dialogue "affichages", l'ubuntu me donnant l'erreur gdbus. Ouvrez l'autre (Cinnamon) pour bien faire les choses.

lien - merci

    
réponse donnée andersoyvind 21.11.2013 - 10:34
la source
0

Pour moi, l’installation du bureau gnome-shell et le passage à celui-ci et la modification de ce paramètre ont également résolu le problème de l’unité.

    
réponse donnée mohs 06.02.2013 - 12:31
la source
0

Essayez de désactiver les pilotes de la carte graphique, redémarrez, essayez si cela fonctionne.

Après avoir démarré sur une clé USB et réussi à faire exactement ce que je voulais avec les écrans (écran d'ordinateur portable sur le moniteur externe gauche à droite), j'ai conclu que quelque chose devait se passer avec les pilotes de ma carte graphique. Je les ai donc désactivés via les paramètres système & gt; Additional Drivers, redémarrés et tout fonctionnait comme je le souhaitais.

PS: Essayé la plupart de ce qui précède, ne semblait pas fonctionner pour moi.

J'espère que cela vous aidera aussi.

    
réponse donnée george 01.12.2013 - 16:55
la source
0

J'ai eu le même en utilisant Settings & gt; Afficher sur 12.04 LTS.

Il semble que le démon de configuration de Gnome doit être actif pour que les modifications prennent effet et que je l’ai accidentellement désactivé depuis les applications de démarrage.

J'espère que ça aide.

    
réponse donnée user271222 20.04.2014 - 01:15
la source
0

Redémarrer gnome-settings-daemon corrigé pour moi:

gnome-settings-daemon --replace > /dev/null 2>&1 &
    
réponse donnée Jim Hunziker 13.05.2014 - 15:15
la source

Lire d'autres questions sur les étiquettes