15.04 et Nvidia: boucle de connexion

35

Mise à niveau 14.10 à 15.04, le bureau ne parvient pas à charger l’écran de connexion passé. Je saisis mon mot de passe, j'entends un octet sonore défectueux, reviens à l'écran de connexion. Aussi ne peut pas démarrer une clé USB 15.04 créée avec un autre PC. Le compte invité fait la même chose. Essayé de supprimer tous les packages de pilotes nvidia, essayé de jouer avec .Xauthority, essayé d'utiliser gdm au lieu de lightdm (échoué encore pire: pas d'écran de connexion du tout). J'ai essayé de réinstaller ubuntu-desktop. Obtenir le code d'erreur de la sonde ACPI PCC a échoué, à partir de 219 ou quelque chose comme ça.

Actuellement en cours d'exécution 15.04 sur la clé USB ... sur un autre PC avec des graphiques intégrés AMD, sans problèmes.

15.04 n'aime pas les cartes graphiques Nvidia. S'il vous plaît aider!

    
posée Dustin French 26.04.2015 - 05:40
la source

12 réponses

17

c'est vous du futur. Voici comment je l'ai corrigé: je ne l'ai pas fait! J'ai re-téléchargé l'image 15.04 du site Web Ubuntu et créé un "disque" de démarrage sur une clé USB. Aujourd'hui, cela a fonctionné, alors que ça n'a pas duré hier soir :( Peut-être que Canonical a réparé leur image ... J'ai donc démarré depuis la clé USB et enlevé mon 15.04 existant et installé une nouvelle copie! Bien sûr, j'ai perdu tous mes fichiers (VirtualBox, tous les jeux installés, etc.) mais maintenant, Linux fonctionne à nouveau. Que ce soit une leçon pour vous Dustin! N'essayez jamais de mettre à niveau un système d'exploitation Ubuntu! Sauvegardez tous vos fichiers et effectuez une installation propre, comme vous le faisiez avec Windows!

    
réponse donnée Dustin French 26.04.2015 - 22:05
la source
12

J'ai eu exactement le même problème. Je ne sais pas exactement pourquoi c'est arrivé, mais il semble que mon noyau n'ait pas été mis à jour.

Pour résoudre ce problème, j'ai utilisé Ctrl + Alt + F1 pour accéder à un texte console virtuelle , connectée à ce site, puis exécutée:

sudo apt-get install linux-generic

Tout a recommencé à fonctionner.

    
réponse donnée Uther 29.04.2015 - 15:11
la source
9

Mon correctif pour mon ordinateur portable

Dell xps l502x, il s’agit donc de la carte graphique Intel + Nvidia optimus.

Regardez ce que vous avez

dkms status

Vous pouvez obtenir quelque chose comme ça

bbswitch, 0.7, 3.19.0-15-generic, x86_64: installed
nvidia-340, 340.76, 3.19.0-15-generic, x86_64: installed

Supprimez tous les pilotes Nvidia, ramenez Ubuntu à l'état "clean".

Regardez ceci: lien

En gros, vous faites:

sudo apt-get purge $(dpkg -l | awk '~/nvidia/ {print }')

Cela devrait supprimer tous les pilotes nvidia et maintenant vous devriez être propre.

Vous pouvez vouloir vérifier:

dkms status

Installez le pilote Nvidia

Regardez ceci: lien (partie de la ligne de commande)

J'ai essayé d'installer nvidia-349, cela n'a pas fonctionné, alors je me souviens avoir utilisé nvidia-340. Il semble important de se rappeler ce qui fonctionne pour vous. Je fais:

sudo apt-get install nvidia-340 #(you may want to try nvidia-346)

Regardez ce long guide

lien

À l’étape 4, au lieu de

sudo echo ON > cat/proc/acpi/bbswitch 

Je l'ai changé pour

sudo tee /proc/acpi/bbswitch <<<ON

basé sur lien

Parfois, après avoir activé bbswitch, redémarrez, quand je fais echo /proc/acpi/bbswitch , je le vois toujours OFF . Assurez-vous que Nvidia est installé en premier lieu ou redémarrez plusieurs fois. S'il s'agit de OFF , suivez le guide pour l'étape suivante.

Redémarrer

Après le guide, redémarrez, vérifiez si vous avez toujours le problème de la boucle de connexion. Si vous avez toujours des problèmes, regardez /var/log/Xorg.0.log

/var/log/Xorg.0.log

Recherchez les messages d’erreur indiqués par (EE). Dans mon cas, il est dit

Failed to load /usr/lib/x86_64-linux-gnu/xorg/extra-modules/libglx.so: libnvidia-tls.so.340.46: cannot open shared object file: No such file or directory

Je fais un locate libglx.so , il semble que le fichier se trouve ailleurs. Il est temps de reconstruire xorg.conf

Reconstruire xorg.conf

Consultez ce guide: lien

C'était ma dernière étape et j'ai pu démarrer sur l'interface graphique.

    
réponse donnée kenpeter 28.04.2015 - 08:51
la source
6

J'ai eu exactement le même problème sur Ubuntu 15.10. Aucune des solutions suggérées ici n'a fonctionné, pas plus que d'autres didacticiels. Après plusieurs installations propres du système, j'ai finalement compris ce qui en était la cause.

NE PAS METTRE nomodeset de façon permanente dans les paramètres de démarrage!

Après une installation propre, je ne pouvais pas me connecter sans taper manuellement nomodeset dans les options de démarrage de grub avant de démarrer. Après la première connexion, cependant, je le définissais dans le fichier de configuration de démarrage afin de ne pas avoir à le taper à chaque fois. Après l’une des ré-installations, j’ai oublié de le faire et cette fois les pilotes NVIDIA installés sans problème et j’ai pu me connecter très bien.

    
réponse donnée user3556519 26.02.2016 - 16:38
la source
2

Je n'ai pas pu installer le paquet

sudo apt-get install linux-kernel-generic

mais cela a résolu le problème avec la boucle de connexion pour moi:

sudo apt-get install linux-generic

merci pour l'idée avec le noyau

    
réponse donnée Sebastian Wittka 29.04.2015 - 21:35
la source
1

IMHO Optimus est Evil .

Ubuntu 14.10 m'a offert quelques cheveux gris à cause de Nvidia , puis je suis passé à Win 8. Hier, j'avais l'impression de manquer quelque chose avec Win 10 et de télécharger 15.04. Première exécution après installation et écran noir avec son de défaillance continue. Ctrl + Alt + F1 n'a pas affiché la console. Réinstallé 2 fois avant de me souvenir du problème 14.10 avec Optimus. Résoudre le problème uniquement avec Bumblebee .

    
réponse donnée Konstantin 10.05.2015 - 15:43
la source
1

J'avais un problème similaire mais un compte secondaire pouvait se connecter, donc je savais que mon système n'était pas bloqué. Voici comment je l'ai corrigé. Je suis allé dans le dossier personnel du compte offensant et j'ai jeté tous les dossiers et fichiers de configuration cachés relatifs à gnome, gtk etc. ou tout ce que je ne voulais pas conserver (paramètres du navigateur, musique, etc.). Redémarrez. J'ai dû redéfinir certaines préférences du système et réorganiser les icônes du bureau, mais beaucoup mieux que toute une installation avec l'ajout de référentiels et de packages supplémentaires. Essayez-le avant de le jeter et de l'installer.

    
réponse donnée Stuart Conner 05.07.2015 - 04:21
la source
1

Légèrement hors sujet, mais si vous avez AMD au lieu de nVidia: Après avoir mis à jour 14.04 à 14.10 puis 15.04, je me suis retrouvé dans la boucle de connexion. Après avoir beaucoup discuté des problèmes avec les pilotes nVidia, ils ne nous ont pas beaucoup aidé. J'ai un HP Pavillion avec processeur AMD & amp; Les chauffeurs Voici les étapes simples qui ont fonctionné:

Appuyez sur ctrl - alt - F1 pour obtenir une invite de console (non-gui).

dkms status # shows that fglrx-core was installed
sudo apt-get purge fglrx-core
sudo apt-get install fglrx-updates
dkms status
sudo reboot now

Alors tout allait bien.

    
réponse donnée user314771 18.05.2015 - 20:38
la source
1

Ce lien a fonctionné comme un charme pour moi - lien .

Il m'a guidé vers les journaux où il montre que le module GLX ne se chargeait pas et a été chargé de réinstaller les pilotes nvidia.

J'en ai fait une meilleure en allant sur lien et en trouvant mon dernier pilote Linux 64 bits, et en utilisant les URL à la place. .

    
réponse donnée Robert Persaud 30.10.2015 - 16:14
la source
1

Pour moi, je viens de forcer une reconfiguration du serveur graphique en supprimant le fichier .Xauthority dans un tty dans le dossier home:

sudo mv .Xauthority .Xauthority_old
    
réponse donnée Psddp 28.01.2016 - 19:16
la source
0

J'avais fait une installation propre du 15.10 mais j'ai trouvé que l'écran de connexion de lightdm affichait des mots incomplets (pa rd) et était en boucle lorsque je me suis connecté. Ctrl-Alt-F1 m'a bien connecté sudo apt-get remove --purge nvidia- *. Cette liste une charge de pilotes NVIDIA et a déclaré qu'aucun n'a été installé. J'ai donc décidé d'installer le dernier en tant qu'expérience. sudo apt-get install nvidia-352 a fait l'affaire. Après l'achèvement, il n'y avait pas de mots incomplets affichés sur l'écran de connexion de lightdm et je me suis ensuite connecté sans problème. Donc, mon correctif était d'installer un pilote d'écran NVIDIA ... de préférence le plus récent. Cheers

    
réponse donnée Dig 29.02.2016 - 20:12
la source
0

Jetez un coup d’œil à votre partition / home avec la commande df si elle n'est pas pleine . Cela peut provoquer le redémarrage de x-server ...

    
réponse donnée Philippe Gachoud 18.03.2016 - 16:56
la source

Lire d'autres questions sur les étiquettes