Comment désactiver le popup du gestionnaire de mise à jour?

38

J'ai configuré ceci:

Automatically check for updates: Never

Mais le gestionnaire de mise à jour continue de répondre à mes souhaits, je n'ai aucun contrôle. J'ai l'impression d'utiliser Windows à nouveau.

Je souhaite pouvoir installer des mises à jour de temps en temps, manuellement .

Que puis-je faire?

    
posée ChocoDeveloper 18.11.2012 - 08:19
la source

13 réponses

10

Désactiver les popups dans la configuration ne semble pas possible, comme l’a dit côteyr dans les commentaires ci-dessus.

Je voulais aussi me débarrasser des popups et des programmes sous-jacents qui consommeraient les ressources de mon système Ubuntu 12.04 sur un Toshiba AC100 (ARM) faible - lien .

La solution de travail la plus simple doit donc être de supprimer le "update-manager" (comme je l'ai mentionné dans les commentaires de lien ).

Après cela, je n’ai eu aucun problème car je pouvais toujours utiliser apt-get ou synaptic pour faire des mises à jour de paquets.

    
réponse donnée imz -- Ivan Zakharyaschev 18.11.2012 - 11:11
la source
15

Ouvrez le fichier de configuration qui exécute la partie update-manager après apt

nano /etc/apt/apt.conf.d/99update-notifier

Ajoutez '#' en face de la ligne, ce qui ressemble à:

#DPkg::Post-Invoke {"if [ -d /var/lib/update-notifier ]; then touch /var/lib/update-notifier/dpkg-run-stamp; fi; if [ -e /var/lib/update-notifier/updates-available ]; then echo > /var/lib/update-notifier/updates-available; fi "; };

Fait

Cela a fonctionné pour moi en arrêtant le gestionnaire de mise à jour après chaque mise à jour apt tout en me permettant d'exécuter manuellement update-manager si je le voulais.

    
réponse donnée Allu2 20.11.2015 - 14:47
la source
15

Désactiver la notification des mises à jour ne suffira pas. Il existe plusieurs tâches en arrière-plan qui exécutent apt-get update (y compris une tâche cron nocturne si je me souviens bien).

Pour arrêter l’exécution de la fenêtre pop-up update-manager

Ensuite, dans les paramètres, définissez Mise à jour automatiquement sur "Jamais" et Notifier la nouvelle version sur "Jamais"

Je suggère de laisser la sécurité immédiatement et de mettre "autres" à toutes les deux semaines.

Vous devez également vous assurer que vous ne lancez pas apt-get update ailleurs. Cela peut se produire lorsque vous installez un logiciel, exécutez update-manager ou dans une tâche cron.

Si cela ne fonctionne pas pour vous:

Vous pouvez le faire en

éditer /etc/apt/apt.conf.d/10periodic et changer

  

APT :: Periodic :: Update-Package-Lists "1";

à

  

APT :: Periodic :: Update-Package-Lists "0";

Dernier recours

Vous pouvez également faire apt-get remove update-manager pour supprimer la fonctionnalité tous ensemble.

    
réponse donnée coteyr 18.11.2012 - 10:08
la source
6

Il est bon que Ubuntu vérifie automatiquement les mises à jour, ce n'est pas bien qu'il affiche des fenêtres contre votre volonté. Vous pouvez avoir des notifications moins invasives via la barre de gnome ou des applications basées sur des terminaux (comme Byobu).

Pour désactiver le update-notifier tout en vérifiant automatiquement les mises à jour par le gestionnaire de mise à jour, exécutez la commande suivante depuis un terminal:

  1. sudo apt-get install gconf-editor au cas où vous ne l'auriez pas déjà installé
  2. sudo gconf-editor pense à l'attribut sudo
  3. recherchez app- & gt; update-notifier et décochez l'option "lancement automatique"
  4. fermez la fenêtre
  5. gconf-editor cette fois-ci en tant qu'utilisateur (c'est-à-dire sans sudo)
  6. recherchez à nouveau app- & gt; update-notifier et remplacez le paramètre "regular_auto_launch_interval" par le nombre de jours que vous souhaitez attendre avant de démarrer (0 est immédiatement, 1 un jour, 99999999 fondamentalement plus jamais)
réponse donnée Andrea Borga 22.01.2013 - 21:11
la source
4

Vous avez défini cette option sur vérifier pour les mises à jour, mais vous trouverez que le gestionnaire de mise à jour s’ouvre car il a déjà sait que des mises à jour sont à effectuer. Effectuez les mises à jour et cela ne vous gênera plus jusqu'à ce que vous mettiez à jour les listes de fichiers.

C'est un peu comme le terminal vous le dira quand il y aura des mises à jour dans la liste apt qui ont été placées avec 'apt-get update', et vous rappellera jusqu'à ce que vous les installiez.

    
réponse donnée fabricator4 18.11.2012 - 09:01
la source
3
sudo killall update-notifier
sudo mv /usr/bin/update-notifier /usr/bin/update-notifier.real
echo -e '#!/bin/bash\nwhile :; do /bin/sleep 86400; done' | sudo tee /usr/bin/update-notifier
sudo chmod 755 /usr/bin/update-notifier

Brutal, mais efficace.

    
réponse donnée GBA 05.11.2014 - 03:24
la source
2

Ubuntu 16.04 exécute une session Gnome

Vous pouvez résoudre ce problème en supprimant "Update Notifier" de "Startup Applications".

Tout d’abord, laissez-le s’afficher dans la liste de vos applications de démarrage.

sudo sed --in-place 's/NoDisplay=true/NoDisplay=false/g' /etc/xdg/autostart/update-notifier.desktop

Décochez ensuite l’élément ici:

gnome-session-properties

De cette façon, vous n'avez pas besoin de modifier votre configuration de mise à jour automatique (mais vous pouvez le faire si vous le souhaitez), renommer les fichiers système et ne pas supprimer les packages.

    
réponse donnée user334639 04.02.2017 - 04:53
la source
2

Je n'aime pas les mises à jour automatiques, donc je veux toujours les désactiver. J'utilise Ubuntu 14.04 avec l'environnement de bureau Gnome. Je ne sais pas si gsettings est disponible dans Unity.

Sur les connexions Internet lentes, la désactivation d'apt-xapian-index empêche le téléchargement automatique des paquets, ce qui prend toute votre bande passante (j'ai parfois 256 kb / s de mobile).

sudo chmod a-x /etc/cron.daily/update-notifier-common 
sudo chmod a-x /etc/cron.weekly/apt-xapian-index 
sudo chmod a-x /etc/cron.weekly/update-notifier-common 

gsettings set com.ubuntu.update-notifier regular-auto-launch-interval 3650
gsettings set com.ubuntu.update-manager launch-time 1900000000

Semblait faire le tour pour moi. 3650 signifie les jours ... 1900000000 indique que le gestionnaire de mise à jour est exécuté pour la dernière fois en 2030:)

Mise à jour: Sous Ubuntu 16.04 , il semble que vous puissiez désactiver les mises à jour automatiques avec les commandes suivantes et en modifiant deux fichiers:

sudo mv /etc/xdg/autostart/update-notifier.desktop /etc/xdg/autostart/update-notifier.desktop.old 
sudo mv /etc/xdg/autostart/gnome-software-service.desktop /etc/xdg/autostart/gnome-software-service.desktop.old

Si l’extension est différente de .desktop, ces commandes ne seront pas exécutées au démarrage du système.

Modifier /etc/apt/apt.conf.d/10periodic

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";

Modifier /etc/apt/apt.conf.d/20auto-upgrades

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Unattended-Upgrade "0";

Si vous avez démarré le gestionnaire de mise à jour même une fois, ces fichiers contiendront quatre lignes:

APT::Periodic::Update-Package-Lists "0";
APT::Periodic::Download-Upgradeable-Packages "0";
APT::Periodic::AutocleanInterval "0";
APT::Periodic::Unattended-Upgrade "0";

Changez simplement toutes les valeurs à "0"

    
réponse donnée Maza 06.12.2015 - 10:10
la source
1

Je ne sais pas trop pourquoi personne n’a pas essayé.

Je désactive simplement tous les points de contrôle sous "logiciel Ubuntu" et "autres logiciels" dans "logiciels et mises à jour", en plus des options de "mises à jour automatiques" et "vérifier les nouvelles versions" à "jamais". Cela évite toute vérification, car il n'y a pas de lien, donc pas de fenêtre contextuelle.

Mon principal inconvénient est que ces mises à jour consomment beaucoup de données Internet. Pour les personnes en déplacement, les données 3G / 4G sont chères et nous souhaitons optimiser leur utilisation. J'espère que Ubuntu comprend cette préoccupation et propose des options faciles pour désactiver complètement les mises à jour dans certaines circonstances.

    
réponse donnée Shaurabh Bharti 28.04.2016 - 09:15
la source
1

Modifier /etc/update-manager/release-upgrades et définir:

Prompt=never changez cela avec votre éditeur préféré).

Ne jamais utiliser update-manager avec -d vérifie si la prochaine version est disponible ou non.

    
réponse donnée Akshay Patil 18.01.2017 - 09:44
la source
0

J'ai eu un problème similaire. Exécuter,

apt-get purge update-notifer*

problème résolu! Ubuntu 12.04.5 LTS

    
réponse donnée user205032 24.10.2015 - 15:15
la source
0

Pour Ubuntu 16.04 , et éventuellement d’autres versions:

sudo chmod 000 /usr/bin/update-manager
sudo chmod 000 /usr/bin/update-notifier

Puis redémarrez. (Alternativement, il est possible que simplement se déconnecter et revenir est suffisant.)

Vous pouvez vérifier que update-manager ne fonctionne pas en examinant la sortie de:

ps auxwww | grep update

(Mis à part: D'autres affiches ont suggéré sudo apt-get purge update-notifer* . Cependant, je préfère ne pas supprimer les paquets qui pourraient être enchevêtrés dans les divers méta-packages desktop .)

    
réponse donnée mpb 20.05.2017 - 20:33
la source
0

Pour désactiver le popup après 12.04, je n’avais plus de support: cd à /etc/apt/apt.conf.d

et édité: 15update-stamp

a commenté la ligne originale et ajouté une ligne "fixe". Mon dossier avait:

APT::Update::Post-Invoke-Success {"touch /var/lib/apt/periodic/update-success-stamp 2>/dev/null || true";};

et maintenant je l'ai substitué avec:

APT::Update::Post-Invoke-Success {"touch /var/lib/apt/periodic/update-success-stamp 2>true || true";};

Maintenant, chaque fois que la mise à jour est lancée, elle est en quelque sorte comme: "les mises à jour recherchées, non trouvées (votre système n’était plus supporté), mais il a été tenté, tout va bien"

    
réponse donnée Ferreira 30.09.2017 - 01:40
la source

Lire d'autres questions sur les étiquettes