Haute température dans une série AMD Radeon HD4000 / 3000 après la mise à niveau

28

J'exécutais 12.04 avec Unity 3D pendant 6 mois; mon portable fonctionnait presque silencieusement et assez froid pour tenir sur mes genoux avec environ 4 heures d'autonomie. J'ai mis à jour à 12.10 et je suis passé au shell Gnome 3. Maintenant, mon ordinateur devient trop chaud pour rester sur mes genoux, le ventilateur tourne constamment à plein régime et j'ai environ 45 minutes d'autonomie. Le comportement est cohérent entre la puissance de la batterie et le courant alternatif. Ceci est la sortie de sensors :

acpitz-virtual-0 
Adapter: Virtual device 
temp1:        +84.0°C  (crit = +99.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +84.0°C  (high = +86.0°C, crit = +100.0°C) 
Core 0:         +74.0°C  (high = +86.0°C, crit = +100.0°C) 
Core 1:         +72.0°C  (high = +86.0°C, crit = +100.0°C) 
Core 2:         +75.0°C  (high = +86.0°C, crit = +100.0°C) 
Core 3:         +84.0°C  (high = +86.0°C, crit = +100.0°C)

radeon-pci-0100 
Adapter: PCI adapter 
temp1:        +76.0°C

J'ai une carte graphique HP Pavilion dv6, Intel i7, AMD Radeon. S'il vous plaît laissez-moi savoir si vous avez besoin d'informations supplémentaires.

Quelle pourrait être la différence entre ces deux éditions d’Ubuntu qui ont provoqué un changement aussi radical?

Modifier 1:

La suggestion de Per @ Paul, j'ai couru htop pour essayer de réduire le problème. Voici le résultat!

(côté gauche du terminal)

(côté droit du terminal)

Ceci est environ 10 minutes après le démarrage, htop , yakuake et une page chrome avec 1 onglet ouvert à cette question sont tout ce que j'ai ouvert manuellement. Le programme le plus exigeant pour le processeur est htop lui-même. Je pense que le problème doit être ailleurs; mes temps sont déjà de ~ 65C pour le processeur et de ~ 69C pour le GPU, avec près de 0% d'utilisation du processeur.

Modifier 2:

Comme demandé par @psusi, voici la sortie de 2 onglets de powertop (mes couleurs ont changé pour la lisibilité):

Encore une fois, tout ce que je lance manuellement est un onglet google-chrome et un terminal yakuake . Je suis assez nouveau à powertop , donc je ne sais pas comment interpréter cela. Faites-moi savoir si vous avez besoin d'informations des autres onglets.

Modifier 3:

J'avais des problèmes de batterie avec 12.04 et je les ai corrigés en changeant certaines lignes en /etc/default/grub ; crédit cette question .

  

GRUB_CMDLINE_LINUX_DEFAULT="splash calme acpi_osi = Linux acpi_backlight = vendeur pcie_aspm = forcer i915.i915_enable_rc6 = 1 i915.lvds_downclock = 1 i915.i915_enable_fbc = 1"   GRUB_CMDLINE_LINUX="pcie_aspm = force"

J'ai gardé ces lignes identiques après la mise à jour au 12.10. Est-ce que ça a l'air bien?

Modifier 4:

@Arup Roy Chowdhury a mentionné que mes pilotes AMD ne sont peut-être pas installés correctement. J'utilise actuellement le pilote suivant (sortie de software-properties-gtk ):

Dois-je utiliser un pilote propriétaire à la place? Le gnome-shell semble avoir une accélération graphique correcte avec l’Open Source.

Modifier 5:

@hazrpg J'ai posté les fichiers journaux que vous avez demandés sur Ubuntu Pastebin . Voici le dmesg.log , lspci .log et lsusb.log . Voir des problèmes?

Modifier 6:

@Sepero Voici mes temps morts. Je ne lance qu'un terminal environ 10 minutes après le démarrage.

acpitz-virtual-0
Adapter: Virtual device
temp1:        +64.0°C  (crit = +99.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0:  +63.0°C  (high = +86.0°C, crit = +100.0°C)

Core 0:         +62.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:         +60.0°C  (high = +86.0°C, crit = +100.0°C)
Core 2:         +60.0°C  (high = +86.0°C, crit = +100.0°C)
Core 3:         +63.0°C  (high = +86.0°C, crit = +100.0°C)

radeon-pci-0100
Adapter: PCI adapter
temp1:        +68.0°C 

Le simple fait d'ouvrir google-chrome pour coller cette édition pendant une minute a augmenté ces températures de quelques degrés chacune. Mon ordinateur n'était pas dans les années 60 avant la mise à jour.

FIXE !!:

Problème résolu. Merci à @ DrA7 et @YellowApple de m'indiquer les problèmes de carte graphique. J'ai trouvé cette question merveilleuse et implémenté la solution de @Nick Andrik. En un mot, installer les pilotes propriétaires (fglrx-updates) de ppa: andrikos a résolu le problème. Je peux maintenant utiliser ATI Catalyst pour choisir mon mode d'alimentation et quelle carte graphique (Intel ou AMD) je souhaite utiliser. Mes températures tombent à ~ 44 degrés et la durée de vie de la batterie est de 4 heures environ. J'ai également installé Jupiter, qui a amélioré la batterie et la température.

Les pilotes open source pour AMD semblent s’améliorer, mais il semble que leur prise en charge des cartes graphiques hybrides (comme la mienne) ne soit pas à la hauteur des spécifications. Utilisez les pilotes propriétaires pour le moment.

    
posée dinkelk 13.04.2017 - 14:23
la source

6 réponses

10

Je pense que cela doit être lié à vos pilotes vidéo.

Est-ce que ce serait en utilisant 12.04 que vous aviez les pilotes propriétaires installés mais en quelque sorte passés en open source après la mise à niveau?

Vos problèmes correspondent exactement aux miens et 12.10 sont installés sur un HP Pavillion G7, avec i5 et hybride graphique Intel HD3000 / Radeon 6850. Je suppose que vous n'utilisez actuellement que le processeur graphique Intel et c'est ce qui cause vos problèmes. (Pourtant, la lecture de la température de votre GPU est la plus élevée ...)

Je n'ai pas encore trouvé de meilleure solution que d'appliquer les paramètres Grub que vous avez décrits dans Edit 3, avec l'installation de Jupiter et le mettre sur "Power Saving".

EDIT

Suis-je pour la première fois depuis la mise à niveau à 12.10 capable d'afficher Unity en utilisant fglrx après avoir appliqué la solution que vous avez suggérée dans "FIXED !!", c'est-à-dire "installer les pilotes propriétaires (fglrx-updates) de ppa: andrikos" sans autres modifications.

    
réponse donnée DrA7 11.12.2012 - 22:01
la source
9

Contexte: Pilotes ATI PowerPlay vs Open source

De nombreuses personnes rencontrent des problèmes de performances graphiques et d’économie d’énergie après la mise à niveau vers Ubuntu 12.10. Cela est dû au manque de prise en charge des pilotes pour X Server 1.13 fourni avec la mise à niveau d'Ubuntu, ce qui oblige les utilisateurs à utiliser des pilotes open source ou à passer aux versions précédentes de X Server. Bien que les pilotes Open Source aient été considérablement améliorés ces dernières années, ils ne sont pas à la hauteur de la gestion de l'alimentation de PowerPlay fournie avec les pilotes ATI propriétaires.

Quelques points à noter ici pour ceux qui pourraient lire:

Cela n'affecte que les cartes graphiques HD 4xxx et les versions inférieures. Les utilisateurs de cartes ultérieures ne devraient avoir aucun problème à utiliser les pilotes ATI Catalyst. Voir cette question pour des problèmes connus.

Solutions possibles

Je n'ai pas encore trouvé de solutions entièrement automatisées qui fonctionnent au niveau de la gestion GPU d'ATI PowerPlay. Cependant, j'ai rencontré quelques outils et astuces intéressants qui vous permettent essentiellement de contrôler les profils GPU.

Rétrogradez à la version précédente de X Server et installez les pilotes Catalyst ATI. La méthode la plus simple consiste peut-être à ne pas utiliser X Server 1.13. Utilisez ppa de Tomasz Makarewicz pour rétrograder X Server vers la version 1.12 et installez les pilotes de catalyseurs hérités de fglrx. Le succès avec lequel ces paquets résolvent les problèmes est mixte alors vous devriez être attentif à ce sujet.

Pour ajouter le référentiel pour les types de paquetages

sudo add-apt-repository ppa:makson96/fglrx

Mettez à jour et mettez à niveau le système pour appliquer la mise à niveau inférieur du serveur X:

sudo apt-get update
sudo apt-get upgrade

et enfin installer le pilote hérité

sudo apt-get install fglrx-legacy

Si vous souhaitez désinstaller ces packages et revenir aux pilotes Xorg, vous devez supprimer le référentiel et revenir à la version standard du serveur X. Cela peut être fait en utilisant ppa-purge:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:makson96/fglrx

qui supprimera automatiquement les packages associés au référentiel cible. Il suffit de redémarrer et les pilotes Xorg doivent être réinstallés.

Contrôle manuel de la méthode d'alimentation

Les pilotes Xorg fournissent des fonctionnalités pour contrôler les méthodes d’alimentation des graphiques Radeon. Le contrôle dynamique doit être activé par défaut, permettant au système de gérer lui-même les profils d'alimentation. Pour afficher l'état actuel du contrôle de l'alimentation, vous pouvez exécuter

sudo cat /sys/class/drm/card0/device/graphics/fb0/device/power_method

Cela affichera soit dynpm (contrôle automatique) ou profil (contrôle manuel). Si vous souhaitez contrôler vous-même les profils d’alimentation, vous pouvez définir le profil par

sudo echo profile > /sys/class/drm/card0/device/graphics/fb0/device/power_method

et fournir un profil valide avec

sudo echo mid > /sys/class/drm/card0/device/graphics/fb0/device/power_profile

Les options possibles sont

default
auto
low
mid
high

Pour réactiver la gestion de l'alimentation dynamique, exécutez simplement

sudo echo dynpm > /sys/class/drm/card0/device/graphics/fb0/device/power_method

Gestionnaire de profil Radeon Power

Les utilisateurs de Gnome 3 pourraient être intéressés par l’extension Radeon Power Profile Manager , contrôler les profils GPU des pilotes Xorg. J'avoue que je n'ai pas testé cet outil moi-même, mais cela vaut la peine d'essayer.

    
réponse donnée Christian Skjødt 11.12.2012 - 23:27
la source
3

J'ai trouvé que 12.10 (et les distributions basées sur Ubuntu basées sur 12.10, comme Linux Mint 14) ont tendance à fonctionner très chaud avec les pilotes open-source sur les GPU AMD / ATI pour une raison quelconque. L'installation du pilote propriétaire aide - ou du moins cela m'a aidé. Allez-y et essayez.

    
réponse donnée YellowApple 11.12.2012 - 18:47
la source
1

J'ai eu un fort t en raison d'une utilisation élevée du processeur non sollicitée. En quelque sorte, l'installation de bumbleebee associée à l'installation de jupiter a réduit l'utilisation du processeur et t!

  

sudo add-apt-repository ppa: bumblebee / stable sudo add-apt-repository

     

ppa: ubuntu-x-swat / x-mises à jour sudo apt-get update

     

sudo apt-get installe bumblebee bumblebee-nvidia linux-headers-generic

    
réponse donnée Venem 08.12.2012 - 01:25
la source
0

La température élevée est probablement due à une charge importante sur le processeur ou sur le GPU ou les deux.

Dans votre cas, il semble que les deux sont très chauds. Je recommande de réduire le problème en vérifiant ce qui utilise vos ressources. Émettre la commande top ou mieux encore htop dans un terminal, puis trier les processus en fonction de l'utilisation du processeur peut vous aider à trouver la tâche à l'origine des températures élevées.

top est déjà installé par défaut. Personnellement, je trouve que htop est beaucoup plus convivial. Appuyez sur F6 pour trier par CPU avec htop.

Pour l'installer: sudo apt-get install htop

    
réponse donnée Paul 05.12.2012 - 09:09
la source
0

J'ai eu le même problème avec Ubuntu 12.04 et 13.04 sur mon ordinateur portable Sony Vaio SVE1512W1ESI avec une carte AMD Radeon HD 7500M / 7600M. Le ventilateur fonctionnait tout le temps et l'outil des capteurs affichait des températures dans les 60 secondes (a commencé avec 56-57 et est ensuite passé à 67-68 avec, par exemple, le navigateur ouvert).

J'ai installé des pilotes propriétaires à partir du système Paramètres - & gt; Pilotes supplémentaires mais n’a pas aidé. Enfin, j'ai installé un pilote propriétaire à partir du site Web d’AMD et le problème a été résolu.

J'ai suivi les étapes simples suivantes pour l'installer (comme décrit dans le manuel d'instructions d'installation disponible sur la même page Web):

  1. sudo sh ./amd-driver-installer-catalyst-13-4-x86.x86_64.run
  2. Choisissez la première option ( Install driver XX on X.Org XX ), puis choisissez Automatic
  3. sudo /usr/bin/aticonfig --initial
  4. Redémarrer
réponse donnée Jahanzeb Farooq 20.07.2013 - 01:56
la source

Lire d'autres questions sur les étiquettes