bloqué au redémarrage et à l'arrêt

28

J'ai récemment installé Ubuntu 12.04 et je l'adore. Cependant, j'ai un problème: je suis incapable d'arrêter ou de redémarrer correctement.

Lorsque j'arrête mon portable (Acer Aspire 5560), il se bloque sur les 5 points et y reste.

Quand je redémarre mon portable, il s’arrête mais quand il redémarre, il reste sur l’écran Purple (pas de logo)

Je pense que je devrais arrêter ceci:

  • sudo service network-manager stop avant la fermeture - rien

  • Ajout de certaines lignes au fichier GRUB - rien

  • installé d'autres versions d'Ubuntu - rien
  • sudo shutdown -h now - rien

et quelques autres.

En ce moment je vois un écran noir devant moi avec le texte

 Asking all remaining processes to terminate [OK]

Et les 5 points avec seulement la dernière orange.

Sur d’autres essais, j’ai eu ce truc:

modem-manager:could not get the system bus......

J'ai d'abord eu Ubuntu dual boot Windows. Et puis ça a bien fonctionné. Cependant, après une nouvelle installation d'Ubuntu, j'ai eu ça.

    
posée Max Beer 05.05.2012 - 17:44
la source

8 réponses

17

J'ai eu un problème similaire avec un Dell XPS 15z que j'ai résolu en ajoutant acpi=noirq aux arguments du noyau:

sudo vi /etc/default/grub

set

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq quiet splash"

alors

sudo update-grub

Notez que précédemment, j'utilisais acpi=off , ce qui me permettait de démarrer, mais pas d'arrêter. Sans drapeau acpi, je n'ai pas pu démarrer.

    
réponse donnée user62664 11.05.2012 - 18:19
la source
5

Vous pouvez essayer ces commandes dans le terminal

  

Pour l’arrêt

sudo halt
     

Pour l’arrêt

sudo init 0
     

Pour redémarrer

sudo init 6
     

Pour l’arrêt

 sudo shutdown -h now
     

Pour la mise en veille prolongée

sudo /etc/acpi/hibernate.sh
    
réponse donnée sRaa 06.05.2012 - 06:54
la source
2

J'ai reçu un piratage de ce lien - lien , pour une raison quelconque si les contrôles USB sont définis sur auto , la boucle shutdown-reboot démarre. La solution était de les rendre on avec force.

J'ai ajouté une fonction dans le script /etc/init.d/halt comme ceci -

# Add this function in the /etc/init.d/halt script
# call before do_stop
set_usbs_on () {
    usbcontrolpath="/sys/bus/usb/devices/*/power/control"
    for dev in $usbcontrolpath;
    do
        echo "Setting $dev: " 'cat $dev' "to on"
        echo on > $dev
        echo ""
    done
}

et je l'appelle avant do_stop dans case stop switch -

stop)
    set_usbs_on
    do_stop
    ;;

Maintenant, la machine s'arrête.

    
réponse donnée ramgorur 24.12.2013 - 01:09
la source
1

J'étais également confronté au même problème sur Dell Inspiron 7537. Aucune des solutions ne fonctionnait pour moi.

Sans intention, je viens d'activer le Bluetooth et maintenant je ne suis pas confronté à ce problème, mais le désactiver entraîne le redémarrage du système au lieu de l'arrêt.

    
réponse donnée vivek kumar 31.05.2015 - 13:43
la source
0

La seule chose que je devais faire était d'appuyer sur Ctrl + Alt + T pour ouvrir le terminal. Lorsqu'il s'ouvre, exécutez la commande ci-dessous

sudo update-grub

et maintenant ça marche très bien.

    
réponse donnée zoky 20.08.2012 - 16:05
la source
0

Même problème avec des faux accrocs "sur les 5 points". J'ai lu quelque part (ne peut pas me rappeler où) d'abord "Log Out" (menu en haut à droite) et ensuite l'arrêt. Je le fais depuis plus d'un mois maintenant, sans plus.

    
réponse donnée Marc Polizzi 27.09.2012 - 04:20
la source
0

Je ne suis pas expert, mais je chargé BartPE pour se rendre à une commande PROMT et réinstallé bios il démarré directement sur le disque dur, il ne pouvait pas deviner le voir juste essayer de charger par défaut dans votre bios pourrait ne pas avoir à mettre à jour

    
réponse donnée Kenny 20.01.2015 - 06:42
la source
0

Je me rends compte que c'est un super vieux message, mais j'ai trouvé la réponse REAL pour ce modèle. Ce n'est pas Ubuntu, c'est Aspire.

À partir du registre de bogues Ubuntu: ( lien )

  

Il semble que ce soit un bogue BIOS / UEFI, donc il n’ya pas de solution pour le corriger   5560g si la planification utilise l'efi.

Un utilisateur sur TomsGuide confirme que c'est le cas même lorsque installer Windows:

  

Le problème est que le modèle ACER Aspire 5560G en quelque sorte (ne demandez pas   comment {peut-être lié au BIOS?}) ne peut pas s'arrêter correctement (geler) lorsque le   Le système d'exploitation est installé dans un style de partition GPT.

Encore une solution à partir de la page des bogues: ( lien )

  

SOLUTION DE CONTOURNEMENT: utilisation de gdisk pour convertir gpt en mbr, installation de la réparation au démarrage, restauration   mbr et ensuite restaurer grub

Beaucoup de travail pour réparer une si petite chose. Certains utilisateurs ont suggéré qu'un BIOS mette à jour mon aide.

CLAUSE DE NON-RESPONSABILITÉ: Je ne peux confirmer qu’en dehors de cette erreur, Windows subit effectivement les mêmes problèmes lorsqu’elle est installée avec gpt. Si je décide de suivre la solution de contournement (très risquée) ou de mettre à jour le BIOS (encore plus risqué) et d'obtenir d'autres résultats, je les mettrai à jour.

    
réponse donnée OneHoopyFrood 21.01.2015 - 19:23
la source

Lire d'autres questions sur les étiquettes