Comment puis-je empêcher la gestion de l'alimentation d'iwconfig?

31

Je suis concerné par ce bogue: 869502 .

Une solution de contournement qui semble arrêter les paniques du noyau pour moi est de désactiver la gestion de l'alimentation de wlan0:

sudo iwconfig wlan0 power off

Cependant, il semble que la gestion de l’alimentation soit automatiquement rétablie lorsque je débranche le câble d’alimentation et que je pense également à bien d’autres reprises.

Y a-t-il quelque chose qui pourrait causer cela? Est-ce que quelqu'un sait comment je peux l'empêcher?

    
posée Alex 05.12.2011 - 01:52
la source

9 réponses

24

Le powermanagement sans fil est exécuté par un hook dans pm-utils . Vous pouvez le désactiver de l'une des manières suivantes:

Créez un fichier dans /etc/pm/config.d . Je l'ai nommé liste noire:

gksu gedit /etc/pm/config.d/blacklist

et dans le fichier keep:

HOOK_BLACKLIST="wireless"

Si vous souhaitez désactiver les autres hooks, les hooks par défaut sont situés à /usr/lib/pm-utils/power.d/ .

OU

Vous pouvez simplement créer un hook vide dans /etc/pm/sleep.d ou /etc/pm/power.d . Voir lequel travaille pour vous. c'est-à-dire

Just do

sudo touch /etc/pm/sleep.d/wireless

OU

sudo touch /etc/pm/power.d/wireless
    
réponse donnée sagarchalise 05.12.2011 - 03:02
la source
22

Si la désactivation de la gestion de l’alimentation de votre interface sans fil accélère la vitesse sur Internet comme ceci:

sudo iwconfig wlan0 power off

Que de lui donner la commande d’exécution permanente comme suit:

  1. cd /etc/pm/power.d

  2. sudo gedit wifi_pwr_off

    Cela ouvrira un fichier vide, copiez le code ci-dessous dedans:

    #!/bin/sh 
    /sbin/iwconfig wlan0 power off
    
  3. Enregistrez le fichier, n'oubliez pas de

    sudo chmod +x wifi_pwr_off
    

    et redémarrer.

réponse donnée Atul Kakrana 01.05.2012 - 23:02
la source
14

Tapez iwconfig et regardez la sortie. Vous devriez voir le nom de votre jeu de puces ainsi que si la gestion de l’alimentation est activée ou non. Si ce n'est pas le cas, c'est probablement désactivé.

Pour désactiver la gestion de l'alimentation, accédez à /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf et vous verrez

[connection]
wifi.powersave = 3

Remplacez 3 par 2 et redémarrez.

Ensuite, exécutez iwconfig et si cela fonctionnait, vous devriez voir Power Management:off .

Source: lien

    
réponse donnée user3273814 15.12.2016 - 02:58
la source
3

Ma méthode préférée consiste à ajouter la ligne suivante dans /etc/network/interfaces aux paramètres de mon interface sans fil:

post-up iwconfig wlan0 power off

Voici un exemple complet:

auto wlan0
iface wlan0 inet static
 address 192.168.1.2
 network 192.168.1.0
 netmask 255.255.255.0
 broadcast 192.168.1.255
 gateway 192.168.1.254
 post-up iwconfig wlan0 power off
 wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Notez que man interfaces indique que le comportement de post-up peut changer dans le futur.

    
réponse donnée RobM 03.01.2013 - 05:31
la source
3

Pour une raison quelconque, les solutions les mieux votées n’ont pas fonctionné pour moi et la gestion de l’énergie a continué à revenir. J'ai fini par faire ce qui suit:

sudo gedit /etc/rc.local

Et ajouté la ligne suivante avant exit 0 :

( sleep 30 && iwconfig wlan0 power off )&

Cela désactive la gestion de l'alimentation 30 secondes après la connexion ...

Edit: En fait, cela ne suffisait pas. J'ai continué à essayer un tas de choses, y compris lien , ce qui, je pense, a résolu mon problème (j'espère).

    
réponse donnée Anis Abboud 16.10.2015 - 15:30
la source
2

Une autre approche consiste à ajouter une directive explicite ( wireless-power ) pour contrôler la gestion de l'alimentation dans le fichier de configuration /etc/network/interfaces (par exemple, le désactiver pour wlan0 avec DHCP):

auto wlan0
iface wlan0 inet dhcp     
  wireless-power off
    
réponse donnée Pierz 05.04.2016 - 18:02
la source
1

Excellent conseil. 'sudo iwconfig wlan0 power off' semble être le seul moyen de faire fonctionner mon module ath9k (avec le noyau 3.2 - curieusement dans le noyau & gt; 3.5, il semble y avoir aucun problème, mais les noyaux en raison de leurs problèmes de suspension / disque) avec amd64 semble être un non, malheureusement. :-()

    
réponse donnée J.-S. Farinet 03.11.2012 - 14:47
la source
1

Une meilleure approche (au moins sur Ubuntu 16.04) consiste à créer /etc/network/if-up.d/wifi-powerman-off avec le contenu suivant:

#!/bin/sh

IWCONFIG=/sbin/iwconfig
WLAN_IFACE=<your wireless device here>

if [ ! -x $IWCONFIG ]; then
    exit 1
fi

if [ "$IFACE" = $WLAN_IFACE ]; then
    $IWCONFIG $IFACE power off
fi

et définissez-le comme exécutable. La gestion de l'alimentation sera désactivée à la prochaine connexion à un réseau.

Cela fonctionne bien avec NetworkManager.

    
réponse donnée Carmine Paolino 17.09.2016 - 03:58
la source
1

Si vous utilisez laptop-mode-tools , vous pouvez désactiver la gestion de l'alimentation sans fil en modifiant /etc/laptop-mode/conf.d/wireless-iwl-power.conf (Ubuntu 14.04):

# Control Intel IWL wireless power?
# Set to 0 to disable
CONTROL_IWL_POWER=0
    
réponse donnée chriscz 08.06.2017 - 10:48
la source

Lire d'autres questions sur les étiquettes