Comment désactiver le démarrage automatique de SSHD?

29

Après l'installation de openssh-server, le serveur démarre à chaque démarrage. Si je veux que ce soit manuel, que dois-je faire?

Dans la version 0.6.7+ de upstart, j'ajouterais une strophe "manual" au fichier de travail.

10.04 a le démarrage 0.6.5-8. Quelle est la méthode préférée pour désactiver le démarrage automatique de ssh dans ce cas?

    
posée komputes 12.08.2011 - 00:45
la source

9 réponses

29

Renommez /etc/init/ssh.conf en /etc/init/ssh.conf.disabled.

sudo mv /etc/init/ssh.conf /etc/init/ssh.conf.disabled
    
réponse donnée komputes 12.08.2011 - 18:11
la source
18

Cela devrait suffire,

 update-rc.d ssh enable # sets the default runlevels to on 
 update-rc.d ssh disable # sets all to off
    
réponse donnée hhlp 12.08.2011 - 11:14
la source
6

Dans votre fichier /etc/init/ssh.conf, commentez la ligne démarrer sur :

# ssh - OpenBSD Secure Shell server
#
# The OpenSSH server provides secure shell access to the system.

description     "OpenSSH server"

#start on filesystem or runlevel [2345]
stop on runlevel [!2345]

respawn
respawn limit 10 5
umask 022
    
réponse donnée Bryan Agee 12.08.2011 - 01:17
la source
5

note au lecteur:

pour moi (Ubuntu 14.xx) seule la réponse de Bryan Agee a fonctionné: /etc/init/ssh.conf: commente la ligne "start on fileystem or runlevel ..."

Pourquoi les autres ne le feront-ils pas?

  

sudo mv /etc/init/ssh.conf /etc/init/ssh.conf.disabled

entraînera la désactivation complète du service . Il est alors impossible de démarrer avec "service ssh start".

  

update-rc.d ssh enable # définit les niveaux d’exécution par défaut sur on

ne fonctionne tout simplement pas (peut-être utilise une routine de démarrage automatique différente)

  

/etc/init/ssh.conf.override avec "manual"

ne fonctionne tout simplement pas

  

touchez / etc / ssh / sshd_not_to_be_run

désactive également complètement le système

  

sudo apt-get install bum

beau logiciel, mais il ne montre pas ssh, donc rien à faire ici

personne interrogeant:     pourquoi les réponses ci-dessus même ici? le système de démarrage est-il si compliqué ou personne ne tente ses solutions? oO

    
réponse donnée TheTrowser 24.01.2016 - 21:36
la source
2
sudo apt-get install bum

Démarrez bum avec les privilèges d'administrateur, désactivez openssh-server, confirmez-le, terminé.

    
réponse donnée RobinJ 12.08.2011 - 11:27
la source
2

Pour le système ayant systemd , la manière correcte de le faire est

sudo systemctl disable ssh.service

alors

sudo systemctl stop ssh.service
    
réponse donnée Jocelyn 14.04.2017 - 11:32
la source
1

Pour les versions avec ssh démarré par upstart, exécutez touch /etc/ssh/sshd_not_to_be_run . Le script d'init up vérifie ce fichier et, s'il existe, ne lance pas sshd.

    
réponse donnée Daenyth 05.11.2012 - 19:54
la source
1

La méthode manuelle fournie avec la méthode /etc/init/ssh.config .override ne fonctionne pas avec Ubuntu 14.04.03. sshd démarre toujours automatiquement.

La méthode /etc/ssh/sshd_not_to_be_run empêche le démarrage manuel de sshd .

J'ai dû utiliser la méthode de Brian Agee pour supprimer "start on" de /etc/init/ssh.conf . Ensuite, pour lancer manuellement sshd :

sudo service ssh start
    
réponse donnée Robert Bailey 21.11.2015 - 19:12
la source
0

J'ai eu la même question et voici ce que j'ai fait à ce sujet. C'est peut-être un peu un piratage, mais cela fonctionne assez bien et vous n'avez pas besoin de compromettre le programme. Mettez ce qui suit dans votre crontab:

@reboot sudo service ssh stop

Cela indique à cron d'arrêter ssh chaque fois que vous allumez votre ordinateur. L'utilisation de ssh pour se connecter à un autre ordinateur n'est pas affectée, car cela désactive uniquement le service du serveur. Et si vous souhaitez le réactiver pendant un court instant, il vous suffit de:

sudo service ssh start

Rappelez-vous juste de le désactiver lorsque vous avez terminé!

    
réponse donnée ARandomScientist 29.11.2016 - 00:05
la source

Lire d'autres questions sur les étiquettes