Les périphériques USB automatisés sont en lecture seule

29

Depuis que j'ai mis à niveau vers Ubuntu 12.10, la sortie automatique des périphériques USB ne fonctionne pas comme prévu. Lorsque je branche un périphérique de stockage, il est reconnu correctement, mais je ne dispose pas des privilèges d’écriture. J'ai pensé que les autorisations de / media ne sont peut-être pas correctement définies, mais je ne sais pas comment elles doivent être. Ils sont comme ça:

drwxr-xr-x  14 root  root   4096 Jan 13 19:37 media

J'ai également vérifié si mon utilisateur est membre du groupe plugdev et il l'est définitivement.

Quoi d'autre pourrait être la cause de ce problème?

Mise à jour: voici la sortie dmesg après avoir branché un périphérique de stockage USB: lien

    
posée user5950 25.01.2013 - 14:53
la source

5 réponses

34

Je pense que vous souffrez du bogue # 1021375

Vous pouvez le contourner en renommant le dossier ~ / .config / nautilus, puis en vous déconnectant et en vous reconnectant.

  1. mv ~/.config/nautilus ~/.config/nautilus-bak
  2. Déconnexion.
  3. Connexion
réponse donnée desgua 29.01.2014 - 20:43
la source
20
sudo mount -o remount,rw /media/MonterFolderName

Cela va résoudre le problème. Je ne sais pas comment le rendre permanent. Je ne suis pas sûr que chmod fonctionnerait si, dans le cas où l'USB n'est pas monté en mode readwrite en premier lieu.

Testé sur Ubuntu 12.10 et 13.

    
réponse donnée Jalpesh 30.07.2013 - 12:28
la source
11

Lorsque le port USB est inséré, il est monté sur /media/<username> et vous devez avoir des autorisations via une liste de contrôle d’accès.

Vous pouvez vérifier quelles sont les autorisations, par exemple

[email protected]:34:50:~$ getfacl /media/bcbc
# file: media/bcbc
# owner: root
# group: root
user::rwx
user:bcbc:r-x
group::---
mask::r-x
other::---

S'il n'y a pas de liste de contrôle d'accès, supprimez simplement le répertoire et il le recrée avec les autorisations appropriées.

sudo rmdir /media/<username>

Ou ajoutez la liste de contrôle d'accès:

sudo setfacl -m u:<username>:rx /media/<username>
    
réponse donnée bcbc 03.02.2013 - 05:34
la source
2

Le problème semble avoir disparu

Ceci est une question de 5 ans sur la version à court terme Ubuntu 12.10. Le lien dmesg n'est plus disponible dans la question du PO. Mais si je connecte un USB Ubuntu 18.04 Live avec stockage persistant, dmesg révèle:

$ dmesg | tail -n18
[115528.249547] usb-storage 1-9:1.0: USB Mass Storage device detected
[115528.250152] scsi host2: usb-storage 1-9:1.0
[115528.250474] usbcore: registered new interface driver usb-storage
[115528.255685] usbcore: registered new interface driver uas
[115529.281407] scsi 2:0:0:0: Direct-Access     Verbatim STORE N GO       PMAP PQ: 0 ANSI: 6
[115529.282090] sd 2:0:0:0: Attached scsi generic sg1 type 0
[115529.992200] sd 2:0:0:0: [sdb] 30261248 512-byte logical blocks: (15.5 GB/14.4 GiB)
[115529.992998] sd 2:0:0:0: [sdb] Write Protect is off
[115529.993006] sd 2:0:0:0: [sdb] Mode Sense: 23 00 00 00
[115529.993787] sd 2:0:0:0: [sdb] No Caching mode page found
[115529.993797] sd 2:0:0:0: [sdb] Assuming drive cache: write through
[115530.592616]  sdb: sdb1 sdb2 sdb3 sdb4 sdb5
[115530.596279] sd 2:0:0:0: [sdb] Attached SCSI removable disk
[115531.018019] EXT4-fs (sdb5): warning: mounting unchecked fs, running e2fsck is recommended
[115531.470201] EXT4-fs (sdb5): mounted filesystem without journal. Opts: (null)
[115531.480738] ISO 9660 Extensions: Microsoft Joliet Level 3
[115531.483397] ISO 9660 Extensions: Microsoft Joliet Level 3
[115531.512219] ISO 9660 Extensions: RRIP_1991A

Contrairement à OP, il n'y a pas d'avertissement pour la lecture seule. Remarquez la ligne:

  

sd 2: 0: 0: 0: [sdb] La protection en écriture est désactivée

Apparemment, quel que soit le problème il y a 5 ans, il n'existe plus aujourd'hui sous Ubuntu 16.04 LTS . Aussi pour la seule autre version de LTS d’aujourd’hui, 14.04 Je ne me souviens pas non plus de ce problème. Seules les cartes SD SD viennent à l'esprit comme étant en lecture seule, ce qui est tout à fait différent.

    
réponse donnée WinEunuuchs2Unix 06.03.2018 - 04:03
la source
1

Rien n’est faux avec les options de montage et le fichier fstab, à ma connaissance, il vous suffit d’utiliser la commande ci-dessous pour obtenir les droits requis sur le dossier des médias. et je vais vous expliquer pourquoi.

1) vos autorisations actuelles sur le dossier, comme vous l'avez mentionné, sont les suivantes. (Excusez-moi si vous le savez et je vous dérange avec ça.)

drwxr-xr-x 14 root root 4096 Jan 13 19:37 media dans ce d représente le répertoire, le premier groupe de rwx représente les droits de l'utilisateur qui possède cet objet, qui est dans votre cas racine.

deuxième groupe de rwx représente les droits du groupe qui possède cet objet & amp; Ici, vous n'avez que r-x, ce qui signifie que même si vous êtes dans le fichier sudoers ou dans le groupe admin, vous n'avez pas le droit d'y écrire.

Le troisième groupe de rwx est ou d'autres utilisateurs, qui ne sont pas propriétaires de cet objet ni dans le groupe qui détient les droits de propriété de cet objet. si votre cas, il est encore une fois r-x. c'est pourquoi vous ne disposez pas d'autorisations en écriture.

2) Vous devez donc modifier les autorisations du dossier multimédia. (Je vais considérer que vous êtes dans le groupe admin ou le fichier sudoers, car cela ne fonctionnera que dans ce cas). c'est donc ce que vous devez faire.

$ sudo chmod -R 775 /media

3) Cela vous donnera les permissions d’écriture requises sur tous les lecteurs montés automatiquement.

S'il vous plaît vérifier et laissez-moi savoir si cela ne fonctionne pas vous dira quoi d'autre peut être fait pour résoudre ce problème.

    
réponse donnée Hrish 05.02.2013 - 21:06
la source

Lire d'autres questions sur les étiquettes