Après la mise à jour vers 16.04, le mode audio Bluetooth A2DP a cessé de fonctionner

28

J'ai un joli récepteur audio bluetooth qui se connecte à ma chaîne hi-fi, et je pouvais le connecter au 14.04 en tant qu'évier A2DP de bonne qualité.

Après la mise à niveau vers 16.04, le périphérique se connecte uniquement en tant que casque et, en essayant de le changer en mode A2DP, cette erreur se produit dans mon journal syslog:

May 21 11:35:50 RRyS pulseaudio[6159]: [pulseaudio] module-bluez5-device.c: Refused to switch profile to a2dp_sink: Not connected

et la qualité de l’audio est absente. Comment puis-je le réparer?

    
posée Rmano 21.05.2016 - 12:32
la source

3 réponses

32

Plusieurs bogues sont ouverts à ce propos, vérifiez par exemple celui-ci (démarré en 15.05) et cet autre, assez ancien ; les causes en général ne sont pas bien comprises.

Avant de commencer à modifier les fichiers système, vous pouvez également vérifier Haut-parleur Bluetooth pas de son dans Ubuntu 16.04 (semble un bogue différent) et bluetooth A2DP ne fonctionne pas sur 16.04 (résolu dans les commentaires par une mise à niveau du noyau).

Le correctif qui a fonctionné pour moi est le suivant --- grâce à utilisateur RobertFM dans le tableau de bord et SimFox3 dans les forums Arch . Toutes les instructions suivantes doivent être exécutées à partir d'un shell racine ( sudo -i ). Faites attention et vérifiez trois fois.

  1. Avant tout, faites une sauvegarde de ces fichiers (vous ne savez jamais):

    cp /etc/bluetooth/audio.conf /etc/bluetooth/audio.conf.bak
    cp /etc/pulse/default.pa /etc/pulse/default.pa.bak
    cp /usr/bin/start-pulseaudio-x11 /usr/bin/start-pulseaudio-x11.bak
    
  2. Modifier /etc/bluetooth/audio.conf et le rendre similaire à celui-ci:

    # Configuration file for the audio service
    # This section contains options which are not specific to any
    # particular interface
    [General]
    Enable=Gateway,Source
    
    # Switch to master role for incoming connections (defaults to true)
    Master=true
    
    # If we want to disable support for specific services
    # Defaults to supporting all implemented services
    #Disable=Gateway,Source,Socket
    Disable=Socket
    
    # SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
    # Defaults to HCI
    #SCORouting=HCI
    
    # Automatically connect both A2DP and HFP/HSP profiles for incoming
    # connections. Some headsets that support both profiles will only connect the
    # other one automatically so the default setting of true is usually a good
    # idea.
    AutoConnect=true
    
    # Headset interface specific options (i.e. options which affect how the audio
    # service interacts with remote headset devices)
    [Headset]
    
    # Set to true to support HFP, false means only HSP is supported
    # Defaults to true
    HFP=true
    
    # Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
    MaxConnected=2
    
    # Set to true to enable use of fast connectable mode (faster page scanning)
    # for HFP when incoming call starts. Default settings are restored after
    # call is answered or rejected. Page scan interval is much shorter and page
    # scan type changed to interlaced. Such allows faster connection initiated
    # by a headset.
    FastConnectable=true
    
    # Just an example of potential config options for the other interfaces
    #[A2DP]
    #SBCSources=1
    #MPEG12Sources=0
    
  3. Modifier /etc/pulse/default.pa et commenter la ligne

    #load-module module-bluetooth-discover
    

    (il suffit d'ajouter le # au début)

  4. Modifiez /usr/bin/start-pulseaudio-x11 et ajoutez la ligne /usr/bin/pactl load-module module-bluetooth-discover après le chargement du module module-x11-xsmp ; en pratique, vous devez éditer le fichier à la fin pour avoir une strophe comme

    if [ x"$SESSION_MANAGER" != x ] ; then
        /usr/bin/pactl load-module module-x11-xsmp "display=$DISPLAY session_manager=$SESSION_MANAGER" > /dev/null
        # add this line here:
        /usr/bin/pactl load-module module-bluetooth-discover
    fi
    
  5. Redémarrer.

    Maintenant, vous devriez pouvoir configurer votre appareil sur A2DP et profiter d'une musique de haute qualité:

    Notez que vous devez parfois déconnecter et reconnecter votre appareil pour réactiver A2DP:

    ... oui, c'est une boîte de bugs. Mais quand ça marche, ça marche à merveille.

  6. Problèmes après le redémarrage

    Après tout cela, le tour semble fonctionner seulement après le prochain redémarrage. Dans un tel cas, essayez de suivre la réponse de rmfought :

      

    Ce qui fonctionne pour moi est de connecter le périphérique Bluetooth, passer à   Mode HSP / HFP, déconnectez-vous, reconnectez-vous puis passez en mode A2DP.

    ... fonctionne aussi pour moi (encore une fois). J'ai même dû dissocier une paire de la clé une fois.

  7. Si ça ne marche toujours pas ...

    Si cela ne fonctionne pas non plus pour vous, vous pouvez essayer avec ce script --- son auteur garde c'est à jour.

réponse donnée Rmano 21.05.2016 - 12:32
la source
35

Ce qui fonctionne pour moi est de connecter le périphérique Bluetooth, de passer en mode HSP / HFP, de déconnecter, de reconnecter puis de passer en mode A2DP.

    
réponse donnée rmfought 11.08.2016 - 20:30
la source
5

Ce n’est pas forcément une solution pour ceux qui ont besoin du micro, mais cela a fonctionné pour Ubuntu 16.04:

sudo nano /etc/bluetooth/audio.conf

Puis ajoutez Disable=Headset sous [General] .

[General]
Disable=Headset

Et redémarrez le service Bluetooth

sudo service bluetooth restart

Et tous les compliments à ce gars: lien

    
réponse donnée helgis 04.09.2016 - 01:31
la source

Lire d'autres questions sur les étiquettes