Ubuntu 16.04 + Nvidia Driver = Ecran vierge

31

MISE À JOUR DE LA QUESTION ORIGINALE 1:

Incluant la capture d'écran des pilotes supplémentaires. J'ai essayé d'installer à la fois 361.42 et 340.96 et les deux fois, j'ai un écran vide après le redémarrage.

QUESTION D'ORIGINE:

Lorsque j'installe le pilote NVIDIA pour Ubuntu et que je le redémarre, je reçois un écran vide. Je n'ai pas essayé 2 des pilotes nvidia et les deux fois, je reçois un écran vide.

Comment installer les pilotes nvidia et ne pas obtenir d’écran vierge?

Vous avez fait une recherche sur Google et il semble que je sois le premier à rencontrer ce problème depuis la publication de la version 16.04:

lien

    
posée oshirowanen 22.04.2016 - 09:37
la source

7 réponses

23

Où / quand obtenez-vous l’écran vide? Est-ce que le menu grub doit apparaître au démarrage ou lorsque l'écran de connexion Ubuntu Unity doit apparaître? Si c'est le dernier, essayez ce qui suit:

  1. Ajoutez nomodeset à votre entrée Ububu grub. Mettez en surbrillance l'entrée que vous utilisez pour démarrer, appuyez sur e, puis ajoutez remplacer

    ... ro quiet splash ...

    avec

    ... ro nomodeset quiet splash ...

Si cela démarre correctement sur l'écran de connexion, appuyez sur Ctrl + Alt + F2 , connectez-vous, puis exécutez sudo prime-select intel . Puis redémarrez et voyez si cela résout le problème.

En outre, comment installez-vous les pilotes NVidia? Effectuez une vérification sur nvidia.com si vous utilisez les bons.

    
réponse donnée SteveFromAccounting 22.04.2016 - 19:17
la source
6

Voici ma solution. Je devais tirer des réponses de plusieurs endroits.

Ma carte graphique est la GeForce GTX 950 de NVidia .

La première chose que j'ai faite a été de télécharger le dernier pilote NVidia stable sur nvidia.com (pour moi, c'était 361.42). J'étais sûr de sélectionner le dernier pilote stable et certifié. Au fait, c'est un fichier ".run". Recherchez comment installer les fichiers .run si vous n'êtes pas familier avec cela.

J'ai ensuite mis en liste noire les pilotes Nouveau en fonction de ce post (mes étapes sont ci-dessous et sont légèrement différentes de ce post):

Installez le pilote Nvidia au lieu de nouveau

J'ai fait tous de mon travail via le terminal virtuel accessible par Ctrl + Alt + F1 à partir de l’écran de connexion:

1) Mettre les modules en liste noire. Ouvrez le fichier blacklist.conf.

sudo vi /etc/modprobe.d/blacklist.conf

ajoutez les modules suivants à la fin du fichier:

blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

Enregistrez le fichier et quittez.

2) Supprimez tous les paquets nvidia * (notez que cela n’a rien fait pour moi, mais c’est recommandé. Pas de mal à le faire)

sudo apt-get remove --purge nvidia*

3) Mettez à jour le disque initramfs. Le mien était configuré pour charger les nouveaux pilotes. Cela prend plusieurs secondes. Ne pas redémarrer ou mettre sous tension!

sudo update-initramfs -u

4) Redémarrer

5) Arrêtez le gestionnaire d’affichage puis installez-le.

À l'écran de connexion, appuyez à nouveau sur Ctrl + Alt + F1 pour accéder au terminal virtuel. Une fois en mode texte, arrêtez le gestionnaire d’affichage:

sudo service lightdm stop

6) Ensuite, exécutez le fichier d'installation (le fichier .run que vous avez téléchargé). L'installation est bien documentée et contient de nombreux messages utiles (imaginez-le!). J'ai eu l'erreur à propos de l'échec du script de pré-installation. J'ai continué quand même. On m'a demandé "Voulez-vous exécuter l'utilitaire nvidia-xconfig pour mettre à jour automatiquement votre fichier de configuration X afin que le pilote NVIDIA X soit utilisé au redémarrage de X? Tout fichier de configuration X préexistant sera sauvegardé", a-t-il répondu Oui "et a continué. J'ai un système 64 bits et j'ai des erreurs 32 bits. Je ne m'en suis pas inquiété et j'ai continué. Les 64 bits installés correctement. Je suis arrivé à la fin de l'installation!

7) Croisez les doigts, redémarrez et connectez-vous. Mon système est finalement arrivé. J'espère que le tien fait aussi!

    
réponse donnée DerWanderer 26.04.2016 - 19:57
la source
2

Essayez d’ajouter nvidia ppa ppa: graphics-drivers / ppa et installez le dernier 364.15.

Cela fonctionne pour moi avec optimus 860m.

Cela ne fonctionne que si le démarrage sécurisé est désactivé.

    
réponse donnée Eduardo Moñino Esteban 22.04.2016 - 16:58
la source
2

Vous devez peut-être mettre en liste noire les pilotes nvidia au démarrage. Cela est parfois nécessaire avec les cartes graphiques hybrides.

  • Modifiez le fichier: /etc/modprobe.d/bumblebee.conf et ajoutez:

    blacklist nvidia-XXX
    blacklist nvidia-XXX-updates
    blacklist nvidia-experimental-XXX
    

    remplacer le XXX par la version du pilote graphique. Par exemple 346

  • redémarrez votre ordinateur.

réponse donnée JOnathanJOnes 24.04.2016 - 00:13
la source
1

J'ai résolu ce problème d'une manière différente. J'ai installé 16.04 sur un très vieil ordinateur. J'ai installé le pilote Nvidia hérité et obtenu l'écran vide.

J'ai installé Lubuntu pour utiliser le bureau LXDE. Cela fonctionne très bien pour moi.

sudo apt-get install lubuntu-desktop
    
réponse donnée Mattmon 17.06.2016 - 18:14
la source
0

Assurez-vous que secureboot est désactivé, le mien est activé et ignore l'avertissement lorsque je suis passé à la version 16.04. Si vous avez Secureboot activé, il sera bloqué sur gdm ou sur un écran noir.

    
réponse donnée user533456 22.04.2016 - 14:32
la source
-2

Essayez d’ajouter les options suivantes à votre fichier de configuration grub / etc / default / grub. Vous devrez mettre à jour grub par la suite.

GRUB_GFXMODE=1280x1024x32,auto
GRUB_GFXPAYLOAD_LINUX=keep
    
réponse donnée Ash 23.04.2016 - 03:01
la source

Lire d'autres questions sur les étiquettes