Aucune version d'Ubuntu ne peut être installée avec un processeur Intel de 6ème génération Skylake

31

Ubuntu ne peut pas être installé sur mon système à cause de ce que dit le titre. Ceci est dû au fait que le support Intel HD Graphics 530 n’a été ajouté que dans le noyau Linux 4.3 et que toutes les versions d’Ubuntu n’ont que des versions du noyau allant jusqu’à la version 4.2 du 15.10. Le processeur de mon ordinateur est le nouveau Intel Skylake 6600K si vous avez besoin de savoir, tout le reste est générique. Il possède une carte mère UEFI BIOS. Aide?

    
posée bain 28.10.2015 - 21:03
la source

6 réponses

22

Démarrez avec le paramètre nomodeset boot tel que décrit dans cette réponse .

Vous pourrez installer Ubuntu. Après l'avoir fait, le système ne redémarrera probablement pas.

Vous devrez accéder au menu grub en appuyant sur Maj ou ECHAP et en entrant nomodeset à nouveau.

Installez ensuite le noyau 4.3. Cela peut être fait de cette façon. Exécuter dans le terminal:

mkdir ~/linux-4.3
cd ~/linux-4.3
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300-generic_4.3.0-040300.201511020949_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-headers-4.3.0-040300_4.3.0-040300.201511020949_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.3-wily/linux-image-4.3.0-040300-generic_4.3.0-040300.201511020949_amd64.deb
sudo dpkg -i *.deb

et redémarrer. J'espère que le système démarrera sans le paramètre nomodeset .

Remarque: le noyau n’obtiendra pas de mises à jour. Vous devrez les installer manuellement à partir du PPA du noyau Mainline .

    
réponse donnée Pilot6 28.10.2015 - 22:33
la source
2

J'ai Ubuntu 15.10 Mate qui fonctionne bien avec Metacity installé, car il semble plus stable.

Je pensais qu'Ubuntu avait apporté des modifications au noyau de 4.2 pour Skylake, lisez ici:

lien

J'utilise un processeur Intel Core i5 6500 de sixième génération. Quelques problèmes mineurs sous Compbiz et Marco (gel partiel des écrans), mais la métacité est restée stable pendant des jours. J'ai un core i5 6500 avec une carte mère Gigabyte B150M D3H et un RAM DDR4 (8 Go). Juste en utilisant des graphiques à bord.

Le seul problème que j'ai rencontré ces derniers jours alors que l'utilisation de la métacité est YouTube sur Chrome provoquera une étrange image fantôme du navigateur si je tente de déplacer le navigateur le long de l'écran. . Son été assez stable jusqu'à présent.

    
réponse donnée Blackheath Weather 29.10.2015 - 07:07
la source
2

Nouvelle version du noyau 4.8.10 (23 novembre 2016)

Les mesures que tout le monde peut prendre sont de s’assurer que le microcode Intel est à jour. Voir la réponse ici: ( Surchauffe d'Ubuntu 16.04 Skylake )

Au lieu du noyau 4.2 , 4.3 ou 4.4.2 dans les autres réponses, vous devez mettre à jour le noyau 4.8.10 qui contient de bonnes critiques / améliorations:

cd /tmp
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8.10/linux-headers-4.8.10-040810_4.8.10-040810.201611210531_all.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8.10/linux-headers-4.8.10-040810-generic_4.8.10-040810.201611210531_amd64.deb
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.8.10/linux-image-4.8.10-040810-generic_4.8.10-040810.201611210531_amd64.deb
sudo dpkg -i *.deb
sudo reboot

Après avoir installé le nouveau noyau, vous pouvez essayer de déployer les modifications de ligne de commande grub pour nomodeset , i915.preliminary_hw_support=1 , etc.

Veuillez noter que la version 4.9 du noyau sera bientôt disponible. Nous espérons tous qu'Intel corrige les problèmes de pstate / cstate / thermald qui touchent nombre d'entre nous dans la version du noyau LTS.

    
réponse donnée WinEunuuchs2Unix 24.11.2016 - 01:37
la source
1

J'avais le même problème, à savoir que je ne pouvais pas installer Ubuntu 15.10 sur mon nouveau Thinkpad. J'ajoute donc ici ma solution au problème, car cela pourrait aider quelqu'un. J'ai essayé différents paramètres du noyau dans les options de démarrage et je l'ai fait fonctionner lorsque j'ai remplacé quiet splash --- par:

i915.preliminary_hw_support=1 nouveau.blacklist=1 edd=on nolapic pcie_aspm=force tpm_tis.interrupts=0 ---

Après avoir pu démarrer dans mon installation Ubuntu, j'ai effectué une mise à jour du noyau vers la version 4.3 et maintenant, je n’utilise qu’un seul paramètre du noyau, nolapic , pour le démarrer. Mais pour activer le toucher et le numériseur, je dois ajouter i915.preliminary_hw_support=1 .

    
réponse donnée albflo 22.01.2016 - 16:37
la source
1

J'ai écrit un manuel pour les problèmes de démarrage de l'écran noir et l'activation du Wi-Fi pour Ubuntu 15.10: lien

Si vous possédez le dernier Dell XPS13 Touch (9350) avec Skylake et Intel Graphics i915 sous Ubuntu 15.10 (ou toute autre version telle que 15.04 ou 16.04), vous devrez apporter des modifications pour le faire démarrer en toute sécurité sans rencontrer les problèmes d'écran noir. De plus, vous activerez le wifi de cette façon.

Pour installer Ubuntu (Kubuntu ou toute autre distribution ou version), vous aurez besoin d’une distribution Linux compatible avec UEFI.

Pour activer le wifi, vous avez besoin du dernier noyau (4.4+). Pour garantir un démarrage fluide et efficace via GRUB, vous devrez activer certains modules et mettre à jour les paramètres de GRUB2.

Installation UEFI Linux sur Dell XPS13 (9350)

  1. Appuyez sur F2 au démarrage (pendant que le logo Dell est affiché) et entrez dans le BIOS UEFI.

  2. Allez dans Général - & gt; Options de démarrage avancées et définissez-les pour désactiver tout.

  3. Accédez à Configuration système - & gt; Opération SATA et passez à AHCI .

  4. Accédez à Secure Boot - & gt; Activer le démarrage sécurisé et basculer vers Désactivé .

  5. Allez dans Comportement POST - & gt; Fastboot et définissez-le sur Thorough .

  6. En outre (après l’installation), vous pouvez modifier General - & gt; Séquence de démarrage dans l’ordre de votre choix et ajoutez GRUB2 - en choisissant EFI / ubuntu / grubx64.efi.

  7. Après l'installation d'Ubuntu (ou de tout autre Linux), mettez-le à jour vers le dernier noyau pour faire fonctionner le wifi sur Dell XPS13 (9350), par exemple Modèles 2015 et 2016.

    1. Téléchargez le dernier noyau stable (par exemple 4.4.2)

      Premièrement, vous devrez mettre à jour votre noyau vers la version 4.4.2 pour prendre en charge les graphiques wifi et Intel i915:

      wget in4serv.com.br/backup/kernel-4.4.2
      sudo chmod +x kernel-4.4.2
      ./kernel-4.4.2
      
    2. Ajouter des modules à initramfs

      Vous devrez éditer le fichier / etc / initramfs-tools / modules en exécutant sudo nano /etc/initramfs-tools/modules et en ajoutant ces deux modules au processus de démarrage:

      i195
      nvme
      
    3. Modification des options de GRUB2

      Modifiez les options de démarrage de grub2 en exécutant sudo nano /etc/default/grub et en modifiant ces lignes:

      GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.preliminary_hw_support=1"
      GRUB_GFXMODE="1024x768"
      

      La dernière ligne est votre résolution préférée, sinon GRUB utilisera la résolution UHD maximale difficile à lire. En outre, n'utilisez aucune résolution 16: 9 car GRUB semble avoir des problèmes avec celles-ci. Utilisez simplement n'importe quelle résolution d'écran 4: 3.

Vous pourrez maintenant démarrer Ubuntu sans problème.

    
réponse donnée dusoft 20.02.2016 - 15:22
la source
1

Problème

Je rencontrais le même problème sur un ThinkCentre m900 SFF avec un processeur i7-6700. Le système se figerait de manière aléatoire et une réinitialisation matérielle était nécessaire, ce qui rendait le travail avec ce système difficile, voire impossible. Le journal indiquait uniquement un état de blocage du processeur, mais ne fournissait pas d'informations détaillées car la consignation était également gelée.

Recherche

Ce problème est probablement lié aux états d'alimentation du processeur Skylake, qui ne sont pas encore compatibles avec les noyaux de la série 4x.

Tentatives de solution

J'ai essayé de définir le paramètre de démarrage intel_idle.max_cstate = 1, comme suggéré ici et ici et ici . Cela n'a pas eu d'effet positif et le système a continué à geler toutes les quelques heures.

J'ai également installé des noyaux plus récents dans Ubuntu 16.10, y compris le noyau 4.8, qui devrait prendre en charge les processeurs Skylake, mais le problème persiste et le système est bloqué. J'ai également essayé Mint 18.0, Mint 18.1, Ubuntu 16.04 et Ubuntu 16.10. Tous les systèmes ont montré le même comportement, ce qui, en rétrospective, n’a rien d’étonnant, car ils sont tous basés sur Xenial, mais j’ai essayé d’empêcher le gestionnaire de fenêtres d’être une cause. J'ai désactivé le GPU intégré et utilisé uniquement la carte Nvidia et vice versa pour exclure le GPU. J'ai désactivé UEFI et réinstallé avec un BIOS hérité, même effet.

Solution de contournement

Lenovo a officiellement certifié le système pour Ubuntu 14.04 , consultez ici . En dernier recours, j'ai réinstallé l'ancienne version d'Ubuntu, qui est apparue avant la sortie du processeur. Je ne m'attendais pas à ce que le noyau 3.x fonctionne, mais par surprise, je lance maintenant Mint 17.3 Rosa , basé sur Trusty (14.04.05 LTS) et sécurisé mises à jour jusqu'au début de 2019. J'espère que le problème sera résolu jusque-là, jusqu'à présent, je n'avais plus de gel.

    
réponse donnée Stefan 10.02.2017 - 09:16
la source

Lire d'autres questions sur les étiquettes