Erreurs de dépendance après l'installation et la tentative de suppression de Google Chrome

31

Donc Ubuntu a parfaitement fonctionné pour moi pendant un moment. J'ai essayé de télécharger Google Chrome et téléchargé accidentellement la version 32 bits. Je suis revenu et j'ai essayé de télécharger le 64 bits (stupidement sans supprimer le 32 bits), et j'ai commencé à avoir des problèmes pour obtenir des messages d'erreur liés à google-chrome-stable .

Ma prochaine étape consistait à purger tout ce que j'avais sur Ubuntu lié à Chrome, mais je reçois toujours ces erreurs et, étant donné que je suis encore un débutant sur Linux, je suis vraiment perdu pour ce qu’il faut faire maintenant. .

Maintenant, je ne peux rien télécharger via la ligne de commande. Par exemple, j'ai juste essayé de télécharger la version de Ubuntu de f.lux et j'ai obtenu ce qui suit:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  gcc-4.8-base:i386 libasn1-8-heimdal:i386 libasound2:i386
  libatk-bridge2.0-0:i386 libatk1.0-0:i386 libatspi2.0-0:i386
  libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386
  libcairo-gobject2:i386 libcairo2:i386 libcolord1:i386 libcups2:i386
  libcurl3:i386 libdatrie1:i386 libdbus-glib-1-2:i386 libdbusmenu-glib4:i386
  libdbusmenu-gtk3-4:i386 libdbusmenu-gtk4:i386 libexpat1:i386 libffi6:i386
  libfontconfig1:i386 libfreetype6:i386 libgconf-2-4:i386 libgcrypt11:i386
  libgdk-pixbuf2.0-0:i386 libglib2.0-0:i386 libgnutls26:i386
  libgpg-error0:i386 libgraphite2-3:i386 libgssapi-krb5-2:i386
  libgssapi3-heimdal:i386 libgtk-3-0:i386 libgtk2.0-0:i386 libharfbuzz0b:i386
  libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386 libheimntlm0-heimdal:i386
  libhx509-5-heimdal:i386 libidn11:i386 libjasper1:i386 libjbig0:i386
  libjpeg-turbo8:i386 libjpeg8:i386 libk5crypto3:i386 libkeyutils1:i386
  libkrb5-26-heimdal:i386 libkrb5-3:i386 libkrb5support0:i386 liblcms2-2:i386
  libldap-2.4-2:i386 libmbim-glib0 libnspr4:i386 libnss3:i386 libp11-kit0:i386
  libpango-1.0-0:i386 libpango1.0-0:i386 libpangocairo-1.0-0:i386
  libpangoft2-1.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386
  libpixman-1-0:i386 libqmi-glib0 libroken18-heimdal:i386 librtmp0:i386
  libsasl2-2:i386 libsasl2-modules:i386 libsasl2-modules-db:i386
  libsqlite3-0:i386 libssl1.0.0:i386 libstdc++6:i386 libtasn1-6:i386
  libthai0:i386 libtiff5:i386 libwayland-client0:i386 libwayland-cursor0:i386
  libwind0-heimdal:i386 libx11-6:i386 libxau6:i386 libxcb-render0:i386
  libxcb-shm0:i386 libxcb1:i386 libxcomposite1:i386 libxcursor1:i386
  libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxft2:i386
  libxi6:i386 libxinerama1:i386 libxkbcommon0:i386 libxrandr2:i386
  libxrender1:i386 libxss1:i386 libxtst6:i386 usb-modeswitch
  usb-modeswitch-data
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libappindicator1 libglade2-0 libindicator7
Suggested packages:
  python-gtk2-doc
The following packages will be REMOVED:
  google-chrome-stable:i386 libappindicator1:i386 libindicator7:i386
The following NEW packages will be installed:
  libappindicator1 libglade2-0 libindicator7 python-appindicator python-glade2
0 upgraded, 5 newly installed, 3 to remove and 3 not upgraded.
1 not fully installed or removed.
Need to get 53.4 kB/101 kB of archives.
After this operation, 185 MB disk space will be freed.
Do you want to continue? [Y/n] Y
Get:1 http://us.archive.ubuntu.com/ubuntu/ trusty/main libglade2-0 amd64 1:2.6.4-2 [44.6 kB]
Get:2 http://us.archive.ubuntu.com/ubuntu/ trusty/main python-glade2 amd64 2.24.0-3ubuntu3 [8,744 B]
Fetched 53.4 kB in 0s (159 kB/s)         
(Reading database ... 170838 files and directories currently installed.)
Removing google-chrome-stable (46.0.2490.71-1) ...
xdg-icon-resource: size argument must be numeric
Try 'xdg-icon-resource --help' for more information.
dpkg: error processing package google-chrome-stable (--remove):
 subprocess installed pre-removal script returned error exit status 1
xdg-icon-resource: size argument must be numeric
Try 'xdg-icon-resource --help' for more information.
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Removing libappindicator1 (12.10.1+13.10.20130920-0ubuntu4.1) ...
Removing libindicator7 (12.10.2+14.04.20141007.1-0ubuntu1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.6) ...
E: Sub-process /usr/bin/dpkg returned an error code (1)

Je dois pouvoir télécharger des paquets sans problèmes. Quelqu'un peut-il m'aider?

EDIT: De plus, lorsque j'ai essayé de mettre à jour le logiciel, j'ai reçu ce message:

**THE PACKAGE SYSTEM IS BROKEN.** 
Check if you are using third party repositories. If so disable them, since they are a common source of problems.
Furthermore run the following command in a Terminal: apt-get install -f

Mais quand je lance apt-get install -f , j'obtiens la sortie suivante:

Errors were encountered while processing:
 google-chrome-stable
E: Sub-process /usr/bin/dpkg returned an error code (1)

Réponse de sudo apt-get install -f :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libatk-bridge2.0-0:i386 libatspi2.0-0:i386 libcairo-gobject2:i386
  libcolord1:i386 libdbusmenu-gtk3-4:i386 libgtk-3-0:i386 liblcms2-2:i386
  libmbim-glib0 libqmi-glib0 libwayland-client0:i386 libwayland-cursor0:i386
  libxkbcommon0:i386 usb-modeswitch usb-modeswitch-data
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up google-chrome-stable (46.0.2490.71-1) ...
xdg-icon-resource: size argument must be numeric
Try 'xdg-icon-resource --help' for more information.
dpkg: error processing package google-chrome-stable (--configure):
 subprocess installed post-installation script returned error exit status 1
E: Sub-process /usr/bin/dpkg returned an error code (1)

La réponse à sudo apt-get update était très longue, alors je l’ai raccourcie au message d’erreur suivant:

W: Failed to fetch http://ppa.launchpad.net/fabricesp/ppa/ubuntu/dists/trusty/main/binary-amd64/Packages  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/fabricesp/ppa/ubuntu/dists/trusty/main/binary-i386/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Erreur pour install-f:

After this operation, 0 B of additional disk space will be used.
Setting up google-chrome-stable (46.0.2490.71-1) ...
xdg-icon-resource: size argument must be numeric
Try 'xdg-icon-resource --help' for more information.
dpkg: error processing package google-chrome-stable (--configure):
 subprocess installed post-installation script returned error exit status 1
E: Sub-process /usr/bin/dpkg returned an error code (1)

Et erreur pour dist-upgrade:

After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] Y
Setting up google-chrome-stable (46.0.2490.71-1) ...
xdg-icon-resource: size argument must be numeric
Try 'xdg-icon-resource --help' for more information.
dpkg: error processing package google-chrome-stable (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 google-chrome-stable
E: Sub-process /usr/bin/dpkg returned an error code (1)

Erreur de sudo dpkg --purge --force-all google-chrome-stable

Removing google-chrome-stable (46.0.2490.71-1) ...
xdg-icon-resource: size argument must be numeric
Try 'xdg-icon-resource --help' for more information.
dpkg: error processing package google-chrome-stable (--purge):
 subprocess installed pre-removal script returned error exit status 1
xdg-icon-resource: size argument must be numeric
Try 'xdg-icon-resource --help' for more information.
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 google-chrome-stable

En réponse aux suggestions de A.B, après avoir exécuté sudo rm /var/lib/dpkg/info/google-chrome-stable*.prerm , j'ai alors couru sudo apt-get install -f et obtenu la même réponse que je recevais:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libatk-bridge2.0-0:i386 libatspi2.0-0:i386 libcairo-gobject2:i386
  libcolord1:i386 libdbusmenu-gtk3-4:i386 libgtk-3-0:i386 liblcms2-2:i386
  libmbim-glib0 libqmi-glib0 libwayland-client0:i386 libwayland-cursor0:i386
  libxkbcommon0:i386 usb-modeswitch usb-modeswitch-data
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up google-chrome-stable (46.0.2490.71-1) ...
xdg-icon-resource: size argument must be numeric
Try 'xdg-icon-resource --help' for more information.
dpkg: error processing package google-chrome-stable (--configure):
 subprocess installed post-installation script returned error exit status 1
E: Sub-process /usr/bin/dpkg returned an error code (1)
    
posée segue_segway 22.10.2015 - 05:34
la source

5 réponses

19

On dirait que votre fichier de sources est corrompu et que des paquets sont cassés. Supprimez le fichier source endommagé en appuyant sur Ctrl + Alt + T pour ouvrir un terminal, puis tapez:

sudo rm /etc/apt/sources.list

Ensuite, tapez

sudo software-properties-gtk

Cela ouvrira software-properties-gtk et un nouveau sources.list sera créé automatiquement.

Puis changez le serveur en US ou en un autre serveur de votre choix. Vous devez activer les référentiels à partir de la nouvelle boîte de dialogue afin de créer de nouvelles sources.list.

Cochez toutes les cases puis cliquez sur Revenir puis cliquez sur Fermer.

Comment restaurer les référentiels par défaut?

Étape 2 Ouvrez un terminal et tapez

sudo apt-get remove --purge google-chrome-stable

Puis lancez

sudo apt-get update && sudo apt-get dist-upgrade -y

Installez ensuite Chrome.

Modifier

J'ai rejoint Sunny dans une discussion pour l'aider à résoudre le problème et à supprimer /var/lib/dpkg/alternatives/google-chrome en exécutant

 sudo rm /var/lib/dpkg/alternatives/google-chrome

et en cours d'exécution

 sudo apt-get update && sudo apt-get dist-upgrade -y

a résolu le problème et Sunny a déclaré que les erreurs ne se produisaient plus.

    
réponse donnée Neil 22.10.2015 - 05:44
la source
8

Eh bien, après la recherche d’une extension et la recherche de choses que j’ai déjà essayées, je suis allé où les scripts phpmyadmin.prerm, phpmyadmin.postrm, etc.

cd /var/lib/dpkg/info/

ls -l phpmyadmin.*
-rw-r--r-- 1 root root 165 2008-03-05 21:42 phpmyadmin.conffiles
-rwxr-xr-x 1 root root 287 2008-03-05 21:42 phpmyadmin.config
-rw-r--r-- 1 root root 33524 2008-08-06 11:31 phpmyadmin.list
-rw-r--r-- 1 root root 51996 2008-03-05 21:42 phpmyadmin.md5sums
-rwxr-xr-x 1 root root 3286 2008-03-05 21:42 phpmyadmin.postinst
-rwxr-xr-x 1 root root 1762 2008-03-05 21:42 phpmyadmin.postrm
-rwxr-xr-x 1 root root 1762 2008-08-06 09:12 phpmyadmin.postrm.orig
-rwxr-xr-x 1 root root 339 2008-03-05 21:42 phpmyadmin.preinst
-rw-r--r-- 1 root root 22441 2008-03-05 21:42 phpmyadmin.templates

puis j'ai supprimé ces fichiers

sudo rm -r phpmyadmin.*

alors j'ai couru

sudo apt-get clean
sudo apt-get update

Je voulais voir si le paquet était toujours là, alors j'ai couru

sudo apt-get remove phpmyadmin

J'ai eu la réponse que le paquet n’était pas installé pour ne pas pouvoir le supprimer.

ENFIN!

De là, je viens de courir

sudo apt-get install phpmyadmin

J'espère que cela aidera quelqu'un, car je cherche beaucoup de réponses dans les forums Ubuntu.

    
réponse donnée Hiren Raiyani 22.09.2016 - 11:59
la source
3

Suivez les commandes ci-dessous pour vous débarrasser de E: Le sous-processus / usr / bin / dpkg a renvoyé un code d'erreur (1)

étape 1:

sudo apt --purge remove unattended-upgrades

Ici, les mises à niveau sans surveillance sont "erreur de traitement du nom du package". Vous pouvez le remplacer par votre nom de package de traitement des erreurs.

étape 2:

sudo apt-get autoremove

étape 3:

sudo apt-get update
    
réponse donnée GANGA SIVA KRISHNA 11.07.2017 - 14:27
la source
1

La suppression de Chrome échoue car le script de pré-retrait pose un problème. Supprimez le script via

sudo rm /var/lib/dpkg/info/google-chrome-stable*.prerm
sudo rm /var/lib/dpkg/info/google-chrome-stable*.postinst

et recommencez la suppression via

sudo apt-get purge google-chrome-stable
sudo apt-get install -f

Pour une meilleure compréhension, lisez ma réponse ici .

Et le deuxième problème, le PPA pPA: fabricesp / ppa de PPA n’a pas de paquet pour Trusty. Utilisez donc

sudo add-apt-repository --r ppa:fabricesp/ppa

pour supprimer le PPA. ppa-purge ne fonctionne pas dans ce cas.

    
réponse donnée A.B. 22.10.2015 - 07:09
la source
0

Essayez d’exécuter les commandes suivantes sur le terminal:

sudo apt-get --purge remove google-chrome-stable
sudo apt-get -f install
sudo apt-get update

J'espère que cela va résoudre votre problème.

    
réponse donnée sup 26.09.2017 - 11:00
la source

Lire d'autres questions sur les étiquettes