Pourquoi la boîte de dialogue PrintScreen n'apparaît-elle pas dans Gnome?

30

J'utilise gnome-shell sur Ubuntu 12.04. Lorsque je frappe PrtSc pour prendre une capture d'écran, cela fonctionne, mais la capture est automatiquement enregistrée dans mon dossier Images. Il n'y a pas de dialogue demandant où enregistrer. Il montre bien la boîte de dialogue sous l'unité.

    
posée Ruben 03.04.2012 - 17:35
la source

4 réponses

30

En supposant que j'ai lu correctement ce rapport de bogue ...

C'est par conception. Non vraiment!

Les commentaires # 37 en parlent.

Les patchs d'unité actuels sont:

  

sur les sessions Unity affichent une boîte de dialogue de confirmation après avoir pris   captures d'écran avec les raccourcis clavier, le comportement de sauvegarde automatique est   confondre nos utilisateurs

Le fil se poursuit:

  

mais votre solution n’aide pas lorsque je n’utilise pas Unity. Pourquoi as-tu pensé   cela ne concerne que les utilisateurs Unity?

Avec la réponse:

  

parce que GNOME nous demande de laisser   leur bureau seul et expédier comme prévu afin que ce que nous essayons de   faire, nous nous en tenons au comportement en amont pour les environnements GNOME et prenons   décision de conception pour Unity

Alors voilà! Les développeurs de Gnome insistent pour que leur environnement de bureau se comporte de cette façon. C'est un problème en amont. Les développeurs Canonical respectent cette décision et par conséquent la "divergence" - Les utilisateurs d'Unity ont la boîte de dialogue Enregistrer sous tandis que les utilisateurs de gnome-shell n'ont pas de fonctionnalité de dialogue by-design .

Ainsi, si vous utilisez gnome-shell / gnome-classic, toutes les captures d'écran sont enregistrées dans le dossier de vos images personnelles ~/Pictures

Remarque: vous pouvez remplacer l’emplacement de la capture d'écran par gsettings (ligne de commande) ou dconf-editor (GUI):

  • définissez org.gnome.gnome-screenshot auto-save-directory sur file:///home/yourusername/wherever/you/want
réponse donnée fossfreedom 03.04.2012 - 17:56
la source
6

Je suis en retard à la fête, mais j'ai juste trébuché dessus et je veux offrir une réponse légèrement différente.

En gros, dans le dernier Gnome 3 / Gnome Shell, ils sont plus d’utilisation de Gnome Screenshot . Cela signifie que toute modification des paramètres par défaut de Gnome-Screenshot (comme l'emplacement de sauvegarde par défaut) n'affectera rien.

Au lieu de cela, vous devez accéder à vos paramètres de clavier, désactiver les raccourcis "Enregistrer une capture [...] d'images dans Pictures" et ajouter vos propres raccourcis personnalisés qui appellent gnome-screenshot sans args (enregistrement automatique défini par gsettings) emplacement), -a (zone de sauvegarde), -w (sauvegarde de la fenêtre actuelle) ou -i (si vous souhaitez que la boîte de dialogue des options soit rétablie). Vous pouvez évidemment combiner certains paramètres ou en ajouter à partir de man gnome-screenshot .

    
réponse donnée IBBoard 28.07.2013 - 21:31
la source
4

Essayez d’utiliser Shutter à la place, c’est le meilleur outil de capture d’écran (comme le dit le site):

sudo add-apt-repository ppa:shutter/ppa    
sudo apt-get update && sudo apt-get install shutter

site d'application: lien

Pour configurer Shutter comme outil par défaut pour prendre des captures d’écran lorsque vous appuyez sur PrtSc ou Alt + PrtSc, voici ce que vous devez faire:

gnome:

1 Allez dans Modifier ▸ Préférences dans Obturateur
 2 Dans l'onglet Clavier, activez à la fois les cases à cocher "Capture" et "Capture with selection":
  3 C'est ça! Maintenant, les raccourcis habituels PrtSc et Alt + PrtSc utiliseront Shutter pour prendre les captures d'écran.

    
réponse donnée speedox 03.04.2012 - 18:32
la source
0

Hey les gars cela pourrait aider, Je fouinais dans le menu gnome en remarquant qu'avec la nouvelle version de shutter permettant d'activer le raccourci clavier n'était pas aussi simple et que le démon iBus n'était pas démarré sur ma machine en mode "gnome fallback". Je l'ai trouvé en allant dans le menu gnome & gt; outils système & gt; Préférences & gt; Méthodes de saisie au clavier Je l'ai cliqué et l'ai lancé comme demandé par un dialogue et maintenant l'ImpressionCreen fonctionne. Bien que la boîte de dialogue utilisée dans l'unité n'apparaisse pas, j'ai trouvé qu'elle était enregistrée dans ~ / Pictures par défaut, donc pas de biggy, j'espère pouvoir aider quelqu'un car cela me frustrait aussi.

    
réponse donnée Matthew Sparks 17.01.2013 - 17:31
la source

Lire d'autres questions sur les étiquettes