Comment exécutez-vous un programme 32 bits sur une version 64 bits d'Ubuntu?

40

J'ai une version 64 bits d'Ubuntu 13.10. Je veux lancer une version 32 bits d'un programme. Cependant, je vois que ia32-libs n'est pas inclus dans 13.10. Existe-t-il un package de remplacement pour ceci ou quoi?

    
posée Cato 15.10.2013 - 01:18
la source

2 réponses

30

Il n’ya plus besoin du package ia32-libs (depuis 12.04 pour être exact), si vous utilisez le système APT, vous n’avez rien à craindre d’installer des paquets 32 bits dans un système 64 bits. Cela s’est produit depuis l’introduction de multiarch , l’une des politiques les plus changeantes de Debian dans la façon dont Debian gère les dépendances. Cette méthode permet d'avoir des cibles binaires différentes dans le même système sans souci de l'architecture du noyau. Cela ne signifie pas que vous pouvez exécuter tout package 32 bits sans préparation, mais si vous installez les bibliothèques / binaires, toutes les applications devraient en théorie pouvoir s'exécuter. Cela est vrai de 64 bits à 32 bits et vice versa.

Pour utiliser une telle méthode, il est recommandé d’utiliser les gestionnaires APT afin d’éviter les dépendances non satisfaites. Le journal des modifications comprend un petit historique sur la façon dont les modifications ont été apportées:

  1. Précisément, le paquet a été vidé et fait paquet transitoire . Il a été ajouté plusieurs dépendances par rapport aux paquets qui n’ont pas été déplacés vers multiarch.
  2. Lentement mais sûrement, tous les paquets ont été reconstruits avec le support multiarchie et les dépendances inverses ont été supprimées ou changées en ia32-lib-multiarch. Lorsque ces paquets ne nécessitent plus les paquets ia34-libs, les dépendances ont été supprimées en même temps. Les dépendances ont été modifiées de ia32-libs à package:arch étant package le nom de la bibliothèque nécessaire et arch l'architecture (ci-dessous un exemple avec skype).
  3. Avec la dernière version , le package ia32-libs-multiarch a été supprimé des versions de pré-enrichissement et ia32-libs ne sont pas publiés dans le monde entier. Tous les packages Ubuntu sont compatibles avec plusieurs partitions et vous pouvez installer différents packages d’architecture dans votre système.

Maintenant, lorsque vous installez un paquet qui nécessite des fichiers binaires 32 bits, si vous ne faites pas attention, vous ne saurez jamais que vous utilisez un paquet 32 ​​bits, car le gestionnaire de paquets va automatiquement extraire les dépendances nécessaires:

sudo apt-get --no-install-recommends -q -y install skype
Reading package lists...
Building dependency tree...
Reading state information...
The following extra packages will be installed:
  libaudio2:i386 libjbig0:i386 liblcms1:i386 libmng1:i386 libqt4-dbus:i386 libqt4-declarative:i386
  libqt4-network:i386 libqt4-opengl:i386 libqt4-script:i386 libqt4-sql:i386 libqt4-xml:i386
  libqt4-xmlpatterns:i386 libqtcore4:i386 libqtgui4:i386 libqtwebkit4:i386 libssl1.0.0:i386 libtiff5:i386
  libxss1:i386 libxv1:i386 skype-bin:i386
Suggested packages:
  nas:i386 liblcms-utils:i386 libqt4-declarative-folderlistmodel:i386 libqt4-declarative-gestures:i386
  libqt4-declarative-particles:i386 libqt4-declarative-shaders:i386 qt4-qmlviewer:i386 libqt4-dev:i386
  libthai0:i386 libicu48:i386 qt4-qtconfig:i386
Recommended packages:
  libqt4-sql-mysql:i386 libqt4-sql-odbc:i386 libqt4-sql-psql:i386 libqt4-sql-sqlite:i386 libcups2:i386
  sni-qt:i386 libasound2-plugins:i386
The following NEW packages will be installed:
  libaudio2:i386 libjbig0:i386 liblcms1:i386 libmng1:i386 libqt4-dbus:i386 libqt4-declarative:i386
  libqt4-network:i386 libqt4-opengl:i386 libqt4-script:i386 libqt4-sql:i386 libqt4-xml:i386
  libqt4-xmlpatterns:i386 libqtcore4:i386 libqtgui4:i386 libqtwebkit4:i386 libssl1.0.0:i386 libtiff5:i386
  libxss1:i386 libxv1:i386 skype skype-bin:i386
0 upgraded, 21 newly installed, 0 to remove and 0 not upgraded.
Need to get 33.9 MB/38.2 MB of archives.
After this operation, 118 MB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously unselected package libssl1.0.0:i386.
(Reading database ... 208485 files and directories currently installed.)
Unpacking libssl1.0.0:i386 (from .../libssl1.0.0_1.0.1c-4ubuntu8.1_i386.deb) ...
Selecting previously unselected package libaudio2:i386.
Unpacking libaudio2:i386 (from .../libaudio2_1.9.3-5ubuntu0.13.04.1_i386.deb) ...
Selecting previously unselected package liblcms1:i386.
Unpacking liblcms1:i386 (from .../liblcms1_1.19.dfsg-1.2ubuntu2_i386.deb) ...
Selecting previously unselected package libmng1:i386.
Unpacking libmng1:i386 (from .../libmng1_1.0.10-3build1_i386.deb) ...
Selecting previously unselected package libqtcore4:i386.
Unpacking libqtcore4:i386 (from .../libqtcore4_4%3a4.8.4+dfsg-0ubuntu9.4_i386.deb) ...
Selecting previously unselected package libqt4-xml:i386.
Unpacking libqt4-xml:i386 (from .../libqt4-xml_4%3a4.8.4+dfsg-0ubuntu9.4_i386.deb) ...
Selecting previously unselected package libqt4-dbus:i386.
Unpacking libqt4-dbus:i386 (from .../libqt4-dbus_4%3a4.8.4+dfsg-0ubuntu9.4_i386.deb) ...
Selecting previously unselected package libqt4-network:i386.
Unpacking libqt4-network:i386 (from .../libqt4-network_4%3a4.8.4+dfsg-0ubuntu9.4_i386.deb) ...
Selecting previously unselected package libqt4-script:i386.
Unpacking libqt4-script:i386 (from .../libqt4-script_4%3a4.8.4+dfsg-0ubuntu9.4_i386.deb) ...
Selecting previously unselected package libqt4-sql:i386.
Unpacking libqt4-sql:i386 (from .../libqt4-sql_4%3a4.8.4+dfsg-0ubuntu9.4_i386.deb) ...
Selecting previously unselected package libqt4-xmlpatterns:i386.
Unpacking libqt4-xmlpatterns:i386 (from .../libqt4-xmlpatterns_4%3a4.8.4+dfsg-0ubuntu9.4_i386.deb) ...
Selecting previously unselected package libjbig0:i386.
Unpacking libjbig0:i386 (from .../libjbig0_2.0-2ubuntu1_i386.deb) ...
Selecting previously unselected package libtiff5:i386.
Unpacking libtiff5:i386 (from .../libtiff5_4.0.2-4ubuntu2.1_i386.deb) ...
Selecting previously unselected package libqtgui4:i386.
Unpacking libqtgui4:i386 (from .../libqtgui4_4%3a4.8.4+dfsg-0ubuntu9.4_i386.deb) ...
Selecting previously unselected package libqt4-declarative:i386.
Unpacking libqt4-declarative:i386 (from .../libqt4-declarative_4%3a4.8.4+dfsg-0ubuntu9.4_i386.deb) ...
Selecting previously unselected package libqt4-opengl:i386.
Unpacking libqt4-opengl:i386 (from .../libqt4-opengl_4%3a4.8.4+dfsg-0ubuntu9.4_i386.deb) ...
Selecting previously unselected package libqtwebkit4:i386.
Unpacking libqtwebkit4:i386 (from .../libqtwebkit4_2.3.0-0ubuntu2_i386.deb) ...
Selecting previously unselected package libxss1:i386.
Unpacking libxss1:i386 (from .../libxss1_1%3a1.2.2-1_i386.deb) ...
Selecting previously unselected package libxv1:i386.
Unpacking libxv1:i386 (from .../libxv1_2%3a1.0.7-1ubuntu0.13.04.1_i386.deb) ...
Selecting previously unselected package skype-bin.
Unpacking skype-bin (from .../skype-bin_4.2.0.11-0ubuntu0.12.04.2_i386.deb) ...
Selecting previously unselected package skype.
Unpacking skype (from .../skype_4.2.0.11-0ubuntu0.12.04.2_amd64.deb) ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Setting up libssl1.0.0:i386 (1.0.1c-4ubuntu8.1) ...
Setting up libaudio2:i386 (1.9.3-5ubuntu0.13.04.1) ...
Setting up liblcms1:i386 (1.19.dfsg-1.2ubuntu2) ...
Setting up libmng1:i386 (1.0.10-3build1) ...
Setting up libqtcore4:i386 (4:4.8.4+dfsg-0ubuntu9.4) ...
Setting up libqt4-xml:i386 (4:4.8.4+dfsg-0ubuntu9.4) ...
Setting up libqt4-dbus:i386 (4:4.8.4+dfsg-0ubuntu9.4) ...
Setting up libqt4-network:i386 (4:4.8.4+dfsg-0ubuntu9.4) ...
Setting up libqt4-script:i386 (4:4.8.4+dfsg-0ubuntu9.4) ...
Setting up libqt4-sql:i386 (4:4.8.4+dfsg-0ubuntu9.4) ...
Setting up libqt4-xmlpatterns:i386 (4:4.8.4+dfsg-0ubuntu9.4) ...
Setting up libjbig0:i386 (2.0-2ubuntu1) ...
Setting up libtiff5:i386 (4.0.2-4ubuntu2.1) ...
Setting up libxss1:i386 (1:1.2.2-1) ...
Setting up libxv1:i386 (2:1.0.7-1ubuntu0.13.04.1) ...
Setting up libqtgui4:i386 (4:4.8.4+dfsg-0ubuntu9.4) ...
Setting up libqt4-declarative:i386 (4:4.8.4+dfsg-0ubuntu9.4) ...
Setting up libqt4-opengl:i386 (4:4.8.4+dfsg-0ubuntu9.4) ...
Setting up libqtwebkit4:i386 (2.3.0-0ubuntu2) ...
Setting up skype-bin (4.2.0.11-0ubuntu0.12.04.2) ...
Setting up skype (4.2.0.11-0ubuntu0.12.04.2) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

Notez que skype est un package i386. Si j'utilise apt-get pour l'installer, je me sauverai plus tard des maux de tête.

Mais certaines personnes préfèrent utiliser les paquets .deb , alors préparez-vous car cela peut être un peu compliqué. Vous devez installer manuellement toutes les dépendances afin que votre système ne se termine pas avec des dépendances non satisfaites. Une commande qui aidera sera dpkg-deb -I car elle affiche les informations du paquet:

dpkg-deb -I zynaddsubfx-dssi_2.4.3-3_amd64.deb 
 new debian package, version 2.0.
 size 266936 bytes: control archive=845 bytes.
     917 bytes,    19 lines      control              
     232 bytes,     3 lines      md5sums              
 Package: zynaddsubfx-dssi
 Source: zynaddsubfx
 Version: 2.4.3-3
 Architecture: amd64
 Maintainer: Ubuntu Developers <[email protected]>
 Original-Maintainer: Debian Multimedia Maintainers <[email protected]>
 Installed-Size: 633
 Depends: libasound2 (>= 1.0.16), libc6 (>= 2.15), libgcc1 (>= 1:4.1.1), libjack-jackd2-0 (>= 1.9.5~dfsg-14) | libjack-0.116, libmxml1, libstdc++6 (>= 4.6), zlib1g (>= 1:1.1.4)
[...]

Comme vous pouvez le voir, il répertorie les dépendances, vous devez donc les sudo apt-get install et sudo dpkg -i . Encore une fois, préférez installer les logiciels à partir des référentiels au lieu de les télécharger et de les installer manuellement avec dpkg -i .

Maintenant, si le votre est en développement, vous pouvez installer n'importe quelle bibliothèque en utilisant la syntaxe apt-get . Ajoutez simplement :i386 à la bibliothèque que vous souhaitez télécharger et faites. Vous n'avez pas besoin de le faire manuellement si vous installez le logiciel à partir des référentiels.

Bottom line: Non, vous pouvez exécuter des packages 32 bits sans installer ia32-libs , si vous installez les packages à partir des référentiels, encore mieux. Si vous êtes en développement, essayez de toujours utiliser le système APT.

    
réponse donnée Braiam 15.10.2013 - 02:22
la source
11

N'oubliez pas d'ajouter l'architecture i386 ou vous ne pourrez pas installer les packages 32 bits:

sudo dpkg --add-architecture i386
sudo apt-get update

Consultez le guide de dépannage du package: lien

    
réponse donnée 13m5 13.02.2014 - 15:18
la source

Lire d'autres questions sur les étiquettes