Impossible de se connecter après l'installation du pilote Nvidia v 14.04

29

J'ai installé avec succès des pilotes pour exécuter la carte graphique Nvidia 750 Ti sur mon bureau. Ubuntu a fonctionné parfaitement pendant une courte période après cela. Ensuite, le gestionnaire de mise à jour m'a invité à installer certaines mises à jour. Je l'ai fait et j'ai redémarré. Après cela, lorsque j'essaie de me connecter, l'écran clignote et revient à la connexion. J'ai essayé plusieurs autres guides qui résolvent des problèmes similaires, mais aucun d'entre eux n'a aidé.

Je suis dual boot Windows 8 et Ubuntu 14.04.

    
posée Zachary Landry 17.05.2015 - 20:10
la source

12 réponses

14

Cela se produit lorsque vous installez des pilotes Nvidia à l’aide d’un fichier .run, téléchargé depuis le site Nvidia. C'est une mauvaise façon d'installer les pilotes. Après chaque mise à jour du noyau, vous devrez les réinstaller à l'aide de la console, car l'interface graphique ne démarrera pas. Maintenant, vous pouvez le réparer en allant sur la console en appuyant sur Ctrl + Alt + F1. Ensuite, connectez-vous et lancez

sudo apt-get purge nvidia*
sudo apt-get install nvidia-331

Puis redémarrez.

Si cela ne fonctionne pas, vous devez désinstaller le pilote. Vous pouvez consulter ICI pour obtenir des instructions.

    
réponse donnée Pilot6 17.05.2015 - 20:15
la source
8

Malheureusement, mon expérience est la suivante:

sudo apt-get purge nvidia*
sudo apt-get install nvidia-current

n'est pas garanti pour fonctionner.

Malheureusement, il est également vrai que les mises à jour du noyau et les mises à jour des pilotes xorg ou d’autres pilotes graphiques brisent souvent l’installation du pilote propriétaire.

Je suis venu pour utiliser ce schéma:
1. Au fur et à mesure que des mises à jour sont annoncées, vérifiez le type de paquets ci-dessus.
2. si aucun n'est inclus dans la mise à jour, laissez-les entrer, plus besoin d'actions.
3. s'il y a des mises à jour "risquées", alors:

Appuyez sur CTRL-ALT-F1, connectez-vous puis tapez

sudo -i
stop lightdm
init 3
cd /to/dir/with/NVIDIA.run-file/
bash NVIDIA-CURRENTLY-INSTALLED-VERSION.run --uninstall
apt-get update && apt-get upgrade

s'il y avait une mise à jour de KERNEL; entrez reboot
 et redémarrer avec le nouveau noyau dans mode de récupération , puis ...

cd /to/dir/with/NVIDIA.run-file/
bash NVIDIA-NEW-or-PREVIOUS-INSTALLED-VERSION.run
reboot

Je recommande également de mettre à jour le noyau 3.16 afin de contourner les nombreuses mises à jour du noyau 3.13.
Suivez les instructions pour Trusty ici:
lien

REMARQUE: évitez les noyaux ultérieurs, c’est-à-dire jusqu’à ce qu’un support similaire leur soit apporté.

    
réponse donnée Hannu 17.05.2015 - 21:14
la source
4

La cause est que lorsque vous mettez à jour quelque chose lié à .Xauthority avec sudo, root possédera ce fichier et vous ne pouvez pas vous connecter en tant qu'utilisateur. Appuyez simplement sur Ctrl + Alt + F2, connectez-vous avec votre nom d'utilisateur et

sudo chown [your_username] /home/[your_username]/.Xauthority
    
réponse donnée Finn 17.03.2016 - 03:02
la source
3

Les pilotes Nvidia installent et enregistrent le code avec dkms. Cela ne fait pas partie de l'installation standard pour le bureau Ubuntu, mais si dkms n'est pas installé, chaque mise à jour du noyau peut potentiellement casser à nouveau les pilotes Nvidia.

Pour éviter cela, vous pouvez installer "dkms" vous-même:

sudo apt-get install dkms

Après avoir installé dkms, réinstallez les pilotes Nvidia à l’aide du fichier d’exécution. Ils pourront enregistrer les pilotes pour la recompiler lorsque de nouveaux noyaux seront installés.

    
réponse donnée Steve Graham 02.12.2015 - 22:03
la source
0

J'ai rencontré un problème similaire après avoir installé le pilote nvidia-304, et pour essayer de faire fonctionner ce composant, j'ai apporté quelques modifications qui ont permis à mon Ubuntu de se connecter à l'infini.

J'ai donc essayé toutes les méthodes mentionnées ici, mais rien n'a fonctionné. Par conséquent, j'ai commencé à suivre toutes les modifications apportées plus tôt. Enfin, la solution trouvée a été les modifications apportées à "update-alternatives".

Hit: Ctrl + Alt + F1 et connectez-vous à tty1

sudo update-alternatives --install /etc/ld.so.conf.d/i386-linux-gnu_GL.conf i386-linux-gnu_gl_conf /usr/lib/i386-linux-gnu/mesa/ld.so.conf 500

et

sudo update-alternatives --install /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf x86_64-linux-gnu_gl_conf /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf 500

J'espère que ça aide.

    
réponse donnée Aman Agrawal 21.03.2016 - 05:48
la source
0

J'ai eu un problème similaire ( apt-get upgrade et à peu près tout est cassé) au cours des derniers jours. Voici mes apprentissages. J'espère qu'ils peuvent aider quelqu'un là-bas.

J'utilise Ubuntu 14.04 sur plusieurs machines et ma solution a fonctionné sur toutes les machines une fois que je l'ai trouvée: P

Tout d’abord, la mise à jour simultanée des pilotes graphiques et du noyau peut poser problème si les modules du noyau graphique sont conçus pour le noyau en cours d’exécution, car le noyau changera après le redémarrage.

Après avoir bricolé pendant quelques heures, c'était ma solution (sur un ordinateur de bureau, en utilisant uniquement la carte graphique Nvidia installée, donc pas besoin de bumblebee ou primus ).

Symptôme: chaque fois que j'ai redémarré lightdm ( service lightdm restart ), le pilote utilisait mesa , donc ne pas utiliser le pilote Nvidia que j'avais installé / mis à jour. Le message en /var/log/Xorg.0.log était qu'il ne pouvait pas charger nvidia_drv.so ) pour vérifier:

update-alternatives --get-selections # lists all alternatives
update-alternatives --config x86_64-linux-gnu_gl_conf # available options and lets you choose "0" to automatically select the best driver
update-alternatives --config i386-linux-gnu_gl_conf # for multiarch or i386 machines

Exemple:

update-alternatives --config x86_64-linux-gnu_gl_conf
There are 3 choices for the alternative x86_64-linux-gnu_gl_conf (providing /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf).

  Selection    Path                                       Priority   Status
------------------------------------------------------------
* 0            /usr/lib/nvidia-340/ld.so.conf              8604      auto mode
  1            /usr/lib/nvidia-340-prime/ld.so.conf        8603      manual mode
  2            /usr/lib/nvidia-340/ld.so.conf              8604      manual mode
  3            /usr/lib/x86_64-linux-gnu/mesa/ld.so.conf   500       manual mode

Résultat: même après l'avoir défini explicitement sur "auto", une fois le démarrage effectué, lightdm le réinitialiserait au pilote mesa , ce qui peut être vu dans /var/log/alternative.log .

La solution

service lightdm stop
# remove all old stuff
apt-get remove --purge nvidia\*
apt-get remove --purge bumblebee
apt-get remove --purge primus primus-libs
apt-get autoremove --purge
# unload old drivers from kernel
rmmod nvidia
rmmod drm
# now everything is gone. Make sure you are running the latest kernel, then:
apt-get install nvidia-XXX # nvidia-367 for me, nvidia-current fits generally
update-alternatives --auto x86_64-linux-gnu_gl_conf
update-alternatives --auto i386-linux-gnu_gl_conf
service lightdm start

Et voila, /var/log/Xorg.0.log montre qu'il charge libglx et nvidia_drv de la société NVIDIA. glxinfo vérifie cela.

    
réponse donnée DrPsychick 08.11.2016 - 02:18
la source
0

Mon expérience est la suivante:

J'ai découvert la raison pour laquelle je n’ai pas pu me connecter après l’installation du pilote nvidia car mon pilote d’affichage est défini sur un pilote NVIDIA obtenu par Ubuntu. Je suppose qu'un conflit survient lorsque l'installateur ne peut pas écraser la configuration d'Ubuntu.

La solution consiste à définir l’affichage sur le pilote d’affichage Noveau, puis à procéder à l’installation avec le fichier * .run.

    
réponse donnée arjepak 15.01.2017 - 08:29
la source
0

Je viens d'avoir le même problème après une mise à jour du pilote Nvidia ... Pour résoudre le problème, j'ai redémarré en utilisant le mode de récupération:

  1. Lorsque le menu GRUB est apparu, j'ai sélectionné "Options avancées"
  2. Dans la liste, j'ai sélectionné l'option du mode de récupération:

    Ubuntu GNU/Linux, with Linux 3.8.0-26-generic (recovery mode)
    
  3. J'ai sélectionné l'option:

    Drop to root shell prompt
    
  4. Ensuite, j'ai fait ce que @ Pilot6 a suggéré: suppression de tous les pilotes nvidia:

    apt-get purge nvidia*
    

    Tant que vous êtes connecté en tant que root, vous n'avez pas besoin de sudo

  5. Ensuite, j'ai redémarré et renvoyé le pilote du matériel actuellement disponible.

    sudo apt-get install nvidia-current
    

Cela fonctionne bien jusqu'à présent ... J'espère que cela vous aide.

Plus d’informations sur le mode de récupération que vous pouvez trouver dans cet article: RecoveryMode

    
réponse donnée emilius 23.08.2015 - 19:13
la source
0

Une autre façon temporaire de continuer le travail est:

  1. au démarrage, choisissez recovery mode , puis

  2. dans le menu de récupération choisissez Resume normal boot

Après cela, vous pourrez vous connecter:)

    
réponse donnée vrshntr 09.11.2017 - 18:24
la source
0

Appuyez sur CTRL - ALT - F1 sur le terminal

Désinstallez les pilotes précédents:

sudo apt-get remove nvidia-*
sudo apt-get autoremove

Retour à l'interface graphique par:

sudo service lightdm restart
    
réponse donnée ccy 03.03.2018 - 14:29
la source
0

J'ai un eMachines T5254 avec une carte graphique Nvidia GeForce 6100. De temps en temps (probablement lorsque je reçois un nouveau noyau), l'ordinateur démarrera sur un écran noir avec ce qui devrait être l'écran de connexion. Mon correctif de travail a été de

  1. Sur l'écran noir, appuyez sur ctrl + alt + F1 (ou sur celle qui ne correspond pas à ma session en cours) et utilisez:

    sudo apt-get purge nvidia-*

  2. Reboot en mode sans échec (contenant shift sur l'écran du BIOS), sélectionnez Options avancées, puis Mode récupération. Vous devrez peut-être sélectionner une ancienne version du noyau.

  3. Sélectionnez le mode graphique sécurisé. (Pour ma part, après l'avoir sélectionné, je suis renvoyé à l'écran principal du mode de récupération et je sélectionne Boot Normally. Je pense qu'il s'agit d'un bogue, mais il se charge en tout temps en mode graphique sécurisé.

  4. Le gui devrait charger maintenant (pas le correctif, évidemment). Accédez à la fenêtre Paramètres système. Cliquez sur Logiciel et mises à jour. À la fin, il y a des pilotes supplémentaires. Lorsque le chargement est terminé, cela me donne quatre options. Les deux premiers sont pour les pilotes Nvidia ver 304, le troisième pour le ver 170 et le dernier est un pilote générique. Le seul qui fonctionne est le ver 170. Sélectionnez-le, attendez que la mise à jour se télécharge et redémarre.

Je suppose que cela est possible via la ligne de commande, mais je n'ai trouvé aucun guide en ligne traitant de cette question. J'espère que cela sera utile à quelqu'un d'autre.

    
réponse donnée Sampsimus 02.01.2016 - 22:05
la source
0

J'ai trouvé la même chose. La formule que j'ai utilisée consistait à désinstaller les pilotes NVIDIA via cette méthode: Hit Ctrl + Alt + F4 pour vous connecter via tty4

sudo apt-get purge nvidia*
sudo apt-get install nvidia-331
sudo service lightdm stop
sudo apt-get install gdm

J'ai aussi utilisé

sudo dpkg -reconfigure gdm

L'écran de connexion est différent. Mais j'ai pu me connecter sans être exclu de la méthode de connexion de l'interface graphique.

Pas parfait mais au moins j'ai pu me connecter à nouveau.

    
réponse donnée Andy Despres 09.02.2016 - 05:03
la source

Lire d'autres questions sur les étiquettes