Ces erreurs SATA sont-elles dangereuses?

30

Je reçois ces erreurs par hasard, et je ne sais pas si c'est normal ou non.

[39441.061856] ata3.00: failed to read SCR 1 (Emask=0x40)
[39441.061866] ata3.01: failed to read SCR 1 (Emask=0x40)
[39441.061892] ata3.15: exception Emask 0x10 SAct 0x0 SErr 0x280100 action 0x6 frozen
[39441.061897] ata3.15: irq_stat 0x08000000, interface fatal error
[39441.061904] ata3.15: SError: { UnrecovData 10B8B BadCRC }
[39441.061910] ata3.00: exception Emask 0x100 SAct 0x0 SErr 0x0 action 0x6 frozen
[39441.061917] ata3.01: exception Emask 0x100 SAct 0xe SErr 0x0 action 0x6 frozen
[39441.061923] ata3.01: failed command: READ FPDMA QUEUED
[39441.061933] ata3.01: cmd 60/a8:08:b0:48:62/00:00:00:00:00/40 tag 1 ncq 86016 in
[39441.061940] ata3.01: status: { DRDY }
[39441.061944] ata3.01: failed command: READ FPDMA QUEUED
[39441.061953] ata3.01: cmd 60/a8:10:b0:49:62/00:00:00:00:00/40 tag 2 ncq 86016 in
[39441.061959] ata3.01: status: { DRDY }
[39441.061963] ata3.01: failed command: READ FPDMA QUEUED
[39441.061972] ata3.01: cmd 60/58:18:58:4a:62/00:00:00:00:00/40 tag 3 ncq 45056 in
[39441.061978] ata3.01: status: { DRDY }
[39441.061987] ata3.15: hard resetting link
[39441.608302] ata3.15: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[39441.609090] ata3.00: hard resetting link
[39441.929246] ata3.00: SATA link up 3.0 Gbps (SStatus 123 SControl 320)
[39441.929333] ata3.01: hard resetting link
[39442.249184] ata3.01: SATA link up 3.0 Gbps (SStatus 123 SControl 320)
[39442.263242] ata3.00: configured for UDMA/133
[39442.277570] ata3.01: configured for UDMA/133
[39442.277725] ata3: EH complete

Je colle également smartctl -a pour sda , sdb et sdc .

Merci d'avance pour votre aide.

    
posée Marcos Junior 08.05.2012 - 19:15
la source

9 réponses

13

Bien que je sois essentiellement d’accord avec la réponse de Geppettvs D'Constanzo , je suggérerais que certaines des premières choses essayez sont

  1. Vérifier que votre câble SATA est correctement connecté et branché sur les connecteurs de la carte mère et du disque dur.

  2. Remplacement de votre câble SATA. Les câbles SATA sont (relativement) peu coûteux et vous obtenez parfois un câble " bad ". Le simple remplacement du câble est souvent le moyen le plus simple de diagnostiquer et de résoudre un problème comme celui-ci.

(Bien qu’il soit quelque peu inattendu que deux câbles soient tous les deux en même temps. Cependant, c’est une chose facile à vérifier. Je pense que cela en vaut probablement la peine.)

Je viens de vous voir des pastbins contenant les données SMART pour vos lecteurs. Notez le grand nombre inattendu d'erreurs CRC pour les lecteurs sdb et sdc . Je vous suggère de commencer par vérifier les câbles et les connexions de ces lecteurs.

[email protected]:/$ sudo  smartctl -a /dev/sda
...
Model Family:     SAMSUNG SpinPoint M7E (AFT)
Device Model:     SAMSUNG HM321HI
...
199 UDMA_CRC_Error_Count    0x0036   200   200   000   Old_age  Always -    0

[email protected]:/$ sudo  smartctl -a /dev/sdb
...
Model Family:     SAMSUNG SpinPoint F4 EG (AFT)
Device Model:     SAMSUNG HD204UI
...
199 UDMA_CRC_Error_Count    0x0036   100   100   000   Old_age  Always  -  57

[email protected]:/$ sudo  smartctl -a /dev/sdc
...
Model Family:     SAMSUNG SpinPoint F4 EG (AFT)
Device Model:     SAMSUNG HD204UI
...
199 UDMA_CRC_Error_Count    0x0036   100   100   000   Old_age  Always  - 398

OK. Donc, pas une latpop alors. ;-)
Bien sûr, si cela se produit sur un ordinateur portable, rien de ce qui précède ne s'applique et je ne suis pas sûr du conseil à offrir. Peut-être supprimer et réinstaller le disque dur? Peut-être faut-il simplement le réinstaller dans son socket pour améliorer la connexion?

sbd et sdc sont connectés sur le même câble e-sata externe (Thermaltake Duo HDD Dock). Je remplacerai mon câble e-sata.

Cela pourrait être dû à un câble défectueux ou de mauvaise qualité. Il se peut également que le câble soit déplacé, heurté ou bousculé d’une manière ou d’une autre pendant l’utilisation du lecteur.

    
réponse donnée irrational John 08.05.2012 - 22:33
la source
9

Il semble que vous ayez un câble d'alimentation / de données SATA endommagé / de mauvaise qualité. Qui peut être à l'origine de mauvais CRC. Ils ne sont pas dangereux du tout et vous pouvez vivre avec eux, mais vous allez bientôt perdre beaucoup de données.

Le rapport SMART de vos disques durs est sain, donc je suis pour des problèmes d'alimentation en fonction de mon expérience lors de la configuration de 5 disques durs dans le même boîtier / la même source d'alimentation. J'ai fini d'utiliser une source d'alimentation externe (475 W) pour 2 disques et le boîtier de 600 W pour tous les boîtiers, y compris les unités GPU, optiques et les disques durs.

Quoi qu’il en soit, je vous suggère de lancer une sauvegarde complète avant de faire autre chose. Si possible, clonez votre disque dur, après quoi vous devriez vérifier les câbles et les tensions d'alimentation.

    
réponse donnée Geppettvs D'Constanzo 08.05.2012 - 19:42
la source
3

Il semble y avoir un problème entre certaines versions du noyau et certains contrôleurs SATA.

J'ai récemment commencé à avoir un problème très similaire (je ne sais pas si c'est pareil) sur un serveur Web exécutant Scientific Linux.

L'information la plus précise et la plus complète que j'ai trouvée sur ce problème est ce bug .

En bref: La désactivation de NCQ semble être la meilleure solution pour les utilisateurs ayant ce problème. .

    
réponse donnée jap1968 31.12.2012 - 14:51
la source
0

C'est presque toujours un mauvais disque, j'ai des milliers de disques que nous utilisons et bien que ces erreurs ne provoquent jamais l'échec du disque, elles ont entraîné une corruption du système de fichiers. Je pense que cela a vraiment à voir avec un problème avec la carte contrôleur sur le lecteur.

J'ai tout essayé pour résoudre ce problème, le correctif est de remplacer le lecteur et tout fonctionne sur les mêmes câbles et contrôleurs.

Bonne chance

    
réponse donnée user209235 29.10.2013 - 20:42
la source
0

Je sais que ce sujet est ancien mais j'ai récemment rencontré le même problème sur une machine nouvellement achetée avec 6 slots sata. J'ai installé le cdrom et le hardrive sur 2 slots sata proches l'un de l'autre et ensuite procédé à l'installation d'ubuntu sans erreurs jusqu'à ce que je redémarre puis j'ai vu le ata8: erreur de lien de réinitialisation matérielle. La machine s'arrête jusqu'à ce point n'a jamais récupéré. J'ai essayé de redémarrer à plusieurs reprises et cela n'a pas fonctionné. Et puis j'ai essayé de remplacer le hardrive sur l'un des 4 emplacements disponibles et cela a fonctionné très bien sans tracas.

    
réponse donnée ultrajohn 11.07.2014 - 13:42
la source
0

J'ai eu le même problème - dans mon cas, cela était dû au fait que l’adaptateur secteur 4 broches vers SATA n’était pas bien branché.

    
réponse donnée Andrei Pokrovsky 27.05.2015 - 06:54
la source
0

Cette erreur est dangereuse et peut endommager votre disque dur.

Pour le résoudre:

  1. Remplacez le câble SATA.
  2. Si l'erreur persiste, branchez le câble SATA sur un autre support de la carte mère (le connecteur actuel pourrait s'oxyder).
  3. Si l’erreur persiste, le problème devrait être sur votre bloc d’alimentation.

lien

    
réponse donnée josircg 26.12.2016 - 12:27
la source
0

J'ai eu le même problème. J'avais tout essayé, mais seulement sur le port micron de mon asus p5k, je n'avais pas les erreurs.

Mais quand j'ai mis le lecteur sur un autre bloc d'alimentation, cela a fonctionné et les erreurs ont disparu. Ensuite, je remets le lecteur dans son alimentation d'origine, mais avec un nouveau connecteur d'alimentation et cela a également fonctionné.

    
réponse donnée Martin Van Der Meulen 05.01.2017 - 19:55
la source
0

Je sais que ce sujet est ancien, mais vient de tomber sur le même problème, venu de Google.

  • obtenir ata3.01: failed command: READ FPDMA QUEUED au démarrage du livecd KUBUNTU 16.04.
  • WINDOWS 7 se comportera de manière erratique, fonctionne correctement pendant un certain temps, mais se fige après avoir regardé youtube.

Changer le câble SATA n’a rien fait.
Remplacé le PSU et le problème a disparu.

    
réponse donnée marco_roboto 12.02.2017 - 10:59
la source

Lire d'autres questions sur les étiquettes