apt-get est bloqué à "XXKb récupéré dans XXsec" [dupliquer]

35

J'ai essayé d’installer crossover et après avoir téléchargé le fichier .deb de leur site Web, j’ai suivi les étapes indiquées lors de son ouverture avec Ubuntu Software Center:

  

Sur les versions 64 bits de Debian et certaines variantes d'Ubuntu, ouvrez d'abord un   terminal et exécutez sudo dpkg --add-architecture i386 ; sudo apt-get update

Depuis que j'ai Ubuntu 16.04 LTS 64 bit, j'exécute la commande.

Mais lors de la copie et du collage de cette commande dans mon terminal, celle-ci s'est arrêtée à la recherche de 535 Ko en 7 secondes et est restée bloquée pendant environ 20 minutes. J'ai fini par le fermer et j'ai essayé d'exécuter les deux commandes séparément, mais après avoir exécuté la commande sudo apt-get update , il se bloque à nouveau après "Récupération de XXKb dans XXsec".

J'ai redémarré mon ordinateur et décidé de lancer le logiciel de mise à jour, qui reste bloqué à environ 75% pendant des heures.

    
posée Steve 20.05.2016 - 01:04
la source

3 réponses

51

C'est un bogue connu et a été corrigé. A partir d'un commentaire dans l'outil de suivi des bogues, l'installation manuelle des packages suivants le problème, du moins pour moi (les URL sont pour amd64, ajuster les URL pour les autres architectures):

cd /tmp && mkdir asfix
cd asfix
wget https://launchpad.net/ubuntu/+archive/primary/+files/appstream_0.9.4-1ubuntu1_amd64.deb
wget https://launchpad.net/ubuntu/+archive/primary/+files/libappstream3_0.9.4-1ubuntu1_amd64.deb
sudo dpkg -i *.deb
cd ..
rm -r asfix
    
réponse donnée hrzhu 20.05.2016 - 04:54
la source
7

Le bogue a été corrigé. Les packages peuvent être téléchargés et installés en ouvrant un terminal (appuyez sur Ctrl + Alt + T ) et exécuter les trois commandes suivantes:

wget http://launchpadlibrarian.net/259142419/libappstream3_0.9.4-1ubuntu1_amd64.deb http://launchpadlibrarian.net/259142413/gir1.2-appstream_0.9.4-1ubuntu1_amd64.deb http://launchpadlibrarian.net/259142412/appstream-index_0.9.4-1ubuntu1_all.deb http://launchpadlibrarian.net/259142418/appstream_0.9.4-1ubuntu1_amd64.deb
sudo dpkg -i libappstream3_0.9.4-1ubuntu1_amd64.deb gir1.2-appstream_0.9.4-1ubuntu1_amd64.deb appstream-index_0.9.4-1ubuntu1_all.deb appstream_0.9.4-1ubuntu1_amd64.deb
sudo apt update
    
réponse donnée Paulo Henrique 20.05.2016 - 04:17
la source
1

J'ai rencontré un problème similaire (coincé apt update le 16.04, 2x apistreamcli à 100%), mais cela n'était lié à aucune installation particulière.

Pour moi, c'était suffisant pour kill -sigterm les processus apistreamcli bloqués. Après cela, apt update && apt upgrade a encore travaillé sans problèmes.

    
réponse donnée jan groth 21.05.2016 - 10:47
la source

Lire d'autres questions sur les étiquettes