Supprimer evolution-calendar-factory du démarrage

29

Existe-t-il un moyen de le supprimer du démarrage?
Je n'en ai pas besoin et je n'utilise pas du tout l'évolution.

    
posée Yehonatan Tsirolnik 09.06.2014 - 09:15
la source

7 réponses

1

Ubuntu ne vous permettra pas de supprimer evolution-calendar-factory car il s’agit d’une bibliothèque partagée par de nombreux programmes.

Si vous essayez d’exécuter: sudo apt-get purge evolution-data-server ou sudo apt-get remove evolution-data-server votre système sera cassé!

Vous pouvez tester ces commandes dans le terminal en utilisant l’indicateur -s (simulate) (faites attention!)

sudo apt-get remove evolution-data-server -s

Et vous verrez que ubuntu-gnome-desktop serait supprimé, et après le prochain redémarrage, vous ne pourrez plus vous connecter au système. : (

Alors, ne supprimez pas evolution-data-server .

    
réponse donnée enoquenroll 13.12.2014 - 03:09
la source
18

Je n’avais pas encore installé Evolution, mais cela fonctionnait toujours aussi.

Supprimez le package evolution-data-server via Software Center. Ou tapez ceci dans un terminal: sudo apt-get purge evolution-data-server . Puis déconnectez-vous et remettez-le en place, il devrait être parti.

    
réponse donnée Aibara 04.07.2014 - 19:37
la source
17

Si vous souhaitez supprimer evolution-data-server , il les supprimera au minimum (testé en 16.04)

The following packages will be REMOVED:
  evolution-data-server gdm3 gnome-contacts gnome-shell libfolks-eds25
0 upgraded, 0 newly installed, 5 to remove and 378 not upgraded.
After this operation, 15.8 MB disk space will be freed.

Alors, le meilleur traitement est un peu méchant, mais ça marche!

Nasty Hack!

Renommez le dossier binaire Evolution pour qu'il ne soit pas trouvé! Ce qui fonctionne pour moi, ce sont ces

sudo mv /usr/lib/evolution-data-server /usr/lib/evolution-data-server-disabled
sudo mv /usr/lib/evolution /usr/lib/evolution-disabled

C'est ça! Maintenant, je peux au moins utiliser le système.

Notes: Si vous désactivez l’évolution de cette façon, vous ne pourrez pas utiliser les synchronisations de calandres ou d’autres fonctionnalités (inutiles pour moi).

Piratage moins sale (mise à jour)

On dirait que de plus en plus de gens ne sont pas satisfaits de l’évolution ces derniers temps. Mais dans ma configuration actuelle, je ne renomme pas le dossier. Au lieu de cela, je retire simplement le bit exécutable et ça marche.

Pour désactiver le processus de calendrier, j'ai utilisé

sudo chmod -x /usr/lib/evolution/evolution-calendar-factory

La bonne chose avec cette méthode est que le service d’évolution peut toujours fonctionner (ils démarrent et fonctionnent)

Répétez le même processus pour evolution-source-registry et evolution-addressbook-factory si vous souhaitez les fermer également!

    
réponse donnée Anwar 24.08.2016 - 19:50
la source
3

Si vous utilisez Gnome ou Gnome-Shell, il semble que vous ne puissiez pas supprimer evolution-data-server, car il supprimera également l'intégralité de DE

[email protected]:/home/user# apt remove evolution-data-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
evolution-data-server gdm3 gnome-contacts gnome-shell gnome-shell-extension-weather gnome-shell-extensions libfolks-eds25
0 upgraded, 0 newly installed, 7 to remove and 6 not upgraded.
After this operation, 17,5 MB disk space will be freed.
Do you want to continue? [Y/n] n

Si vous voulez toujours vous débarrasser de ces processus ennuyeux et gourmands en ressources, vous pouvez simplement supprimer (ou mieux renommer) le répertoire de leurs exécutables:

[email protected]:/home/user# mv /usr/lib/evolution /usr/lib/evolution_DISABLE

Puis tuez tous les processus en cours d'exécution:

[email protected]:/home/user# for procname in $(ps aux | grep evolution | awk -F'/' '{print $NF}' | grep evolution | grep -v grep); do killall $procname; done

Ainsi, Gnome ne pourra plus les redémarrer.

Travaillé pour moi sans aucun dommage collatéral visible.

    
réponse donnée MariusPontmercy 24.08.2016 - 19:34
la source
2

Donc, si vous pensez que les réponses ci-dessus sont trop toxiques pour votre système (en supprimant les prérequis de gnome-desktop, en supprimant / en renommant les fichiers packagés? Non, merci!), j'ai peut-être une solution pour vous.

Créez ~/.config/upstart/kill-evolution-services.conf et remplissez-le avec le code suivant. Assurez-vous de remplacer USER par votre nom d'utilisateur.

start on desktop-start
stop on desktop-end

script
  ME=USER
  GIVEUP=60
  while ! pgrep -u "$ME" -f '^/usr/lib/evolution/evolution'; do
    GIVEUP=$((GIVEUP - 1))
    if test $GIVEUP = 0; then
      break
    fi
    sleep 1
  done
  pkill -u "$ME" -f '^/usr/lib/evolution/evolution'
end script

Cela fonctionnera lors de la connexion, attendez que les services d’évolution aient démarré (jusqu’à 60 ans, ajustables avec GIVEUP), puis tuez-les. D'après ce que j'ai vu (16.04), ils resteront morts jusqu'à ce que vous interagissiez avec certaines applications qui en ont besoin, comme gnome-calendar (l'application, pas l'indicateur). Pour contrer cela, vous pouvez ajouter ce qui suit à crontab (lancez "crontab -e" depuis le terminal). Encore une fois, assurez-vous de remplacer USER par votre nom d'utilisateur.

*/1 * * * * pkill -u USER -f '^/usr/lib/evolution/evolution'

Cela va essayer de tuer les services d’évolution une fois par minute.

Nous nous sommes donc débarrassés des services d’évolution sans rendre fous ni même appeler sudo . Les problèmes d’utilisation de la mémoire avec ces services auraient été résolus dans Gnome 3.20, mais Ubuntu n’a pas encore réussi à les ramener à 3.18. Gardez un œil sur lien , même si cela n'a rien à voir avec indicateur- datetime, d'après ce que je peux dire. L'indicateur fonctionne bien sans les services d'évolution à la connexion lightdm, de toute façon.

Si cela finit par avoir des effets secondaires sur votre configuration, vous pouvez simplement supprimer ~/.config/upstart/kill-evolution-services.conf et supprimer la ligne crontab (encore une fois, crontab -e d'un terminal). Si vous êtes paranoïaque, déconnectez-vous et reconnectez-vous pour faire bonne mesure.

    
réponse donnée Trent Nelson 18.03.2017 - 20:04
la source
2

Vous pouvez masquer les unités en utilisant systemd (testé sur Ubuntu 18.04, Unity):

systemctl --user mask evolution-addressbook-factory.service evolution-calendar-factory.service evolution-source-registry.service

Après la déconnexion / connexion, les services ne seront plus lancés.

    
réponse donnée Marco Biscaro 26.04.2018 - 20:50
la source
0

Je n'ai pas essayé de le supprimer depuis que je lance gnome, mais ce qui a fonctionné a été de copier les fichiers d'unité systemd dans / etc et de définir ExecStart sur / bin / ls:

cp /usr/lib/systemd/user/evolution-calendar-factory.service /etc/systemd/user/
cp /usr/lib/systemd/user/evolution-source-registry.service /etc/systemd/user/

et dans le fichier d'unité assurez-vous que ExecStart est / bin / ls:

ExecStart=/bin/ls

Alors fais

systemctl --user daemon-reload
systemctl --user restart evolution-source-registry
systemctl --user restart evolution-calendar-factory

Notez que faire "systemctl disable --user evolution-source-registry" semblait n'avoir aucun effet.

    
réponse donnée perl2012 08.11.2017 - 14:01
la source

Lire d'autres questions sur les étiquettes